summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorDavid Sommerseth <davids@redhat.com>2013-09-12 17:01:59 +0200
committerDavid Sommerseth <davids@redhat.com>2013-09-12 17:01:59 +0200
commitd9922c0cf642da50794c3d23b61dcdd49684af8e (patch)
treef569204632cb7f7fd5b32198f1842438372e1542 /setup.py
parentc61363e517154548f0b85772e1f83186dff898bc (diff)
downloadpython-ethtool-d9922c0cf642da50794c3d23b61dcdd49684af8e.tar.gz
python-ethtool-d9922c0cf642da50794c3d23b61dcdd49684af8e.tar.xz
python-ethtool-d9922c0cf642da50794c3d23b61dcdd49684af8e.zip
Migrated from libnl-1 to libnl-3
This ports the current functionality from libnl-1 to libnl-3.0. At the current stage, it should be functional but more patches cleaning up the code will come. Signed-off-by: David Sommerseth <davids@redhat.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 3 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 99dc718..6bf992d 100644
--- a/setup.py
+++ b/setup.py
@@ -4,7 +4,7 @@ from distutils.core import setup, Extension
import commands
import sys
-version = '0.8'
+version = '0.9'
def pkgconfig(pkg):
def _str2list(pkgstr, onlystr):
@@ -43,7 +43,8 @@ def pkgconfig(pkg):
}
-libnl = pkgconfig('libnl-1')
+libnl = pkgconfig('libnl-3.0')
+libnl['libs'].append('nl-route-3')
# don't reformat this line, Makefile parses it
setup(name='ethtool',