summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e6eaa5e..2e84238 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -23,6 +23,14 @@ IF(EUREPHIADM)
SET(ADMIN_ENABLED on)
ENDIF(EUREPHIADM)
+IF(ADMIN_ENABLED)
+ find_package(PkgConfig)
+ pkg_search_module(LIBXML2 REQUIRED libxml-2.0 libxml2 libxml>=2.6)
+ INCLUDE_DIRECTORIES(BEFORE ${LIBXML2_INCLUDE_DIRS})
+ ADD_DEFINITIONS(-DHAVE_LIBXML2)
+ SET(EXTRA_LIBS ${LIBXML2_LIBRARIES})
+ENDIF(ADMIN_ENABLED)
+
IF(NOT DATABASE)
message(FATAL_ERROR "Cannot build eurephia without any database drivers.")
ENDIF(NOT DATABASE)