summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Sommerseth <dazo@users.sourceforge.net>2008-12-13 19:40:31 +0100
committerDavid Sommerseth <dazo@users.sourceforge.net>2008-12-13 19:40:31 +0100
commite2a63248399aaff5605316702f9085ceda0ef8c5 (patch)
treeb3cbc1a330bc0a0a5ae0ac29130b7b5767056711 /CMakeLists.txt
parentb140ce52fd1f705f4acd7b91347eb2f584c45460 (diff)
downloadeurephia-e2a63248399aaff5605316702f9085ceda0ef8c5.tar.gz
eurephia-e2a63248399aaff5605316702f9085ceda0ef8c5.tar.xz
eurephia-e2a63248399aaff5605316702f9085ceda0ef8c5.zip
Moved libxml2 check from edb-sqlite to the global CMakeLists.txt
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e6eaa5e..2e84238 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -23,6 +23,14 @@ IF(EUREPHIADM)
SET(ADMIN_ENABLED on)
ENDIF(EUREPHIADM)
+IF(ADMIN_ENABLED)
+ find_package(PkgConfig)
+ pkg_search_module(LIBXML2 REQUIRED libxml-2.0 libxml2 libxml>=2.6)
+ INCLUDE_DIRECTORIES(BEFORE ${LIBXML2_INCLUDE_DIRS})
+ ADD_DEFINITIONS(-DHAVE_LIBXML2)
+ SET(EXTRA_LIBS ${LIBXML2_LIBRARIES})
+ENDIF(ADMIN_ENABLED)
+
IF(NOT DATABASE)
message(FATAL_ERROR "Cannot build eurephia without any database drivers.")
ENDIF(NOT DATABASE)