summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a281c9d..07b5cb0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -109,4 +109,7 @@ ENDIF(NOT HAVE_PTHREAD_MUTEX_LOCK OR NOT HAVE_PTHREAD_MUTEX_UNLOCK)
ADD_DEFINITIONS(-g -Wall)
-SUBDIRS(${subdirs})
+ADD_LIBRARY(common STATIC IMPORTED)
+SET_PROPERTY(TARGET common PROPERTY IMPORTED_LOCATION ${CMAKE_SOURCE_DIR}/common/libeurephiacommon.a)
+
+SUBDIRS(common ${subdirs})