summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Sommerseth <dazo@users.sourceforge.net>2009-04-11 00:31:48 +0200
committerDavid Sommerseth <dazo@users.sourceforge.net>2009-04-11 00:31:48 +0200
commit75f1e6f6b12f9fe461e4afa5bf3c998d21d48394 (patch)
tree77420f3134189dc5bce5b0d3fe77826b66f702aa /CMakeLists.txt
parent10fd2098416c78958a199f31480bd363eaa76212 (diff)
downloadeurephia-75f1e6f6b12f9fe461e4afa5bf3c998d21d48394.tar.gz
eurephia-75f1e6f6b12f9fe461e4afa5bf3c998d21d48394.tar.xz
eurephia-75f1e6f6b12f9fe461e4afa5bf3c998d21d48394.zip
Rewritten CMake rules to build common/ as static library
This static library is later on linked in. This is to avoid recompiling the same source files several times during a complete eurephia compilation.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a281c9d..07b5cb0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -109,4 +109,7 @@ ENDIF(NOT HAVE_PTHREAD_MUTEX_LOCK OR NOT HAVE_PTHREAD_MUTEX_UNLOCK)
ADD_DEFINITIONS(-g -Wall)
-SUBDIRS(${subdirs})
+ADD_LIBRARY(common STATIC IMPORTED)
+SET_PROPERTY(TARGET common PROPERTY IMPORTED_LOCATION ${CMAKE_SOURCE_DIR}/common/libeurephiacommon.a)
+
+SUBDIRS(common ${subdirs})