summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Sommerseth <dazo@users.sourceforge.net>2009-09-26 22:56:23 +0200
committerDavid Sommerseth <dazo@users.sourceforge.net>2009-09-26 22:56:23 +0200
commit1e010e77c4ab10de0e01102eee228714cad23405 (patch)
treef0a0ad9a39dd5234c026ad0fd960bfdb1a69aaaf /CMakeLists.txt
parentcf7a28b6fe409fbfddcbad58bcc6b25ffe1b959d (diff)
downloadeurephia-1e010e77c4ab10de0e01102eee228714cad23405.tar.gz
eurephia-1e010e77c4ab10de0e01102eee228714cad23405.tar.xz
eurephia-1e010e77c4ab10de0e01102eee228714cad23405.zip
Added misc. compiler optimisations
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2f22271..b2e75ea 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -43,7 +43,7 @@ SET(XSLTROOT "/usr/local/share/eurephia/xslt" CACHE STRING "Root path for the XS
SET(CMAKE_INSTALL_PREFIX ${PREFIX})
# Default C compiler flags
-SET(CMAKE_C_FLAGS "-fno-delete-null-pointer-checks -g -Wall")
+SET(CMAKE_C_FLAGS "-fno-delete-null-pointer-checks -g -Wall -Wpointer-arith")
IF(GCOV)
SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fprofile-arcs -ftest-coverage")
ENDIF(GCOV)