summaryrefslogtreecommitdiffstats
path: root/common/refarray/Makefile.am
diff options
context:
space:
mode:
authorDmitri Pal <dpal@redhat.com>2010-04-05 10:59:33 -0400
committerStephen Gallagher <sgallagh@redhat.com>2010-04-08 08:53:36 -0400
commit69e1a7254ff2be3d7b0b0d968f6ddeb638c0be86 (patch)
tree917be1d30693cf1667385e3796ca11ceba97d1e2 /common/refarray/Makefile.am
parent9c124af8868a7d3908c03ec369e28daef17d5f12 (diff)
downloadsssd-69e1a7254ff2be3d7b0b0d968f6ddeb638c0be86.tar.gz
sssd-69e1a7254ff2be3d7b0b0d968f6ddeb638c0be86.tar.xz
sssd-69e1a7254ff2be3d7b0b0d968f6ddeb638c0be86.zip
Adding interface documentation
Package refarray documentation by default
Diffstat (limited to 'common/refarray/Makefile.am')
-rw-r--r--common/refarray/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/common/refarray/Makefile.am b/common/refarray/Makefile.am
index 724131f..abda089 100644
--- a/common/refarray/Makefile.am
+++ b/common/refarray/Makefile.am
@@ -34,6 +34,22 @@ check_PROGRAMS = ref_array_ut
ref_array_ut_SOURCES = ref_array_ut.c
ref_array_ut_LDADD = libref_array.la
+if HAVE_DOXYGEN
+docs:
+# A temp way of building docs until we hook into the package build
+ rm -fR doc
+ mkdir -p doc
+ $(DOXYGEN) ref_array.cfg.doxy
+else
+docs:
+ @echo "Doxygen not installed, cannot generate documentation"
+ @exit 1
+endif
+
+
TESTS = ref_array_ut
tests: all $(check_PROGRAMS)
+
+clean-local:
+ rm -Rf doc