summaryrefslogtreecommitdiffstats
path: root/glib/Makefile.am
diff options
context:
space:
mode:
authorPaul Pogonyshev <pogonyshev@gmx.net>2009-04-18 23:42:08 +0300
committerPaul Pogonyshev <pogonyshev@gmx.net>2009-04-18 23:42:08 +0300
commitd6a62d095cfa42c5ab4ac67017d995ce45ee158c (patch)
tree9440e9ea80cb2bc5b616e20b343c9ad59fdcb5cc /glib/Makefile.am
parent549a656122f11a969917f1f333b1e3416b3fb47d (diff)
downloadpygobject-d6a62d095cfa42c5ab4ac67017d995ce45ee158c.tar.gz
pygobject-d6a62d095cfa42c5ab4ac67017d995ce45ee158c.tar.xz
pygobject-d6a62d095cfa42c5ab4ac67017d995ce45ee158c.zip
Remove 'ltihooks.py' as using deprecated Python module.
Remove the script and all related imports. All relevant Makefile's now create symbolic links for '.so' files from '.libs' to the level up, so that C helper modules are still importable in built, but not installed source tree.
Diffstat (limited to 'glib/Makefile.am')
-rw-r--r--glib/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/glib/Makefile.am b/glib/Makefile.am
index 2877b5f..8b178a4 100644
--- a/glib/Makefile.am
+++ b/glib/Makefile.am
@@ -50,3 +50,10 @@ _glib_la_SOURCES = \
if PLATFORM_WIN32
_glib_la_CFLAGS += -DPLATFORM_WIN32
endif
+
+
+all: $(pyglib_LTLIBRARIES:.la=.so)
+clean-local:
+ rm -f $(pyglib_LTLIBRARIES:.la=.so)
+.la.so:
+ $(LN_S) .libs/$@ $@