summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Cantrell <dcantrell@redhat.com>2009-09-25 17:46:18 -1000
committerDavid Cantrell <dcantrell@redhat.com>2009-09-29 11:36:02 -1000
commitb3737582a3d57974fcb308eda61cbfcb46df5551 (patch)
treed7a9e3d16d837a5362d3fc33b7387fc289e152dd /Makefile.am
parenta814d4803f3f999a1bf9a53f0d04cb26a4f1f490 (diff)
downloadanaconda-b3737582a3d57974fcb308eda61cbfcb46df5551.tar.gz
anaconda-b3737582a3d57974fcb308eda61cbfcb46df5551.tar.xz
anaconda-b3737582a3d57974fcb308eda61cbfcb46df5551.zip
Update po/anaconda.pot during a 'bumpver' run.
Since we have to store anaconda.pot in the source tree for the translators, make sure we update it when bumpver is run so it stays current. When you run 'make bumpver', you will now be checking in at least two files but up to three: anaconda.spec.in [required] configure.ac [required] po/anaconda.pot [optional, only if it needed updating] Make sure you add all of these files for 'New version' commits.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a5ad89f86..c530623d4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -130,6 +130,7 @@ bumpver:
(head -n $$cl anaconda.spec.in ; echo "$$DATELINE" ; cat newspeclog ; echo ""; cat speclog) > anaconda.spec.in.new ; \
mv anaconda.spec.in.new anaconda.spec.in ; rm -f speclog ; rm -f newspeclog ; \
sed -i "s/AC_INIT(\[$(PACKAGE_NAME)\], \[$(PACKAGE_VERSION)\], \[$(PACKAGE_BUGREPORT\])/AC_INIT(\[$(PACKAGE_NAME)\], \[$$NEWVERSION\], \[$(PACKAGE_BUGREPORT\])/" configure.ac
+ $(MAKE) -C po $(PACKAGE_NAME).pot-update
install-buildrequires:
yum install $$(grep BuildRequires: anaconda.spec.in | cut -d ' ' -f 2)