summaryrefslogtreecommitdiffstats
path: root/cygwin-w32api-runtime.spec
diff options
context:
space:
mode:
authorYaakov Selkowitz <yselkowitz@users.sourceforge.net>2013-01-21 20:59:37 -0600
committerYaakov Selkowitz <yselkowitz@users.sourceforge.net>2013-01-21 20:59:37 -0600
commit541645b42908cfca27c45a5d921c02a0efcaf0b3 (patch)
tree698fb04b79a28fb2fd2d2b8f98e95c0780e7fa00 /cygwin-w32api-runtime.spec
parentdc585231a1c63188df3c6785fb638d3312df1684 (diff)
downloadcygwin-w32api-runtime-541645b42908cfca27c45a5d921c02a0efcaf0b3.tar.gz
cygwin-w32api-runtime-541645b42908cfca27c45a5d921c02a0efcaf0b3.tar.xz
cygwin-w32api-runtime-541645b42908cfca27c45a5d921c02a0efcaf0b3.zip
cygwin-w32api-runtime 20121215
Diffstat (limited to 'cygwin-w32api-runtime.spec')
-rw-r--r--cygwin-w32api-runtime.spec83
1 files changed, 83 insertions, 0 deletions
diff --git a/cygwin-w32api-runtime.spec b/cygwin-w32api-runtime.spec
new file mode 100644
index 0000000..0cc0a37
--- /dev/null
+++ b/cygwin-w32api-runtime.spec
@@ -0,0 +1,83 @@
+%define __strip %{_cygwin_strip}
+%define __objdump %{_cygwin_objdump}
+%define _use_internal_dependency_generator 0
+%define __find_requires %{_cygwin_findrequires}
+%define __find_provides %{_cygwin_findprovides}
+
+%global snapshot_date 20121215
+%global branch trunk
+
+Name: cygwin-w32api-runtime
+Version: 2.0.999
+Release: 0.13.%{branch}.%{snapshot_date}
+Summary: Windows API libraries for Cygwin toolchain
+
+License: Public Domain and ZPLv2.1
+Group: Development/Libraries
+URL: http://mingw-w64.sourceforge.net/
+BuildArch: noarch
+
+%if 0%{?snapshot_date}
+# To regerenate a snapshot:
+# wget http://mingw-w64.svn.sourceforge.net/viewvc/mingw-w64/%{branch}/?view=tar -O mingw-w64-%{branch}-snapshot-$(date '+%Y%m%d').tar.gz
+Source0: mingw-w64-%{branch}-snapshot-%{snapshot_date}.tar.gz
+%else
+Source0: http://downloads.sourceforge.net/mingw-w64/mingw-w64-v%{version}.tar.gz
+%endif
+
+BuildRequires: cygwin-filesystem
+BuildRequires: cygwin-binutils
+BuildRequires: cygwin-w32api-headers >= %{version}-%{release}
+BuildRequires: cygwin-gcc
+
+Requires: cygwin-filesystem
+Requires: cygwin-w32api-headers >= %{version}-%{release}
+
+Obsoletes: cygwin-w32api < 3.17-4
+Obsoletes: cygwin-w32api-libs
+Provides: cygwin-w32api = 3.17-4
+Provides: cygwin-w32api-libs = %{version}-%{release}
+
+%description
+MinGW Windows cross-compiler runtime, base libraries.
+
+
+%prep
+%if 0%{?snapshot_date}
+rm -rf mingw-w64-v%{version}
+mkdir mingw-w64-v%{version}
+cd mingw-w64-v%{version}
+tar -xf %{S:0}
+%setup -q -D -T -n mingw-w64-v%{version}/%{branch}
+%else
+%setup -q -n mingw-w64-v%{version}
+%endif
+
+
+%build
+pushd mingw-w64-crt
+ %_cygwin_configure --enable-w32api --disable-lib64
+ make %{?_smp_mflags}
+popd
+
+
+%install
+pushd mingw-w64-crt
+ make install DESTDIR=$RPM_BUILD_ROOT
+popd
+
+# Dunno what to do with these files
+rm -rf $RPM_BUILD_ROOT%{_cygwin_includedir}/w32api/*.c
+
+
+%files
+%doc COPYING DISCLAIMER DISCLAIMER.PD
+%{_cygwin_libdir}/w32api/
+
+
+%changelog
+* Tue Oct 16 2012 Yaakov Selkowitz <cygwin-ports-general@lists.sourceforge.net> - 2.0.999-1.trunk.20121215
+- Change name and update to match current Cygwin package.
+
+* Tue Oct 16 2012 Yaakov Selkowitz <cygwin-ports-general@lists.sourceforge.net> - 2.0.999-1.trunk.20121016
+- Replace mingw.org w32api with mingw-w64 to match Cygwin distribution.