summaryrefslogtreecommitdiffstats
path: root/cygwin-pkg-config.spec
diff options
context:
space:
mode:
authorYaakov Selkowitz <yselkowitz@users.sourceforge.net>2013-06-26 19:18:45 -0500
committerYaakov Selkowitz <yselkowitz@users.sourceforge.net>2013-06-26 19:18:45 -0500
commit835d08ee5f76168d9ba67f3f43e6e4c8e1676946 (patch)
treefaf73f059245542e7d613e8ec013196e95b4b49b /cygwin-pkg-config.spec
downloadcygwin-pkg-config-835d08ee5f76168d9ba67f3f43e6e4c8e1676946.tar.gz
cygwin-pkg-config-835d08ee5f76168d9ba67f3f43e6e4c8e1676946.tar.xz
cygwin-pkg-config-835d08ee5f76168d9ba67f3f43e6e4c8e1676946.zip
cygwin-pkg-config 0.28
Diffstat (limited to 'cygwin-pkg-config.spec')
-rw-r--r--cygwin-pkg-config.spec95
1 files changed, 95 insertions, 0 deletions
diff --git a/cygwin-pkg-config.spec b/cygwin-pkg-config.spec
new file mode 100644
index 0000000..8a2cc3a
--- /dev/null
+++ b/cygwin-pkg-config.spec
@@ -0,0 +1,95 @@
+Name: cygwin-pkg-config
+Version: 0.28
+Release: 1%{?dist}
+Summary: A tool for determining compilation options
+
+License: GPLv2+
+Group: Development/Tools
+URL: http://pkgconfig.freedesktop.org
+Source0: http://www.freedesktop.org/software/pkgconfig/releases/pkg-config-%{version}.tar.gz
+
+BuildRequires: glib2-devel
+BuildRequires: cygwin32-filesystem >= 7
+BuildRequires: cygwin64-filesystem >= 7
+
+
+%description
+The pkgconfig tool determines compilation options. For each required
+library, it reads the configuration file and outputs the necessary
+compiler and linker flags.
+
+
+# Cygwin32
+%package -n cygwin32-pkg-config
+Summary: A tool for determining compilation options for the Cygwin32 target
+Requires: cygwin32-filesystem >= 7
+
+%description -n cygwin32-pkg-config
+The pkgconfig tool determines compilation options. For each required
+library, it reads the configuration file and outputs the necessary
+compiler and linker flags.
+
+# Cygwin64
+%package -n cygwin64-pkg-config
+Summary: A tool for determining compilation options for the Cygwin64 target
+Requires: cygwin64-filesystem >= 7
+
+%description -n cygwin64-pkg-config
+The pkgconfig tool determines compilation options. For each required
+library, it reads the configuration file and outputs the necessary
+compiler and linker flags.
+
+
+%prep
+%setup -q -n pkg-config-%{version}
+
+
+%build
+%global _configure ../configure
+
+mkdir build_cyg32
+pushd build_cyg32
+ %configure \
+ --disable-shared \
+ --disable-host-tool \
+ --program-prefix=%{cygwin32_target}- \
+ --with-pc-path=%{cygwin32_libdir}/pkgconfig:%{cygwin32_datadir}/pkgconfig:%{_datadir}/pkgconfig
+
+ make %{?_smp_mflags}
+popd
+
+mkdir build_cyg64
+pushd build_cyg64
+ %configure \
+ --disable-shared \
+ --disable-host-tool \
+ --program-prefix=%{cygwin64_target}- \
+ --with-pc-path=%{cygwin64_libdir}/pkgconfig:%{cygwin64_datadir}/pkgconfig:%{_datadir}/pkgconfig
+
+ make %{?_smp_mflags}
+popd
+
+
+%install
+make install -C build_cyg32 DESTDIR=$RPM_BUILD_ROOT
+make install -C build_cyg64 DESTDIR=$RPM_BUILD_ROOT
+
+# These files conflict with ordinary pkg-config.
+rm -rf ${RPM_BUILD_ROOT}%{_datadir}/aclocal
+rm -rf ${RPM_BUILD_ROOT}%{_datadir}/doc/pkg-config
+
+
+%files -n cygwin32-pkg-config
+%doc AUTHORS README NEWS COPYING pkg-config-guide.html
+%{_bindir}/%{cygwin32_target}-pkg-config
+%{_mandir}/man1/%{cygwin32_target}-pkg-config.1*
+
+%files -n cygwin64-pkg-config
+%doc AUTHORS README NEWS COPYING pkg-config-guide.html
+%{_bindir}/%{cygwin64_target}-pkg-config
+%{_mandir}/man1/%{cygwin64_target}-pkg-config.1*
+
+
+%changelog
+* Wed Jun 26 2013 Yaakov Selkowitz <cygwin-ports-general@lists.sourceforge.net> - 0.28-1
+- Initial spec file, largely based on mingw-pkg-config.