summaryrefslogtreecommitdiffstats
path: root/cygwin-pcre.spec
diff options
context:
space:
mode:
authorYaakov Selkowitz <yselkowi@redhat.com>2016-03-30 16:26:51 -0500
committerYaakov Selkowitz <yselkowi@redhat.com>2016-03-30 16:26:51 -0500
commit1e484580e8989ee76f3f273281b3520bdf873b08 (patch)
tree3a51069b32693db3f9c6b9affc2cb1ea5a63a961 /cygwin-pcre.spec
parente6351bf981ac2069ab857a763dec5a0b52768f87 (diff)
downloadcygwin-pcre-1e484580e8989ee76f3f273281b3520bdf873b08.tar.gz
cygwin-pcre-1e484580e8989ee76f3f273281b3520bdf873b08.tar.xz
cygwin-pcre-1e484580e8989ee76f3f273281b3520bdf873b08.zip
cygwin-pcre 8.38
Diffstat (limited to 'cygwin-pcre.spec')
-rw-r--r--cygwin-pcre.spec85
1 files changed, 82 insertions, 3 deletions
diff --git a/cygwin-pcre.spec b/cygwin-pcre.spec
index aaaaffa..250b3b2 100644
--- a/cygwin-pcre.spec
+++ b/cygwin-pcre.spec
@@ -1,8 +1,8 @@
%{?cygwin_package_header}
Name: cygwin-pcre
-Version: 8.32
-Release: 2
+Version: 8.38
+Release: 1%{?dist}
Summary: Cygwin pcre library
Group: Development/Libraries
@@ -11,7 +11,65 @@ URL: http://www.pcre.org/
BuildArch: noarch
Source0: ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/pcre-%{version}.tar.bz2
-
+# Upstream thinks RPATH is good idea.
+Patch0: pcre-8.21-multilib.patch
+# Refused by upstream, bug #675477
+#Patch1: pcre-8.32-refused_spelling_terminated.patch
+# Fix compiling comments with auto-callouts, upstream bug #1725,
+# fixed in upstream after 8.38
+Patch2: pcre-8.38-Fix-auto-callout-comment-bug.patch
+# Fix compiling expressions with negated classes in UCP mode,
+# upstream bug #1732, fixed in upstream after 8.38
+Patch3: pcre-8.38-Fix-negated-POSIX-class-within-negated-overall-class.patch
+# Fix compiling expressions with an isolated \E between an item and its
+# qualifier with auto-callouts, upstream bug #1724,
+# fixed in upstream after 8.38
+Patch4: pcre-8.38-Fix-bug-for-isolated-E-between-an-item-and-its-quali.patch
+# Fix crash in regexec() if REG_STARTEND option is set and pmatch argument is
+# NULL, upstream bug #1727, fixed in upstream after 8.38
+Patch5: pcre-8.38-Give-error-for-regexec-with-pmatch-NULL-and-REG_STAR.patch
+# Fix a stack overflow when formatting a 32-bit integer in pcregrep tool,
+# upstream bug #1728, fixed in upstream after 8.38
+Patch6: pcre-8.38-Allow-for-up-to-32-bit-numbers-in-the-ordin-function.patch
+# Fix compiling expressions with an empty \Q\E sequence between an item and
+# its qualifier with auto-callouts, upstream bug #1735,
+# fixed in upstream after 8.38
+Patch7: pcre-8.38-Fix-Q-E-before-qualifier-bug-when-auto-callouts-are-.patch
+# Fix compiling expressions with global extended modifier that is disabled by
+# local no-extended option at the start of the expression just after
+# a whitespace, in upstream after 8.38
+Patch8: pcre-8.38-Fix-x-bug-when-pattern-starts-with-white-space-and-x.patch
+# Fix possible crash in pcre_copy_named_substring() if a named substring has
+# number greater than the space in the ovector, upstream bug #1741,
+# in fixed in upstream after 8.38
+Patch9: pcre-8.38-Fix-copy-named-substring-bug.patch
+# Fix a buffer overflow when compiling an expression with named groups with
+# a group that reset capture numbers, upstream bug #1742,
+# fixed in upstream after 8.38
+Patch10: pcre-8.38-Fix-by-hacking-another-length-computation-issue.patch
+# Fix a crash in pcre_get_substring_list() if the use of \K caused the start
+# of the match to be earlier than the end, upstream bug #1744,
+# fixed in upstream after 8.38
+Patch11: pcre-8.38-Fix-get_substring_list-bug-when-K-is-used-in-an-asse.patch
+# Fix pcretest for expressions with a callout inside a look-behind assertion,
+# upstream bug #1783, fixed in upstream after 8.38
+Patch12: pcre-8.38-Fix-pcretest-bad-behaviour-for-callout-in-lookbehind.patch
+# Fix CVE-2016-3191 (workspace overflow for (*ACCEPT) with deeply nested
+# parentheses), upstream bug #1791, fixed in upstream after 8.38
+Patch13: pcre-8.38-Fix-workspace-overflow-for-ACCEPT-with-deeply-nested.patch
+# Fix CVE-2016-1283 (heap buffer overflow in handling of nested duplicate named
+# groups with a nested back reference), bug #1295386, upstream bug #1767,
+# fixed in upstream after 8.38
+Patch14: pcre-8.38-Yet-another-duplicate-name-bugfix-by-overestimating-.patch
+# Fix a heap buffer overflow in pcretest causing infinite loop when matching
+# globally with an ovector less than 2, bug #1312786, upstream bug #1777,
+# fixed in upstream after 8.38
+Patch15: pcre-8.38-Fix-pcretest-loop-for-global-matching-with-an-ovecto.patch
+# Fix a non-diagnosis of missing assection after (?(?C) that could corrupt
+# process stack, upstream bug #1780, fixed in upstream after 8.38
+Patch16: pcre-8.38-Fix-non-diagnosis-of-missing-assertion-after-C.patch
+# Fix a typo in pcre_study()
+Patch17: pcre-8.38-Fix-typo-in-pcre_study.patch
BuildRequires: autoconf, automake, libtool
BuildRequires: cygwin32-filesystem
@@ -48,6 +106,24 @@ Cross compiled PCRE library for use with Cygwin x86_64 toolchain.
%prep
%setup -q -n pcre-%{version}
+%patch0 -p1
+#patch1 -p1
+%patch2 -p1
+%patch3 -p1
+%patch4 -p1
+%patch5 -p1
+%patch6 -p1
+%patch7 -p1
+%patch8 -p1
+%patch9 -p1
+%patch10 -p1
+%patch11 -p1
+%patch12 -p1
+%patch13 -p1
+%patch14 -p1
+%patch15 -p1
+%patch16 -p1
+%patch17 -p1
mkdir -p m4
autoreconf -fiv
@@ -125,6 +201,9 @@ rm -rf $RPM_BUILD_ROOT%{cygwin64_mandir}
%changelog
+* Wed Mar 30 2016 Yaakov Selkowitz <yselkowi@redhat.com> - 8.38-1
+- new version with latest Fedora patchset
+
* Fri Jun 28 2013 Yaakov Selkowitz <cygwin-ports-general@lists.sourceforge.net> - 8.32-2
- Rebuild for new Cygwin packaging scheme.
- Add cygwin64 support.