summaryrefslogtreecommitdiffstats
path: root/cygwin-gcc.spec
diff options
context:
space:
mode:
Diffstat (limited to 'cygwin-gcc.spec')
-rw-r--r--cygwin-gcc.spec71
1 files changed, 47 insertions, 24 deletions
diff --git a/cygwin-gcc.spec b/cygwin-gcc.spec
index 7133998..2bc8d19 100644
--- a/cygwin-gcc.spec
+++ b/cygwin-gcc.spec
@@ -1,15 +1,17 @@
+# when changing gcc_minor, also change the soversion of cyggcj-*.dll etc.
+# and the name of libgcj-*.pc
%global gcc_major 4
-%global gcc_minor 7
-%global gcc_micro 3
+%global gcc_minor 8
+%global gcc_micro 2
%global gcc_branch %{gcc_major}.%{gcc_minor}
%global gcc_version %{gcc_major}.%{gcc_minor}.%{gcc_micro}
# Note, gcc_release must be integer, if you want to add suffixes to
# %%{release}, append them after %%{gcc_release} on Release: line.
%global gcc_release 1
-%global build_ada 0
+%global build_ada 1
# building cross-gnat requires matching X.Y version of native gnat
-%if 0%{?fedora} >= 17 && 0%{?fedora} < 19
+%if 0%{?fedora} >= 19 && 0%{?fedora} < 22 || 0%{?rhel} == 7
%ifarch %{ix86} x86_64 ia64 ppc ppc64 alpha
%global build_ada 1
%endif
@@ -37,12 +39,13 @@ BuildRequires: cygwin32-w32api-runtime
BuildRequires: gmp-devel
BuildRequires: mpfr-devel
BuildRequires: libmpc-devel
-%if 0%{?fedora} >= 15 || 0%{?rhel} == 7
-BuildRequires: ppl-devel >= 0.11
-BuildRequires: cloog-ppl-devel >= 0.15
+%if 0
+BuildRequires: isl-devel = 0.11.1
+BuildRequires: cloog-isl-devel = 0.18.0
%endif
BuildRequires: zlib-devel
BuildRequires: flex
+BuildRequires: gettext
%if %{build_ada}
BuildRequires: gcc-gnat
%endif
@@ -54,19 +57,23 @@ BuildRequires: gcc-java
%endif
Source0: ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{gcc_version}/gcc-%{gcc_version}.tar.bz2
+Patch0: gcc46-textdomain.patch
Patch1: gcc47-ada.patch
Patch3: gcc47-libffi-noinst.patch
-Patch4: gcc47-libstdc.patch
+Patch4: gcc47-libstdc-cygwin.patch
Patch7: gcc47-cross-jardir.patch
-Patch8: gcc45-cross-libstdc.patch
Patch9: gcc47-cross-ecjx.patch
Patch10: gcc45-java-FIONREAD.diff
Patch13: gcc45-cross-exe-suffix.diff
Patch14: gcc47-boehm-gc-cygwin.patch
Patch15: gcc47-execstack.patch
Patch16: gcc47-java-jni.patch
-Patch17: gcc47-specs.patch
+Patch17: gcc48-specs-cygwin.patch
Patch19: gcc48-lto-plugin-soname.patch
+Patch20: gcc48-java-soname.patch
+Patch21: gcc48-libatomic-cygwin.patch
+Patch22: gcc48-libgcc-references.patch
+Patch23: gcc48-Wimplicit-decls.patch
%description
@@ -84,6 +91,7 @@ Requires: cygwin32-w32api-runtime
Requires: cygwin32-cpp
# We don't run the automatic dependency scripts which would
# normally detect and provide the following DLL:
+Provides: cygwin32(cygatomic-1.dll)
Provides: cygwin32(cyggcc_s-1.dll)
Provides: cygwin32(cyggomp-1.dll)
Provides: cygwin32(cygquadmath-0.dll)
@@ -195,10 +203,10 @@ Requires: cygwin32-libiconv
Requires: cygwin32-zlib
# We don't run the automatic dependency scripts which would
# normally detect and provide the following DLL:
-Provides: cygwin32(cyggcj-13.dll)
-Provides: cygwin32(cyggcj-noncore-13.dll)
-Provides: cygwin32(cyggcj-tools-13.dll)
-Provides: cygwin32(cyggij-13.dll)
+Provides: cygwin32(cyggcj-14.dll)
+Provides: cygwin32(cyggcj-noncore-14.dll)
+Provides: cygwin32(cyggcj-tools-14.dll)
+Provides: cygwin32(cyggij-14.dll)
Provides: cygwin32(cygjvm.dll)
Provides: %{name}-java = %{version}-%{release}
Obsoletes: %{name}-java < 4.7
@@ -209,19 +217,23 @@ Cygwin cross-compiler for Java.
%prep
%setup -q -n gcc-%{gcc_version}
+%patch0 -p2
%patch1 -p2
%patch3 -p2
%patch4 -p2
%patch7 -p2
-%patch8 -p1
%patch9 -p1
%patch10 -p2
%patch13 -p1
%patch14 -p2
%patch15 -p2
%patch16 -p2
-%patch17 -p2
+%patch17 -p0
%patch19 -p2
+%patch20 -p0
+%patch21 -p2
+%patch22 -p0
+%patch23 -p2
echo %{gcc_version} > gcc/BASE-VER
echo 'Fedora Cygwin %{gcc_version}-%{gcc_release}' > gcc/DEV-PHASE
@@ -254,7 +266,7 @@ CC="%{__cc} ${RPM_OPT_FLAGS}" \
--disable-multilib \
--with-system-zlib \
--enable-shared --enable-shared-libgcc --enable-static \
- --disable-nls --without-included-gettext \
+ --without-included-gettext \
--disable-win32-registry \
--enable-threads=posix \
--enable-version-specific-runtime-libs \
@@ -346,12 +358,15 @@ find $RPM_BUILD_ROOT -name '*.la' -delete
popd
+%find_lang cygwin32-gcc
+%find_lang cygwin32-cpplib
+
%clean
rm -rf $RPM_BUILD_ROOT
-%files -n cygwin32-gcc
+%files -n cygwin32-gcc -f cygwin32-gcc.lang
%{_bindir}/%{cygwin32_target}-gcc
%{_bindir}/%{cygwin32_target}-gcc-%{version}
%{_bindir}/%{cygwin32_target}-gcc-ar
@@ -363,6 +378,8 @@ rm -rf $RPM_BUILD_ROOT
%{_libdir}/gcc/%{cygwin32_target}/%{version}/crtbegin.o
%{_libdir}/gcc/%{cygwin32_target}/%{version}/crtend.o
%{_libdir}/gcc/%{cygwin32_target}/%{version}/crtfastmath.o
+%{_libdir}/gcc/%{cygwin32_target}/%{version}/libatomic.a
+%{_libdir}/gcc/%{cygwin32_target}/%{version}/libatomic.dll.a
%{_libdir}/gcc/%{cygwin32_target}/%{version}/libgcc.a
%{_libdir}/gcc/%{cygwin32_target}/%{version}/libgcc_eh.a
%{_libdir}/gcc/%{cygwin32_target}/%{version}/libgcc_s.dll.a
@@ -391,6 +408,7 @@ rm -rf $RPM_BUILD_ROOT
%{_libexecdir}/gcc/%{cygwin32_target}/%{version}/plugin/
%dir %{_datadir}/gcc-%{gcc_version}
%dir %{_datadir}/gcc-%{gcc_version}/%{cygwin32_target}
+%{cygwin32_bindir}/cygatomic-1.dll
%{cygwin32_bindir}/cyggcc_s-1.dll
%{cygwin32_bindir}/cyggomp-1.dll
%{cygwin32_bindir}/cygquadmath-0.dll
@@ -400,7 +418,7 @@ rm -rf $RPM_BUILD_ROOT
%doc gcc/README* gcc/COPYING*
-%files -n cygwin32-cpp
+%files -n cygwin32-cpp -f cygwin32-cpplib.lang
/lib/%{cygwin32_target}-cpp
%{_bindir}/%{cygwin32_target}-cpp
%{_mandir}/man1/%{cygwin32_target}-cpp.1*
@@ -495,17 +513,22 @@ rm -rf $RPM_BUILD_ROOT
%{_libexecdir}/gcc/%{cygwin32_target}/%{version}/ecj1
%{_libexecdir}/gcc/%{cygwin32_target}/%{version}/jc1
%{_libexecdir}/gcc/%{cygwin32_target}/%{version}/jvgenmain
-%{cygwin32_bindir}/cyggcj-13.dll
-%{cygwin32_bindir}/cyggcj-noncore-13.dll
-%{cygwin32_bindir}/cyggcj-tools-13.dll
-%{cygwin32_bindir}/cyggij-13.dll
+%{cygwin32_bindir}/cyggcj-14.dll
+%{cygwin32_bindir}/cyggcj-noncore-14.dll
+%{cygwin32_bindir}/cyggcj-tools-14.dll
+%{cygwin32_bindir}/cyggij-14.dll
%{cygwin32_bindir}/cygjvm.dll
-%{cygwin32_libdir}/pkgconfig/libgcj-4.7.pc
+%{cygwin32_libdir}/pkgconfig/libgcj-4.8.pc
%{_datadir}/gcc-%{gcc_version}/%{cygwin32_target}/java
%endif
%changelog
+* Sun Jan 19 2014 Yaakov Selkowitz <yselkowitz@users.sourceforge.net> - 4.8.2-1
+- Version bump.
+- Enable Ada on systems with native gcc-gnat-4.8.x.
+- Enable NLS without colliding with native gcc.
+
* Thu Jun 27 2013 Yaakov Selkowitz <yselkowitz@users.sourceforge.net> - 4.7.3-1
- Version bump.
- Update for new Cygwin packaging scheme.