summaryrefslogtreecommitdiffstats
path: root/cygwin-gcc.spec
diff options
context:
space:
mode:
Diffstat (limited to 'cygwin-gcc.spec')
-rw-r--r--cygwin-gcc.spec139
1 files changed, 14 insertions, 125 deletions
diff --git a/cygwin-gcc.spec b/cygwin-gcc.spec
index 51f2053..162e830 100644
--- a/cygwin-gcc.spec
+++ b/cygwin-gcc.spec
@@ -2,25 +2,20 @@
# and the name of libgcj-*.pc
%global gcc_major 4
%global gcc_minor 8
-%global gcc_micro 2
+%global gcc_micro 3
%global gcc_branch %{gcc_major}.%{gcc_minor}
%global gcc_version %{gcc_major}.%{gcc_minor}.%{gcc_micro}
# Note, gcc_release must be integer, if you want to add suffixes to
# %%{release}, append them after %%{gcc_release} on Release: line.
-%global gcc_release 2
+%global gcc_release 1
%global build_ada 0
# building cross-gnat requires matching X.Y version of native gnat
-%if 0%{?fedora} >= 19 && 0%{?fedora} < 22 || 0%{?rhel} == 7
+%if 0%{?fedora} >= 19 && 0%{?fedora} < 21 || 0%{?rhel} == 7
%ifarch %{ix86} x86_64 ia64 ppc ppc64 alpha
%global build_ada 1
%endif
%endif
-%if 0%{?rhel} >= 7
-%global build_java 0
-%else
-%global build_java 1
-%endif
%global __os_install_post /usr/lib/rpm/brp-compress %{nil}
@@ -53,31 +48,18 @@ BuildRequires: gettext
%if %{build_ada}
BuildRequires: gcc-gnat
%endif
-%if %{build_java}
-BuildRequires: cygwin32-libiconv
-BuildRequires: cygwin32-zlib
-BuildRequires: gcc-c++
-BuildRequires: gcc-java
-%endif
Source0: ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{gcc_version}/gcc-%{gcc_version}.tar.bz2
Patch0: gcc46-textdomain.patch
Patch1: gcc47-ada.patch
-Patch3: gcc47-libffi-noinst.patch
Patch4: gcc47-libstdc-cygwin.patch
-Patch7: gcc47-cross-jardir.patch
-Patch9: gcc47-cross-ecjx.patch
-Patch10: gcc45-java-FIONREAD.diff
Patch13: gcc45-cross-exe-suffix.diff
-Patch14: gcc47-boehm-gc-cygwin.patch
Patch15: gcc47-execstack.patch
-Patch16: gcc47-java-jni.patch
Patch17: gcc48-specs-cygwin.patch
Patch19: gcc48-lto-plugin-soname.patch
-Patch20: gcc48-java-soname.patch
Patch21: gcc48-libatomic-cygwin.patch
-Patch22: gcc48-libgcc-references.patch
Patch23: gcc48-Wimplicit-decls.patch
+Patch24: gcc49-default-manifest.patch
%description
@@ -106,6 +88,9 @@ Provides: cygwin(cyggomp-1.dll)
Provides: cygwin(cygssp-0.dll)
Provides: %{name} = %{version}-%{release}
Obsoletes: %{name} < 4.7
+# prevent update errors
+Obsoletes: %{name}-java < %{version}-%{release}
+Obsoletes: cygwin32-gcc-java < %{version}-%{release}
%description -n cygwin32-gcc
@@ -198,46 +183,18 @@ Obsoletes: %{name}-gnat < 4.7
Cygwin cross-compiler for Ada.
-%package -n cygwin32-gcc-java
-Summary: Cygwin cross-compiler for Java
-Group: Development/Languages
-Requires: cygwin32-gcc = %{version}-%{release}
-Requires: ecj
-Requires: cygwin32-libiconv
-Requires: cygwin32-zlib
-# We don't run the automatic dependency scripts which would
-# normally detect and provide the following DLL:
-Provides: cygwin32(cyggcj-14.dll)
-Provides: cygwin32(cyggcj-noncore-14.dll)
-Provides: cygwin32(cyggcj-tools-14.dll)
-Provides: cygwin32(cyggij-14.dll)
-Provides: cygwin32(cygjvm.dll)
-Provides: %{name}-java = %{version}-%{release}
-Obsoletes: %{name}-java < 4.7
-
-%description -n cygwin32-gcc-java
-Cygwin cross-compiler for Java.
-
-
%prep
%setup -q -n gcc-%{gcc_version}
%patch0 -p2
%patch1 -p2
-%patch3 -p2
%patch4 -p2
-%patch7 -p2
-%patch9 -p1
-%patch10 -p2
%patch13 -p1
-%patch14 -p2
%patch15 -p2
-%patch16 -p2
%patch17 -p0
%patch19 -p2
-%patch20 -p0
%patch21 -p2
-%patch22 -p0
%patch23 -p2
+%patch24 -p0
echo %{gcc_version} > gcc/BASE-VER
echo 'Fedora Cygwin %{gcc_version}-%{gcc_release}' > gcc/DEV-PHASE
@@ -250,9 +207,6 @@ pushd build_cyg32
%if %{build_ada}
enablelada=,ada
%endif
-%if %{build_java}
-enableljava=,java
-%endif
CC="%{__cc} ${RPM_OPT_FLAGS}" \
../configure \
@@ -280,7 +234,7 @@ CC="%{__cc} ${RPM_OPT_FLAGS}" \
%if 0%{?fedora} >= 15 || 0%{?rhel} == 7
--enable-graphite \
%endif
- --enable-languages="c,c++,objc,obj-c++${enableljava},fortran${enablelada},lto" \
+ --enable-languages="c,c++,objc,obj-c++,fortran${enablelada},lto" \
--enable-lto --disable-symvers \
--enable-libgomp --disable-libitm --enable-libssp \
--enable-libquadmath --enable-libquadmath-support \
@@ -288,13 +242,6 @@ CC="%{__cc} ${RPM_OPT_FLAGS}" \
%if %{build_ada}
--enable-libada \
%endif
-%if %{build_java}
- --enable-libjava \
- --enable-libgcj-sublibs --disable-jni --disable-java-awt \
- --enable-default-preferences-peer=file \
- --with-ecj-jar=%{_datadir}/java/ecj.jar \
- --without-libiconv-prefix \
-%endif
--with-bugurl=http://cygwinports.org
make %{?_smp_mflags} all
@@ -312,32 +259,10 @@ make DESTDIR=$RPM_BUILD_ROOT install
rm -rf $RPM_BUILD_ROOT%{_infodir}
rm -f $RPM_BUILD_ROOT%{_libdir}/libiberty*
rm -f $RPM_BUILD_ROOT%{_mandir}/man7/*
-%if %{build_java}
-rm -fr $RPM_BUILD_ROOT%{_libdir}/gcj-%{version}-*
-rm -fr $RPM_BUILD_ROOT%{_libdir}/logging.properties
-rm -fr $RPM_BUILD_ROOT%{_libdir}/security/
-rm -f $RPM_BUILD_ROOT%{_datadir}/gcc-%{gcc_version}/%{cygwin32_target}/python/*.py
-#rm -f $RPM_BUILD_ROOT%{_datadir}/gcc-%{gcc_version}/%{cygwin64_target}/python/*.py
-%endif
# This file is provided by cygwin32-libbfd
rm -f $RPM_BUILD_ROOT%{_prefix}/%{cygwin32_target}/lib/libiberty.a
-# These scripts are not intended for cross-compiling scenarios
-%if %{build_java}
-rm -f $RPM_BUILD_ROOT%{_bindir}/%{cygwin32_target}-aot-compile
-rm -f $RPM_BUILD_ROOT%{_bindir}/%{cygwin32_target}-jcf-dump
-rm -f $RPM_BUILD_ROOT%{_bindir}/%{cygwin32_target}-rebuild-gcj-db
-rm -f $RPM_BUILD_ROOT%{_mandir}/man1/%{cygwin32_target}-aot-compile*
-rm -f $RPM_BUILD_ROOT%{_mandir}/man1/%{cygwin32_target}-g[^+cfn]*
-rm -f $RPM_BUILD_ROOT%{_mandir}/man1/%{cygwin32_target}-gc-analyze*
-rm -f $RPM_BUILD_ROOT%{_mandir}/man1/%{cygwin32_target}-gcj-dbtool*
-rm -f $RPM_BUILD_ROOT%{_mandir}/man1/%{cygwin32_target}-gcjh*
-rm -f $RPM_BUILD_ROOT%{_mandir}/man1/%{cygwin32_target}-gnative2ascii*
-rm -f $RPM_BUILD_ROOT%{_mandir}/man1/%{cygwin32_target}-j*
-rm -f $RPM_BUILD_ROOT%{_mandir}/man1/%{cygwin32_target}-rebuild-gcj-db*
-%endif
-
mkdir -p $RPM_BUILD_ROOT/lib
ln -sf ..%{_prefix}/bin/%{cygwin32_target}-cpp \
$RPM_BUILD_ROOT/lib/%{cygwin32_target}-cpp
@@ -349,14 +274,6 @@ mv $RPM_BUILD_ROOT%{_libdir}/gcc/%{cygwin32_target}/*.dll \
$RPM_BUILD_ROOT%{_libdir}/gcc/%{cygwin32_target}/%{gcc_version}/*.dll \
$RPM_BUILD_ROOT%{cygwin32_bindir}
-
-%if %{build_java}
-# Move libgcj pkg-config files into sysroot
-mkdir -p $RPM_BUILD_ROOT%{cygwin32_libdir}/pkgconfig
-mv $RPM_BUILD_ROOT%{_libdir}/pkgconfig/* \
- $RPM_BUILD_ROOT%{cygwin32_libdir}/pkgconfig
-%endif
-
# Don't want the *.la files.
find $RPM_BUILD_ROOT -name '*.la' -delete
@@ -494,40 +411,12 @@ rm -rf $RPM_BUILD_ROOT
%endif
-%if %{build_java}
-%files -n cygwin32-gcc-java
-%defattr(-,root,root,-)
-%{_bindir}/%{cygwin32_target}-gcj
-%{_mandir}/man1/%{cygwin32_target}-gcj.1*
-%{_libdir}/gcc/%{cygwin32_target}/%{version}/include/c++/gcj/
-%{_libdir}/gcc/%{cygwin32_target}/%{version}/include/c++/gnu/
-%{_libdir}/gcc/%{cygwin32_target}/%{version}/include/c++/java/
-%{_libdir}/gcc/%{cygwin32_target}/%{version}/include/c++/javax/
-%{_libdir}/gcc/%{cygwin32_target}/%{version}/include/c++/org/
-%{_libdir}/gcc/%{cygwin32_target}/%{version}/include/c++/sun/
-%{_libdir}/gcc/%{cygwin32_target}/%{version}/include/gcj/
-%{_libdir}/gcc/%{cygwin32_target}/%{version}/include/jawt*.h
-%{_libdir}/gcc/%{cygwin32_target}/%{version}/include/jni*.h
-%{_libdir}/gcc/%{cygwin32_target}/%{version}/include/jvmpi.h
-%{_libdir}/gcc/%{cygwin32_target}/%{version}/libgcj.dll.a
-%{_libdir}/gcc/%{cygwin32_target}/%{version}/libgcj-noncore.dll.a
-%{_libdir}/gcc/%{cygwin32_target}/%{version}/libgcj.spec
-%{_libdir}/gcc/%{cygwin32_target}/%{version}/libgcj-tools.dll.a
-%{_libdir}/gcc/%{cygwin32_target}/%{version}/libgij.dll.a
-%{_libexecdir}/gcc/%{cygwin32_target}/%{version}/ecj1
-%{_libexecdir}/gcc/%{cygwin32_target}/%{version}/jc1
-%{_libexecdir}/gcc/%{cygwin32_target}/%{version}/jvgenmain
-%{cygwin32_bindir}/cyggcj-14.dll
-%{cygwin32_bindir}/cyggcj-noncore-14.dll
-%{cygwin32_bindir}/cyggcj-tools-14.dll
-%{cygwin32_bindir}/cyggij-14.dll
-%{cygwin32_bindir}/cygjvm.dll
-%{cygwin32_libdir}/pkgconfig/libgcj-4.8.pc
-%{_datadir}/gcc-%{gcc_version}/%{cygwin32_target}/java
-%endif
-
-
%changelog
+* Tue Jun 10 2014 Yaakov Selkowitz <yselkowitz@users.sourceforge.net> - 4.8.3-1
+- Version bump.
+- Remove java support (dropped from F21/EL7).
+- Added patch to support default manifest.
+
* Tue Jan 21 2014 Yaakov Selkowitz <yselkowitz@users.sourceforge.net> - 4.8.2-2
- Fix 64-bit builtin types for i686-cygwin target.