summaryrefslogtreecommitdiffstats
path: root/cygwin-gcc.spec
diff options
context:
space:
mode:
Diffstat (limited to 'cygwin-gcc.spec')
-rw-r--r--cygwin-gcc.spec15
1 files changed, 8 insertions, 7 deletions
diff --git a/cygwin-gcc.spec b/cygwin-gcc.spec
index 680444e..801b26f 100644
--- a/cygwin-gcc.spec
+++ b/cygwin-gcc.spec
@@ -7,7 +7,7 @@
%global gcc_version %{gcc_major}.%{gcc_minor}.%{gcc_micro}
# Note, gcc_release must be integer, if you want to add suffixes to
# %%{release}, append them after %%{gcc_release} on Release: line.
-%global gcc_release 3
+%global gcc_release 5
%global build_ada 0
# building cross-gnat requires matching X.Y version of native gnat
@@ -21,7 +21,7 @@
Name: cygwin-gcc
Version: %{gcc_version}
-Release: %{gcc_release}.1%{?dist}
+Release: %{gcc_release}%{?dist}
Summary: Cygwin GCC cross-compiler
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ with exceptions
@@ -61,6 +61,7 @@ Patch23: gcc48-Wimplicit-decls.patch
Patch24: gcc49-default-manifest.patch
Patch25: gcc48-libgcc-deregister.patch
Patch26: gcc48-__cxa_atexit.patch
+Patch27: gcc48-libstdc-atexit_thread.patch
%description
@@ -199,6 +200,7 @@ Cygwin cross-compiler for Ada.
%patch24 -p0
%patch25 -p0
%patch26 -p2
+%patch27 -p0
echo %{gcc_version} > gcc/BASE-VER
echo 'Fedora Cygwin %{gcc_version}-%{gcc_release}' > gcc/DEV-PHASE
@@ -281,10 +283,6 @@ popd
%find_lang cygwin32-cpplib
-%clean
-rm -rf $RPM_BUILD_ROOT
-
-
%files -n cygwin32-gcc -f cygwin32-gcc.lang
%{_bindir}/%{cygwin32_target}-gcc
%{_bindir}/%{cygwin32_target}-gcc-%{version}
@@ -408,7 +406,10 @@ rm -rf $RPM_BUILD_ROOT
%changelog
-* Thu Aug 07 2014 Yaakov Selkowitz <yselkowi@redhat.com> - 4.8.3-3.1
+* Mon Aug 11 2014 Yaakov Selkowitz <yselkowi@redhat.com> - 4.8.3-5
+- Separate Win32 patch for __cxa_thread_atexit.
+
+* Thu Aug 07 2014 Yaakov Selkowitz <yselkowi@redhat.com> - 4.8.3-4
- Build with --enable-__cxa_atexit
* Wed Jul 30 2014 Yaakov Selkowitz <yselkowitz@cygwin.com> - 4.8.3-3