summaryrefslogtreecommitdiffstats
path: root/cygwin-gcc.spec
diff options
context:
space:
mode:
authorYaakov Selkowitz <yselkowi@redhat.com>2016-02-21 18:56:00 -0600
committerYaakov Selkowitz <yselkowi@redhat.com>2016-02-21 18:56:00 -0600
commit2426323bbdcaf8d5904f1f243bb2a5066dd21c8a (patch)
tree21ab325f116ab50e84ac20a77bbaf569eb56a469 /cygwin-gcc.spec
parentd9caede9a622bfa41c984c4685a7b185421c96d7 (diff)
downloadcygwin-gcc-2426323bbdcaf8d5904f1f243bb2a5066dd21c8a.tar.gz
cygwin-gcc-2426323bbdcaf8d5904f1f243bb2a5066dd21c8a.tar.xz
cygwin-gcc-2426323bbdcaf8d5904f1f243bb2a5066dd21c8a.zip
cygwin-gcc 5.3.0
Diffstat (limited to 'cygwin-gcc.spec')
-rw-r--r--cygwin-gcc.spec178
1 files changed, 120 insertions, 58 deletions
diff --git a/cygwin-gcc.spec b/cygwin-gcc.spec
index 2c73a26..1078e95 100644
--- a/cygwin-gcc.spec
+++ b/cygwin-gcc.spec
@@ -1,15 +1,11 @@
-%global gcc_major 4
-%global gcc_minor 9
-%global gcc_micro 3
-%global gcc_branch %{gcc_major}.%{gcc_minor}
-%global gcc_version %{gcc_major}.%{gcc_minor}.%{gcc_micro}
+%global gcc_version 5.3.0
# Note, gcc_release must be integer, if you want to add suffixes to
# %%{release}, append them after %%{gcc_release} on Release: line.
%global gcc_release 1
%global build_ada 0
-# building cross-gnat requires matching X.Y version of native gnat
-%if 0%{?fedora} == 21
+# building cross-gnat requires matching major version of native gnat
+%if 0%{?fedora} >= 22 && 0%{?fedora} < 24
%ifarch %{ix86} x86_64 ia64 ppc ppc64 ppc64p7 alpha %{arm} aarch64
%global build_ada 1
%endif
@@ -29,12 +25,12 @@ URL: http://gcc.gnu.org
BuildRequires: texinfo
BuildRequires: cygwin32-filesystem
BuildRequires: cygwin32-binutils
-BuildRequires: cygwin32 >= 1.7.32
+BuildRequires: cygwin32 >= 2.4.1
BuildRequires: cygwin32-w32api-headers
BuildRequires: cygwin32-w32api-runtime
BuildRequires: cygwin64-filesystem
BuildRequires: cygwin64-binutils
-BuildRequires: cygwin64 >= 1.7.32
+BuildRequires: cygwin64 >= 2.4.1
BuildRequires: cygwin64-w32api-headers
BuildRequires: cygwin64-w32api-runtime
BuildRequires: gmp-devel
@@ -43,9 +39,8 @@ BuildRequires: libmpc-devel
%if 0%{?fedora} || 0%{?rhel} >= 7
BuildRequires: libstdc++-static
%endif
-%if 0%{?fedora} >= 20
-BuildRequires: isl-devel >= 0.11.1
-BuildRequires: cloog-devel >= 0.18.0
+%if 0%{?fedora}
+BuildRequires: isl-devel >= 0.14
%endif
BuildRequires: zlib-devel
BuildRequires: flex
@@ -63,25 +58,26 @@ Patch3: 0003-AWT-Font-fix-for-Cygwin.patch
Patch4: 0004-Cygwin-ioctl-may-emit-EINVAL.patch
Patch5: 0005-use-avoid-version-if-not-tracking-SO-version.patch
Patch6: 0006-cygwin-uses-cyg-library-prefix.patch
-Patch7: 0007-bump-libgcj-version.patch
-Patch8: 0008-libatomic-libtool-fixes-for-Cygwin.patch
-Patch9: 0009-support-64bit-cygwin-too.patch
-Patch10: 0010-Avoid-installing-libffi.patch
-Patch11: 0011-libitm-libtool-fixes-for-Cygwin.patch
-Patch12: 0012-Cygwin-uses-sysv-ABI-on-x86_64.patch
-Patch13: 0013-Do-not-version-lto-plugin-on-cygwin-mingw.patch
-Patch14: 0014-add-dummy-pthread-tsaware-and-large-address-aware-fo.patch
-Patch15: 0015-handle-dllimport-properly-in-medium-model.patch
-Patch16: 0016-skip-test-for-cygwin-mingw.patch
-Patch17: 0017-64bit-Cygwin-uses-SEH.patch
-Patch18: 0018-define-RTS_CONTROL_ENABLE-and-DTR_CONTROL_ENABLE-for.patch
-Patch19: 0019-fix-some-implicit-declaration-warnings.patch
-Patch20: 0020-fix-gnat-DLL-prefix-for-Cygwin.patch
-Patch21: 0021-__cxa-atexit-for-Cygwin.patch
-Patch22: 0022-prevent-modules-from-being-unloaded-before-their-dto.patch
-Patch23: 0023-Attempt-to-fix-dw2-unwinder-for-Cygwin.patch
-Patch24: 0024-Restore-compile-mode-pthread.patch
-Patch25: 0025-fix-cygwin-stdint.patch
+Patch7: 0007-Avoid-installing-libffi.patch
+#Patch8: 0008-libitm-libtool-fixes-for-Cygwin.patch
+Patch9: 0009-Cygwin-uses-sysv-ABI-on-x86_64.patch
+Patch10: 0010-Do-not-version-lto-plugin-on-cygwin-mingw.patch
+Patch11: 0011-add-dummy-pthread-tsaware-and-large-address-aware-fo.patch
+Patch12: 0012-handle-dllimport-properly-in-medium-model.patch
+Patch13: 0013-skip-test-for-cygwin-mingw.patch
+Patch14: 0014-64bit-Cygwin-uses-SEH.patch
+Patch15: 0015-define-RTS_CONTROL_ENABLE-and-DTR_CONTROL_ENABLE-for.patch
+Patch16: 0016-fix-some-implicit-declaration-warnings.patch
+Patch17: 0017-__cxa-atexit-for-Cygwin.patch
+Patch18: 0018-prevent-modules-from-being-unloaded-before-their-dto.patch
+Patch19: 0019-Cygwin-doesn-t-do-text-mode-translations-for-file-ha.patch
+Patch20: 0020-cygwin-uses-cyg-lib-prefix.patch
+Patch21: 0021-search-usr-lib-w32api-explicitly.patch
+Patch22: 0022-libgomp-soname-cygwin-mingw.patch
+Patch23: 0023-glibcxx-use-c99.patch
+Patch24: 0024-libitm-weak-symbols.patch
+Patch25: 0025-enable-libcilkrts.patch
+Patch26: 0026-g++-gnu-source.patch
# Fedora-specific patches
Patch1000: 1000-cross-exe-suffix.patch
@@ -104,17 +100,20 @@ Group: Development/Languages
# NB: Explicit cygwin32-filesystem dependency is REQUIRED here.
Requires: cygwin32-filesystem
Requires: cygwin32-binutils
-Requires: cygwin32 >= 1.7.32
+Requires: cygwin32 >= 2.4.1
Requires: cygwin32-default-manifest
Requires: cygwin32-w32api-runtime
Requires: cygwin32-cpp = %{version}-%{release}
# We don't run the automatic dependency scripts which would
# normally detect and provide the following DLL:
Provides: cygwin32(cygatomic-1.dll)
+Provides: cygwin32(cygcilkrts-5.dll)
Provides: cygwin32(cyggcc_s-1.dll)
Provides: cygwin32(cyggomp-1.dll)
Provides: cygwin32(cygquadmath-0.dll)
Provides: cygwin32(cygssp-0.dll)
+Provides: cygwin32(cygvtv-0.dll)
+Provides: cygwin32(cygvtv_stubs-0.dll)
# for backwards compatibility (libquadmath is new to 4.7)
Provides: cygwin(cyggcc_s-1.dll)
Provides: cygwin(cyggomp-1.dll)
@@ -211,8 +210,8 @@ Requires: cygwin32-gcc = %{version}-%{release}
# We don't run the automatic dependency scripts which would
# normally detect and provide the following DLL:
# (shared libgnat doesn't work quite right, nor does it cross-build
-#Provides: cygwin32(cyggnat-4.7.dll)
-#Provides: cygwin32(cyggnarl-4.7.dll)
+#Provides: cygwin32(cyggnat-5.dll)
+#Provides: cygwin32(cyggnarl-5.dll)
# for backwards compatibility
Provides: %{name}-gnat = %{version}-%{release}
Obsoletes: %{name}-gnat < 4.7
@@ -226,17 +225,20 @@ Group: Development/Languages
# NB: Explicit cygwin-filesystem dependency is REQUIRED here.
Requires: cygwin64-filesystem
Requires: cygwin64-binutils
-Requires: cygwin64 >= 1.7.32
+Requires: cygwin64 >= 2.4.1
Requires: cygwin64-default-manifest
Requires: cygwin64-w32api-runtime
Requires: cygwin64-cpp = %{version}-%{release}
# We don't run the automatic dependency scripts which would
# normally detect and provide the following DLLs:
Provides: cygwin64(cygatomic-1.dll)
+Provides: cygwin64(cygcilkrts-5.dll)
Provides: cygwin64(cyggcc_s-seh-1.dll)
Provides: cygwin64(cyggomp-1.dll)
Provides: cygwin64(cygquadmath-0.dll)
Provides: cygwin64(cygssp-0.dll)
+Provides: cygwin64(cygvtv-0.dll)
+Provides: cygwin64(cygvtv_stubs-0.dll)
# prevent update errors
%if ! %{build_ada}
Obsoletes: cygwin64-gcc-gnat < %{version}-%{release}
@@ -308,8 +310,8 @@ Requires: cygwin64-gcc = %{version}-%{release}
# We don't run the automatic dependency scripts which would
# normally detect and provide the following DLL:
# (shared libgnat doesn't work quite right, nor does it cross-build
-#Provides: cygwin64(cyggnat-4.7.dll)
-#Provides: cygwin64(cyggnarl-4.7.dll)
+#Provides: cygwin64(cyggnat-5.dll)
+#Provides: cygwin64(cyggnarl-5.dll)
%description -n cygwin64-gcc-gnat
Cygwin x86_64 cross-compiler for Ada.
@@ -324,7 +326,7 @@ Cygwin x86_64 cross-compiler for Ada.
%patch5 -p1
%patch6 -p1
%patch7 -p1
-%patch8 -p1
+#patch8 -p1
%patch9 -p1
%patch10 -p1
%patch11 -p1
@@ -339,9 +341,10 @@ Cygwin x86_64 cross-compiler for Ada.
%patch20 -p1
%patch21 -p1
%patch22 -p1
-%patch23 -p1
+%patch23 -p2
%patch24 -p1
-%patch25 -p1
+%patch25 -p2
+%patch26 -p2
%patch1000 -p1
%patch1001 -p1
@@ -351,6 +354,10 @@ echo 'Fedora Cygwin %{gcc_version}-%{gcc_release}' > gcc/DEV-PHASE
%build
+# configure tries to test SUSv4-compliant behaviour of
+# realpath(..., NULL) via _XOPEN_VERSION
+export glibcxx_cv_realpath=yes
+
mkdir -p build_cyg32
pushd build_cyg32
@@ -378,13 +385,19 @@ CC="%{__cc} ${RPM_OPT_FLAGS}" \
--with-sysroot=%{cygwin32_sysroot} \
--enable-shared --enable-shared-libgcc --enable-__cxa_atexit \
--with-dwarf2 --disable-sjlj-exceptions \
-%if 0%{?fedora} >= 20
+%if 0%{?fedora}
--enable-graphite \
%endif
--enable-languages="c,c++,objc,obj-c++,fortran${enablelada},lto" \
+ --disable-libcc1 \
--enable-lto --disable-symvers \
- --enable-libgomp --disable-libitm --enable-libssp \
+ --enable-libatomic \
+ --enable-libcilkrts \
+ --enable-libgomp \
+ --enable-libitm \
+ --enable-libssp \
--enable-libquadmath --enable-libquadmath-support \
+ --with-default-libstdcxx-abi=gcc4-compatible \
--with-python-dir=/share/gcc-%{gcc_version}/%{cygwin32_target}/python \
%if %{build_ada}
--enable-libada \
@@ -422,13 +435,19 @@ CC="%{__cc} ${RPM_OPT_FLAGS}" \
--with-sysroot=%{cygwin64_sysroot} \
--enable-shared --enable-shared-libgcc --enable-__cxa_atexit \
--with-dwarf2 \
-%if 0%{?fedora} >= 20
+%if 0%{?fedora}
--enable-graphite \
%endif
--enable-languages="c,c++,objc,obj-c++,fortran${enablelada},lto" \
+ --disable-libcc1 \
--enable-lto --disable-symvers \
- --enable-libgomp --disable-libitm --enable-libssp \
+ --enable-libatomic \
+ --enable-libcilkrts \
+ --enable-libgomp \
+ --enable-libitm \
+ --enable-libssp \
--enable-libquadmath --enable-libquadmath-support \
+ --with-default-libstdcxx-abi=gcc4-compatible \
--with-python-dir=/share/gcc-%{gcc_version}/%{cygwin64_target}/python \
%if %{build_ada}
--enable-libada \
@@ -467,6 +486,17 @@ ln -sf ..%{_prefix}/bin/%{cygwin64_target}-cpp \
mv $RPM_BUILD_ROOT%{_prefix}/lib/gcc/%{cygwin64_target}/lib/libgcc_s.dll.a \
$RPM_BUILD_ROOT%{_prefix}/lib/gcc/%{cygwin64_target}/%{gcc_version}/
+# clean-up include-fixed
+mv $RPM_BUILD_ROOT%{_prefix}/lib/gcc/%{cygwin32_target}/%{gcc_version}/include-fixed/*limits.h \
+ $RPM_BUILD_ROOT%{_prefix}/lib/gcc/%{cygwin32_target}/%{gcc_version}/include/
+mv $RPM_BUILD_ROOT%{_prefix}/lib/gcc/%{cygwin64_target}/%{gcc_version}/include-fixed/*limits.h \
+ $RPM_BUILD_ROOT%{_prefix}/lib/gcc/%{cygwin64_target}/%{gcc_version}/include/
+rm -fr $RPM_BUILD_ROOT%{_prefix}/lib/gcc/%{cygwin32_target}/%{gcc_version}/include-fixed/
+rm -fr $RPM_BUILD_ROOT%{_prefix}/lib/gcc/%{cygwin64_target}/%{gcc_version}/include-fixed/
+
+# This is a runtime plugin of libgomp, not a link library
+rm -f $RPM_BUILD_ROOT%{_prefix}/lib/gcc/*/%{version}/libgomp-plugin-host_nonshm.dll.a
+
# libtool installs DLL files of runtime libraries into $(libdir)/../bin,
# but we need them in cygwin*_bindir.
mkdir -p $RPM_BUILD_ROOT%{cygwin32_bindir}
@@ -499,6 +529,7 @@ cat cygwin-cpplib.lang >> cygwin-gcc.lang
%{_bindir}/%{cygwin32_target}-gcc-nm
%{_bindir}/%{cygwin32_target}-gcc-ranlib
%{_bindir}/%{cygwin32_target}-gcov
+%{_bindir}/%{cygwin32_target}-gcov-tool
%dir %{_prefix}/lib/gcc/%{cygwin32_target}
%dir %{_prefix}/lib/gcc/%{cygwin32_target}/%{version}
%{_prefix}/lib/gcc/%{cygwin32_target}/%{version}/crtbegin.o
@@ -507,6 +538,9 @@ cat cygwin-cpplib.lang >> cygwin-gcc.lang
%{_prefix}/lib/gcc/%{cygwin32_target}/%{version}/crtfastmath.o
%{_prefix}/lib/gcc/%{cygwin32_target}/%{version}/libatomic.a
%{_prefix}/lib/gcc/%{cygwin32_target}/%{version}/libatomic.dll.a
+%{_prefix}/lib/gcc/%{cygwin32_target}/%{version}/libcilkrts.a
+%{_prefix}/lib/gcc/%{cygwin32_target}/%{version}/libcilkrts.dll.a
+%{_prefix}/lib/gcc/%{cygwin32_target}/%{version}/libcilkrts.spec
%{_prefix}/lib/gcc/%{cygwin32_target}/%{version}/libgcc.a
%{_prefix}/lib/gcc/%{cygwin32_target}/%{version}/libgcc_eh.a
%{_prefix}/lib/gcc/%{cygwin32_target}/%{version}/libgcc_s.dll.a
@@ -514,16 +548,23 @@ cat cygwin-cpplib.lang >> cygwin-gcc.lang
%{_prefix}/lib/gcc/%{cygwin32_target}/%{version}/libgomp.a
%{_prefix}/lib/gcc/%{cygwin32_target}/%{version}/libgomp.dll.a
%{_prefix}/lib/gcc/%{cygwin32_target}/%{version}/libgomp.spec
+%{_prefix}/lib/gcc/%{cygwin32_target}/%{version}/libitm.a
+%{_prefix}/lib/gcc/%{cygwin32_target}/%{version}/libitm.spec
%{_prefix}/lib/gcc/%{cygwin32_target}/%{version}/libquadmath.a
%{_prefix}/lib/gcc/%{cygwin32_target}/%{version}/libquadmath.dll.a
%{_prefix}/lib/gcc/%{cygwin32_target}/%{version}/libssp.a
%{_prefix}/lib/gcc/%{cygwin32_target}/%{version}/libssp_nonshared.a
%{_prefix}/lib/gcc/%{cygwin32_target}/%{version}/libssp.dll.a
+%{_prefix}/lib/gcc/%{cygwin32_target}/%{version}/libvtv.a
+%{_prefix}/lib/gcc/%{cygwin32_target}/%{version}/libvtv.dll.a
+%{_prefix}/lib/gcc/%{cygwin32_target}/%{version}/libvtv_stubs.a
+%{_prefix}/lib/gcc/%{cygwin32_target}/%{version}/libvtv_stubs.dll.a
%dir %{_prefix}/lib/gcc/%{cygwin32_target}/%{version}/include
+%dir %{_prefix}/lib/gcc/%{cygwin32_target}/%{version}/include/cilk
%dir %{_prefix}/lib/gcc/%{cygwin32_target}/%{version}/include/ssp
%{_prefix}/lib/gcc/%{cygwin32_target}/%{version}/include/[^j]*.h
+%{_prefix}/lib/gcc/%{cygwin32_target}/%{version}/include/cilk/*.h
%{_prefix}/lib/gcc/%{cygwin32_target}/%{version}/include/ssp/*.h
-%{_prefix}/lib/gcc/%{cygwin32_target}/%{version}/include-fixed/
%dir %{_prefix}/lib/gcc/%{cygwin32_target}/%{version}/install-tools
%{_prefix}/lib/gcc/%{cygwin32_target}/%{version}/install-tools/*
%{_prefix}/lib/gcc/%{cygwin32_target}/%{version}/plugin/
@@ -536,10 +577,14 @@ cat cygwin-cpplib.lang >> cygwin-gcc.lang
%dir %{_datadir}/gcc-%{gcc_version}
%dir %{_datadir}/gcc-%{gcc_version}/%{cygwin32_target}
%{cygwin32_bindir}/cygatomic-1.dll
+%{cygwin32_bindir}/cygcilkrts-5.dll
%{cygwin32_bindir}/cyggcc_s-1.dll
%{cygwin32_bindir}/cyggomp-1.dll
+%{cygwin32_bindir}/cyggomp-plugin-host_nonshm-1.dll
%{cygwin32_bindir}/cygquadmath-0.dll
%{cygwin32_bindir}/cygssp-0.dll
+%{cygwin32_bindir}/cygvtv-0.dll
+%{cygwin32_bindir}/cygvtv_stubs-0.dll
%{_mandir}/man1/%{cygwin32_target}-gcc.1*
%{_mandir}/man1/%{cygwin32_target}-gcov.1*
@@ -593,10 +638,9 @@ cat cygwin-cpplib.lang >> cygwin-gcc.lang
%{_prefix}/lib/gcc/%{cygwin32_target}/%{version}/libgfortran.spec
%{_prefix}/lib/gcc/%{cygwin32_target}/%{version}/libgfortranbegin.a
%dir %{_prefix}/lib/gcc/%{cygwin32_target}/%{version}/finclude
-%{_prefix}/lib/gcc/%{cygwin32_target}/%{version}/finclude/omp_lib.f90
-%{_prefix}/lib/gcc/%{cygwin32_target}/%{version}/finclude/omp_lib.h
-%{_prefix}/lib/gcc/%{cygwin32_target}/%{version}/finclude/omp_lib.mod
-%{_prefix}/lib/gcc/%{cygwin32_target}/%{version}/finclude/omp_lib_kinds.mod
+%{_prefix}/lib/gcc/%{cygwin32_target}/%{version}/finclude/ieee_*
+%{_prefix}/lib/gcc/%{cygwin32_target}/%{version}/finclude/omp_lib*
+%{_prefix}/lib/gcc/%{cygwin32_target}/%{version}/finclude/openacc*
%{_libexecdir}/gcc/%{cygwin32_target}/%{version}/f951
%{cygwin32_bindir}/cyggfortran-3.dll
@@ -608,8 +652,8 @@ cat cygwin-cpplib.lang >> cygwin-gcc.lang
%{_prefix}/lib/gcc/%{cygwin32_target}/%{version}/adainclude/
%{_prefix}/lib/gcc/%{cygwin32_target}/%{version}/adalib/
%{_libexecdir}/gcc/%{cygwin32_target}/%{version}/gnat1
-#%%{cygwin32_bindir}/cyggnarl-4.7.dll
-#%%{cygwin32_bindir}/cyggnat-4.7.dll
+#%%{cygwin32_bindir}/cyggnarl-5.dll
+#%%{cygwin32_bindir}/cyggnat-5.dll
%endif
%files -n cygwin64-gcc
@@ -619,6 +663,7 @@ cat cygwin-cpplib.lang >> cygwin-gcc.lang
%{_bindir}/%{cygwin64_target}-gcc-nm
%{_bindir}/%{cygwin64_target}-gcc-ranlib
%{_bindir}/%{cygwin64_target}-gcov
+%{_bindir}/%{cygwin64_target}-gcov-tool
%dir %{_prefix}/lib/gcc/%{cygwin64_target}
%dir %{_prefix}/lib/gcc/%{cygwin64_target}/%{version}
%{_prefix}/lib/gcc/%{cygwin64_target}/%{version}/crtbegin.o
@@ -627,6 +672,9 @@ cat cygwin-cpplib.lang >> cygwin-gcc.lang
%{_prefix}/lib/gcc/%{cygwin64_target}/%{version}/crtfastmath.o
%{_prefix}/lib/gcc/%{cygwin64_target}/%{version}/libatomic.a
%{_prefix}/lib/gcc/%{cygwin64_target}/%{version}/libatomic.dll.a
+%{_prefix}/lib/gcc/%{cygwin64_target}/%{version}/libcilkrts.a
+%{_prefix}/lib/gcc/%{cygwin64_target}/%{version}/libcilkrts.dll.a
+%{_prefix}/lib/gcc/%{cygwin64_target}/%{version}/libcilkrts.spec
%{_prefix}/lib/gcc/%{cygwin64_target}/%{version}/libgcc.a
%{_prefix}/lib/gcc/%{cygwin64_target}/%{version}/libgcc_eh.a
%{_prefix}/lib/gcc/%{cygwin64_target}/%{version}/libgcc_s.dll.a
@@ -634,16 +682,23 @@ cat cygwin-cpplib.lang >> cygwin-gcc.lang
%{_prefix}/lib/gcc/%{cygwin64_target}/%{version}/libgomp.a
%{_prefix}/lib/gcc/%{cygwin64_target}/%{version}/libgomp.dll.a
%{_prefix}/lib/gcc/%{cygwin64_target}/%{version}/libgomp.spec
+%{_prefix}/lib/gcc/%{cygwin64_target}/%{version}/libitm.a
+%{_prefix}/lib/gcc/%{cygwin64_target}/%{version}/libitm.spec
%{_prefix}/lib/gcc/%{cygwin64_target}/%{version}/libquadmath.a
%{_prefix}/lib/gcc/%{cygwin64_target}/%{version}/libquadmath.dll.a
%{_prefix}/lib/gcc/%{cygwin64_target}/%{version}/libssp.a
%{_prefix}/lib/gcc/%{cygwin64_target}/%{version}/libssp_nonshared.a
%{_prefix}/lib/gcc/%{cygwin64_target}/%{version}/libssp.dll.a
+%{_prefix}/lib/gcc/%{cygwin64_target}/%{version}/libvtv.a
+%{_prefix}/lib/gcc/%{cygwin64_target}/%{version}/libvtv.dll.a
+%{_prefix}/lib/gcc/%{cygwin64_target}/%{version}/libvtv_stubs.a
+%{_prefix}/lib/gcc/%{cygwin64_target}/%{version}/libvtv_stubs.dll.a
%dir %{_prefix}/lib/gcc/%{cygwin64_target}/%{version}/include
+%dir %{_prefix}/lib/gcc/%{cygwin64_target}/%{version}/include/cilk
%dir %{_prefix}/lib/gcc/%{cygwin64_target}/%{version}/include/ssp
%{_prefix}/lib/gcc/%{cygwin64_target}/%{version}/include/[^j]*.h
+%{_prefix}/lib/gcc/%{cygwin64_target}/%{version}/include/cilk/*.h
%{_prefix}/lib/gcc/%{cygwin64_target}/%{version}/include/ssp/*.h
-%{_prefix}/lib/gcc/%{cygwin64_target}/%{version}/include-fixed/
%dir %{_prefix}/lib/gcc/%{cygwin64_target}/%{version}/install-tools
%{_prefix}/lib/gcc/%{cygwin64_target}/%{version}/install-tools/*
%{_prefix}/lib/gcc/%{cygwin64_target}/%{version}/plugin/
@@ -656,10 +711,14 @@ cat cygwin-cpplib.lang >> cygwin-gcc.lang
%dir %{_datadir}/gcc-%{gcc_version}
%dir %{_datadir}/gcc-%{gcc_version}/%{cygwin64_target}
%{cygwin64_bindir}/cygatomic-1.dll
+%{cygwin64_bindir}/cygcilkrts-5.dll
%{cygwin64_bindir}/cyggcc_s-seh-1.dll
%{cygwin64_bindir}/cyggomp-1.dll
+%{cygwin64_bindir}/cyggomp-plugin-host_nonshm-1.dll
%{cygwin64_bindir}/cygquadmath-0.dll
%{cygwin64_bindir}/cygssp-0.dll
+%{cygwin64_bindir}/cygvtv-0.dll
+%{cygwin64_bindir}/cygvtv_stubs-0.dll
%{_mandir}/man1/%{cygwin64_target}-gcc.1*
%{_mandir}/man1/%{cygwin64_target}-gcov.1*
@@ -713,10 +772,9 @@ cat cygwin-cpplib.lang >> cygwin-gcc.lang
%{_prefix}/lib/gcc/%{cygwin64_target}/%{version}/libgfortran.spec
%{_prefix}/lib/gcc/%{cygwin64_target}/%{version}/libgfortranbegin.a
%dir %{_prefix}/lib/gcc/%{cygwin64_target}/%{version}/finclude
-%{_prefix}/lib/gcc/%{cygwin64_target}/%{version}/finclude/omp_lib.f90
-%{_prefix}/lib/gcc/%{cygwin64_target}/%{version}/finclude/omp_lib.h
-%{_prefix}/lib/gcc/%{cygwin64_target}/%{version}/finclude/omp_lib.mod
-%{_prefix}/lib/gcc/%{cygwin64_target}/%{version}/finclude/omp_lib_kinds.mod
+%{_prefix}/lib/gcc/%{cygwin64_target}/%{version}/finclude/ieee_*
+%{_prefix}/lib/gcc/%{cygwin64_target}/%{version}/finclude/omp_lib*
+%{_prefix}/lib/gcc/%{cygwin64_target}/%{version}/finclude/openacc*
%{_libexecdir}/gcc/%{cygwin64_target}/%{version}/f951
%{cygwin64_bindir}/cyggfortran-3.dll
@@ -728,12 +786,16 @@ cat cygwin-cpplib.lang >> cygwin-gcc.lang
%{_prefix}/lib/gcc/%{cygwin64_target}/%{version}/adainclude/
%{_prefix}/lib/gcc/%{cygwin64_target}/%{version}/adalib/
%{_libexecdir}/gcc/%{cygwin64_target}/%{version}/gnat1
-#%%{cygwin64_bindir}/cyggnarl-4.7.dll
-#%%{cygwin64_bindir}/cyggnat-4.7.dll
+#%%{cygwin64_bindir}/cyggnarl-5.dll
+#%%{cygwin64_bindir}/cyggnat-5.dll
%endif
%changelog
+* Sun Feb 21 2016 Yaakov Selkowitz <yselkowi@redhat.com> - 5.3.0-1
+- new version
+- Enable libcilkrts, libitm, libvtv
+
* Fri Aug 14 2015 Yaakov Selkowitz <yselkowi@redhat.com> - 4.9.3-1
- Update to 4.9.3