summaryrefslogtreecommitdiffstats
path: root/cygwin-binutils.spec
diff options
context:
space:
mode:
authorYaakov Selkowitz <yselkowitz@users.sourceforge.net>2011-02-17 04:08:23 -0600
committerYaakov Selkowitz <yselkowitz@users.sourceforge.net>2011-02-17 04:08:23 -0600
commit86f5e4614beb9fefdd584305382628364e427950 (patch)
treeae27556441ce9dd7d7a90fd4784dfc19fe5e81cd /cygwin-binutils.spec
downloadcygwin-binutils-86f5e4614beb9fefdd584305382628364e427950.tar.gz
cygwin-binutils-86f5e4614beb9fefdd584305382628364e427950.tar.xz
cygwin-binutils-86f5e4614beb9fefdd584305382628364e427950.zip
Initial commit
Diffstat (limited to 'cygwin-binutils.spec')
-rw-r--r--cygwin-binutils.spec74
1 files changed, 74 insertions, 0 deletions
diff --git a/cygwin-binutils.spec b/cygwin-binutils.spec
new file mode 100644
index 0000000..3cf46e1
--- /dev/null
+++ b/cygwin-binutils.spec
@@ -0,0 +1,74 @@
+Name: cygwin-binutils
+Version: 2.21
+Release: 1%{?dist}
+Summary: Cygwin binutils
+
+License: GPLv2+ and LGPLv2+ and GPLv3+ and LGPLv3+
+Group: Development/Libraries
+URL: http://www.gnu.org/software/binutils/
+Source0: http://ftp.gnu.org/gnu/binutils/binutils-%{version}.tar.bz2
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+
+BuildRequires: flex
+BuildRequires: bison
+BuildRequires: texinfo
+BuildRequires: cygwin-filesystem
+
+# NB: This must be left in.
+Requires: cygwin-filesystem
+
+
+%description
+Cygwin binutils (utilities like 'strip', 'as', 'ld') which
+understand Cygwin PE executables and DLLs.
+
+
+%prep
+%setup -q -n binutils-%{version}
+
+
+%build
+mkdir -p build
+cd build
+CFLAGS="$RPM_OPT_FLAGS" \
+../configure \
+ --build=%_build --host=%_host \
+ --target=%{_cygwin_target} \
+ --verbose --disable-nls \
+ --without-included-gettext \
+ --disable-win32-registry \
+ --disable-werror \
+ --with-sysroot=%{_cygwin_sysroot} \
+ --prefix=%{_prefix} --bindir=%{_bindir} \
+ --includedir=%{_includedir} --libdir=%{_libdir} \
+ --mandir=%{_mandir} --infodir=%{_infodir}
+
+make all
+
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+cd build
+make DESTDIR=$RPM_BUILD_ROOT install
+
+# These files conflict with ordinary binutils.
+rm -rf $RPM_BUILD_ROOT%{_infodir}
+rm -f ${RPM_BUILD_ROOT}%{_libdir}/libiberty*
+
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+
+%files
+%defattr(-,root,root)
+%{_mandir}/man1/*
+%{_bindir}/i686-pc-cygwin-*
+%{_prefix}/i686-pc-cygwin/bin
+%{_prefix}/i686-pc-cygwin/lib/ldscripts
+
+
+%changelog
+* Wed Feb 16 2011 Yaakov Selkowitz <yselkowitz@users.sourceforge.net> - 2.21-1
+- Initial RPM release, largely based on mingw32-binutils.