summaryrefslogtreecommitdiffstats
path: root/install/configure.ac
diff options
context:
space:
mode:
authorPetr Viktorin <pviktori@redhat.com>2012-06-20 06:38:16 -0400
committerRob Crittenden <rcritten@redhat.com>2012-07-24 16:54:21 -0400
commit23e188f2260f60e05cc7c33b029440db2253a170 (patch)
tree9ca3f6babeccbba8c19b1346c6ed6a54f13fbaad /install/configure.ac
parentcc42d19e35ee54b9fcf82e70b7897a6d386d08b9 (diff)
downloadfreeipa-23e188f2260f60e05cc7c33b029440db2253a170.tar.gz
freeipa-23e188f2260f60e05cc7c33b029440db2253a170.tar.xz
freeipa-23e188f2260f60e05cc7c33b029440db2253a170.zip
Arrange stripping .po files
The .po files we use for translations have two shortcomings when used in Git: - They include file locations, which change each time the source is updated. This results in large, unreadable diffs that don't merge well. - They include source strings for untranslated messages, wasting space unnecessarily. Update the Makefile so that the extraneous information is stripped when the files are updated or pulled form Transifex, and empty translation files are removed entirely. Also, translations are normalized to a common style. This should help diffs and merges. The validator requires file location comments to identify the programming language, and to produce good error reports. To make this work, merge the comments in before validation. First patch for: https://fedorahosted.org/freeipa/ticket/2435
Diffstat (limited to 'install/configure.ac')
-rw-r--r--install/configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/install/configure.ac b/install/configure.ac
index 827ddbab4..9e781a684 100644
--- a/install/configure.ac
+++ b/install/configure.ac
@@ -48,6 +48,11 @@ if test "x$MSGCMP" = "xno"; then
AC_MSG_ERROR([msgcmp not found, install gettext])
fi
+AC_PATH_PROG(MSGATTRIB, msgattrib, [no])
+if test "x$MSGATTRIB" = "xno"; then
+ AC_MSG_ERROR([msgattrib not found, install gettext])
+fi
+
AC_PATH_PROG(TX, tx, [/usr/bin/tx])
AC_ARG_WITH([gettext_domain],