summaryrefslogtreecommitdiffstats
path: root/python-mock.spec
diff options
context:
space:
mode:
authorPraveen <daredevil@localhost.localdomain>2012-02-01 22:06:34 +0530
committerPraveen <daredevil@localhost.localdomain>2012-02-01 22:06:34 +0530
commit68369d0bdf98902ced9d603308cdc83b084e6c3f (patch)
tree0aaebf0266c36f59b4fb0aa4ee4cb568b582a066 /python-mock.spec
parentcc1e31528729b7fe0bd07912a74953187dca8b9c (diff)
downloadpython-mock-68369d0bdf98902ced9d603308cdc83b084e6c3f.tar.gz
python-mock-68369d0bdf98902ced9d603308cdc83b084e6c3f.tar.xz
python-mock-68369d0bdf98902ced9d603308cdc83b084e6c3f.zip
Initial import (#724936).
Diffstat (limited to 'python-mock.spec')
-rw-r--r--python-mock.spec46
1 files changed, 46 insertions, 0 deletions
diff --git a/python-mock.spec b/python-mock.spec
new file mode 100644
index 0000000..192d418
--- /dev/null
+++ b/python-mock.spec
@@ -0,0 +1,46 @@
+%global mod_name mock
+
+Name: python-mock
+Version: 0.7.2
+Release: 1%{?dist}
+Summary: A Python Mocking and Patching Library for Testing
+
+Group: Development/Libraries
+License: BSD
+URL: http://www.voidspace.org.uk/python/%{mod_name}/
+Source0: http://pypi.python.org/packages/source/m/%{mod_name}/%{mod_name}-%{version}.tar.gz
+Source1: LICENSE.txt
+
+BuildArch: noarch
+BuildRequires: python-devel
+
+%description
+Mock is a Python module that provides a core mock class. It removes the need
+to create a host of stubs throughout your test suite. After performing an
+action, you can make assertions about which methods / attributes were used and
+arguments they were called with. You can also specify return values and set
+needed attributes in the normal way.
+
+
+%prep
+%setup -q -n %{mod_name}-%{version}
+cp -p %{SOURCE1} .
+
+%build
+CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py build
+
+
+%install
+rm -rf $RPM_BUILD_ROOT
+%{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
+
+
+%files
+%doc docs/ README.txt PKG-INFO LICENSE.txt
+%{python_sitelib}/*.egg-info/
+%{python_sitelib}/%{mod_name}.py*
+
+
+%changelog
+* Fri Jul 22 2011 Praveen Kumar <kumarpraveen.nitdgp@gmail.com> - 0.7.2-1
+- Initial RPM release