summaryrefslogtreecommitdiffstats
path: root/perl-Unix-Statgrab.spec
diff options
context:
space:
mode:
Diffstat (limited to 'perl-Unix-Statgrab.spec')
-rw-r--r--perl-Unix-Statgrab.spec77
1 files changed, 50 insertions, 27 deletions
diff --git a/perl-Unix-Statgrab.spec b/perl-Unix-Statgrab.spec
index 5cbbf85..efb5726 100644
--- a/perl-Unix-Statgrab.spec
+++ b/perl-Unix-Statgrab.spec
@@ -1,18 +1,44 @@
Name: perl-Unix-Statgrab
-Version: 0.04
-Release: 25.1%{?dist}
+Version: 0.109
+Release: 2%{?dist}
Summary: Perl extension for collecting information about the machine
License: LGPLv2+
-Group: Development/Libraries
URL: http://search.cpan.org/dist/Unix-Statgrab/
-Source0: http://www.cpan.org/authors/id/V/VP/VPARSEVAL/Unix-Statgrab-%{version}.tar.gz
-Patch0: Unix-Statgrab-0.04-fixedtest.patch
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-BuildRequires: libstatgrab-devel >= 0.12
-BuildRequires: perl(ExtUtils::MakeMaker)
-BuildRequires: perl(Test::Pod)
-BuildRequires: perl(Test::Pod::Coverage)
-Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
+Source0: http://www.cpan.org/authors/id/R/RE/REHSACK/Unix-Statgrab-%{version}.tar.gz
+# rt#107241
+Patch0: Unix-Statgrab-0.109-Disable-get_user_stats-tests.patch
+# Build
+BuildRequires: coreutils
+BuildRequires: findutils
+BuildRequires: gcc
+BuildRequires: make
+BuildRequires: perl
+BuildRequires: perl(Capture::Tiny)
+BuildRequires: perl(Config)
+BuildRequires: perl(Config::AutoConf)
+BuildRequires: perl(ExtUtils::CBuilder)
+BuildRequires: perl(ExtUtils::Constant)
+BuildRequires: perl(ExtUtils::MakeMaker) >= 6.76
+BuildRequires: perl(File::Basename)
+BuildRequires: perl(File::Spec)
+BuildRequires: perl(lib)
+BuildRequires: perl(parent)
+BuildRequires: perl(strict)
+BuildRequires: perl(Text::ParseWords)
+BuildRequires: perl(warnings)
+BuildRequires: pkgconfig
+BuildRequires: pkgconfig(libstatgrab) >= 0.90
+# Runtime
+BuildRequires: perl(AutoLoader)
+BuildRequires: perl(Carp)
+BuildRequires: perl(DynaLoader)
+BuildRequires: perl(Exporter)
+BuildRequires: perl(vars)
+# Tests only
+BuildRequires: perl(Test::More)
+# Optional tests only
+BuildRequires: perl(Test::LeakTrace)
+Requires: perl(:MODULE_COMPAT_%(eval "$(perl -V:version)"; echo $version))
%description
Unix::Statgrab is a wrapper for libstatgrab as available from
@@ -22,37 +48,34 @@ operating system, CPU, memory usage, network interfaces, hard-disks etc.
%prep
%setup -q -n Unix-Statgrab-%{version}
-%patch0 -p1 -b .fixedtest
+%patch0 -p1
%build
-%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"
+perl Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}" NO_PACKLIST=1
make %{?_smp_mflags}
%install
-rm -rf $RPM_BUILD_ROOT
-
-make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
-
-find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} \;
-find $RPM_BUILD_ROOT -type f -name '*.bs' -size 0 -exec rm -f {} \;
-find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null \;
-
-%{_fixperms} $RPM_BUILD_ROOT/*
+make pure_install DESTDIR=%{buildroot}
+find %{buildroot} -type f -name '*.bs' -size 0 -exec rm -f {} +
+%{_fixperms} %{buildroot}/*
%check
make test
-%clean
-rm -rf $RPM_BUILD_ROOT
-
%files
-%defattr(-,root,root,-)
-%doc Changes README
+%doc Changes README.md
%{perl_vendorarch}/auto/*
%{perl_vendorarch}/Unix*
%{_mandir}/man3/*
%changelog
+* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.109-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
+
+* Tue Sep 22 2015 Petr Ĺ abata <contyk@redhat.com> - 0.109-1
+- 0.109 bump
+- Disabling user_data tests as they seem to be broken at the moment (rt#107241)
+
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.04-25.1
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild