summaryrefslogtreecommitdiffstats
path: root/perl-Unix-Statgrab.spec
diff options
context:
space:
mode:
authorSteven Pritchard <steve@fedoraproject.org>2007-04-17 18:40:51 +0000
committerSteven Pritchard <steve@fedoraproject.org>2007-04-17 18:40:51 +0000
commit114e57baf71352338db3c144be1c7b534a020ca5 (patch)
tree6007baf911ee882b5b776ad8148fb4f325e503ac /perl-Unix-Statgrab.spec
parent56322c8e2f9227a50e10eeba687f3f9166317b99 (diff)
downloadperl-Unix-Statgrab-114e57baf71352338db3c144be1c7b534a020ca5.tar.gz
perl-Unix-Statgrab-114e57baf71352338db3c144be1c7b534a020ca5.tar.xz
perl-Unix-Statgrab-114e57baf71352338db3c144be1c7b534a020ca5.zip
BR ExtUtils::MakeMaker. Reformat to more closely resemble cpanspec output.perl-Unix-Statgrab-0_04-2_fc7F-8-startF-8-splitF-7-startF-7-split
Use fixperms macro instead of our own chmod incantation. Remove some macro other usage.
Diffstat (limited to 'perl-Unix-Statgrab.spec')
-rw-r--r--perl-Unix-Statgrab.spec68
1 files changed, 36 insertions, 32 deletions
diff --git a/perl-Unix-Statgrab.spec b/perl-Unix-Statgrab.spec
index e0a6015..0a55e7b 100644
--- a/perl-Unix-Statgrab.spec
+++ b/perl-Unix-Statgrab.spec
@@ -1,20 +1,17 @@
-Name: perl-Unix-Statgrab
-Summary: Perl extension for collecting information about the machine
-
-Version: 0.04
-Release: 1%{?dist}
-
-Group: Development/Libraries
-License: LGPL
-URL: http://search.cpan.org/dist/Unix-Statgrab/
-Source0: http://search.cpan.org/CPAN/authors/id/V/VP/VPARSEVAL/Unix-Statgrab-%{version}.tar.gz
-Source1: http://www.fsf.org/licensing/licenses/lgpl.txt
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-
-BuildRequires: libstatgrab-devel >= 0.12
-BuildRequires: perl(Test::Pod), perl(Test::Pod::Coverage)
-
-Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
+Name: perl-Unix-Statgrab
+Version: 0.04
+Release: 2%{?dist}
+Summary: Perl extension for collecting information about the machine
+License: LGPL
+Group: Development/Libraries
+URL: http://search.cpan.org/dist/Unix-Statgrab/
+Source0: http://www.cpan.org/authors/id/V/VP/VPARSEVAL/Unix-Statgrab-%{version}.tar.gz
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildRequires: libstatgrab-devel >= 0.12
+BuildRequires: perl(ExtUtils::MakeMaker)
+BuildRequires: perl(Test::Pod)
+BuildRequires: perl(Test::Pod::Coverage)
+Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
%description
Unix::Statgrab is a wrapper for libstatgrab as available from
@@ -25,34 +22,41 @@ operating system, CPU, memory usage, network interfaces, hard-disks etc.
%prep
%setup -q -n Unix-Statgrab-%{version}
-%{__cp} %{SOURCE1} LICENSE.TXT
-
%build
-CFLAGS="$RPM_OPT_FLAGS" %{__perl} Makefile.PL INSTALLDIRS=vendor
-%{__make} %{?_smp_mflags} OPTIMIZE="$RPM_OPT_FLAGS"
+%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"
+make %{?_smp_mflags}
%install
-%{__rm} -rf $RPM_BUILD_ROOT
-%{__make} pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
-find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
-find $RPM_BUILD_ROOT -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
-find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null ';'
-chmod -R u+w $RPM_BUILD_ROOT/*
+rm -rf $RPM_BUILD_ROOT
+
+make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
+
+find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} \;
+find $RPM_BUILD_ROOT -type f -name '*.bs' -size 0 -exec rm -f {} \;
+find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null \;
+
+%{_fixperms} $RPM_BUILD_ROOT/*
%check
-%{__make} test
+make test
%clean
-%{__rm} -rf $RPM_BUILD_ROOT
+rm -rf $RPM_BUILD_ROOT
%files
%defattr(-,root,root,-)
-%doc LICENSE.TXT Changes README
-%{perl_vendorarch}/Unix
+%doc Changes README
%{perl_vendorarch}/auto/*
-%{_mandir}/man3/*.3*
+%{perl_vendorarch}/Unix*
+%{_mandir}/man3/*
%changelog
+* Tue Apr 17 2007 Steven Pritchard <steve@kspei.com> 0.04-2
+- BR ExtUtils::MakeMaker.
+- Reformat to more closely resemble cpanspec output.
+- Use fixperms macro instead of our own chmod incantation.
+- Remove some macro other usage.
+
* Tue Sep 26 2006 Steven Pritchard <steve@kspei.com> 0.04-1
- Update to 0.04.
- Drop compile fix patch.