summaryrefslogtreecommitdiffstats
path: root/puppet.spec
diff options
context:
space:
mode:
Diffstat (limited to 'puppet.spec')
-rw-r--r--puppet.spec40
1 files changed, 22 insertions, 18 deletions
diff --git a/puppet.spec b/puppet.spec
index 57f23bc..f36530e 100644
--- a/puppet.spec
+++ b/puppet.spec
@@ -1,25 +1,28 @@
%{!?ruby_sitelibdir: %define ruby_sitelibdir %(ruby -rrbconfig -e 'puts Config::CONFIG["sitelibdir"]')}
%define confdir conf/redhat
-Summary: A network tool for managing many disparate systems
-Name: puppet
-Version: 0.24.5
-Release: 2%{?dist}
-License: GPLv2+
-Group: System Environment/Base
+Name: puppet
+Version: 0.24.5
+Release: 2%{?dist}
+Summary: A network tool for managing many disparate systems
-URL: http://puppet.reductivelabs.com/
-Source: http://reductivelabs.com/downloads/puppet/%{name}-%{version}.tgz
+Group: System Environment/Base
+
+License: GPLv2+
+URL: http://puppet.reductivelabs.com/
+Source0: http://reductivelabs.com/downloads/puppet/%{name}-%{version}.tgz
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+
+BuildRequires: ruby >= 1.8.1
-Requires: ruby >= 1.8.1
%if 0%{?fedora} || 0%{?rhel} >= 5
-Requires: ruby(abi) = 1.8
-Requires: ruby-shadow
-BuildArch: noarch
+BuildArch: noarch
+Requires: ruby(abi) = 1.8
+Requires: ruby-shadow
%endif
-Requires: facter >= 1.1.4
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-BuildRequires: ruby >= 1.8.1
+
+Requires: facter >= 1.1.4
+Requires: ruby >= 1.8.1
%description
Puppet lets you centrally manage every important aspect of your system using a
@@ -28,9 +31,9 @@ normally aggregated in different files, like users, cron jobs, and hosts,
along with obviously discrete elements like packages, services, and files.
%package server
-Group: System Environment/Base
-Summary: Server for the puppet system management tool
-Requires: puppet = %{version}-%{release}
+Group: System Environment/Base
+Summary: Server for the puppet system management tool
+Requires: puppet = %{version}-%{release}
%description server
Provides the central puppet server daemon which provides manifests to clients.
@@ -175,6 +178,7 @@ rm -rf %{buildroot}
- Simplify Fedora/RHEL version checks for ruby(abi) and BuildArch
- Quiet a few rpmlint complaints
- Remove useless %%pbuild macro
+- Make specfile more like the Fedora/EPEL template
* Mon Jul 28 2008 David Lutterkort <dlutter@redhat.com> - 0.24.5-1
- Add /usr/bin/puppetdoc