summaryrefslogtreecommitdiffstats
path: root/puppet.spec
diff options
context:
space:
mode:
Diffstat (limited to 'puppet.spec')
-rw-r--r--puppet.spec17
1 files changed, 15 insertions, 2 deletions
diff --git a/puppet.spec b/puppet.spec
index 98a85e5..863d33b 100644
--- a/puppet.spec
+++ b/puppet.spec
@@ -7,9 +7,9 @@
Summary: A network tool for managing many disparate systems
Name: puppet
-Version: 0.23.2
+Version: 0.24.0
Release: 1%{?dist}
-License: GPL
+License: GPLv2+
Group: System Environment/Base
URL: http://puppet.reductivelabs.com/
@@ -48,6 +48,15 @@ The server can also function as a certificate authority and file server.
for f in bin/* ; do
sed -i -e '1c#!/usr/bin/ruby' $f
done
+# Fix some rpmlint complaints
+for f in mac_dscl.pp mac_dscl_revert.pp \
+ mac_netinfo.pp mac_pkgdmg.pp ; do
+ sed -i -e'1d' examples/code/$f
+ chmod a-x examples/code/$f
+done
+
+find examples/ -type f -empty | xargs rm
+find examples/ -type f | xargs chmod a-x
%install
rm -rf %{buildroot}
@@ -148,6 +157,10 @@ fi
rm -rf %{buildroot}
%changelog
+* Fri Dec 14 2007 David Lutterkort <dlutter@redhat.com> - 0.24.0-1
+- Fixed license
+- Munge examples/ to make rpmlint happier
+
* Wed Aug 22 2007 David Lutterkort <dlutter@redhat.com> - 0.23.2-1
- New version