summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJorg Schuler <jcsjcs@users.sourceforge.net>2006-03-16 15:34:34 +0000
committerJorg Schuler <jcsjcs@users.sourceforge.net>2006-03-16 15:34:34 +0000
commitd3bab54a791fbc5b7835e069dcada96fb6c82efe (patch)
treec5a18421b35013c3fcd1ac5dbe72daa649a30b2b /configure.ac
parent435acf166a4aeda13d14ce7818fa33f2b7855b4f (diff)
downloadlibgpod-d3bab54a791fbc5b7835e069dcada96fb6c82efe.tar.gz
libgpod-d3bab54a791fbc5b7835e069dcada96fb6c82efe.tar.xz
libgpod-d3bab54a791fbc5b7835e069dcada96fb6c82efe.zip
* itdb_device.[ch]: rewrote ipod-device.c, removed all hal-code,
removed all code irrelevant to writing the iTunesDB and ArtworkDB. * autodetect iControl directory now also works for ArtworkDB. * db-artwork-parser.c (ipod_db_get_artwork_db_path): create Artwork directory if not already present. * itdb.h: Itdb_iTunesDB: moved mountpoint and musicdirs into private Itdb_Device. Use itdb_set_mountpoint() and itdb_get_mountpoint() to access the mountpoint. git-svn-id: https://gtkpod.svn.sf.net/svnroot/gtkpod/libgpod/trunk@1220 f01d2545-417e-4e96-918e-98f8d0dbbcb6
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac38
1 files changed, 0 insertions, 38 deletions
diff --git a/configure.ac b/configure.ac
index 6eb4188..42bb297 100644
--- a/configure.ac
+++ b/configure.ac
@@ -74,44 +74,6 @@ fi
AM_CONDITIONAL(HAVE_GDKPIXBUF, test x"$have_gdkpixbuf" = xyes)
dnl **************************************************
-dnl * hal is optional
-dnl **************************************************
-
-AC_ARG_ENABLE(hal, [AC_HELP_STRING([--enable-hal],[support hal])],
-[case "${enableval}" in
- no) enable_hal05=no ;;
- *) enable_hal05=yes;;
-esac], enable_hal05=no)
-if test x$enable_hal05 = xyes; then
- PKG_CHECK_MODULES(HAL, dbus-1 dbus-glib-1 hal >= 0.5.2 hal < 0.6, enable_hal05=yes, enable_hal05=no)
- if test x$enable_hal05 = xyes; then
- AC_DEFINE_UNQUOTED(HAVE_LIBHAL, 1, [Whether HAL is available or not])
- fi
- LIBGPOD_CFLAGS="$LIBGPOD_CFLAGS $HAL_CFLAGS"
- LIBGPOD_LIBS="$LIBGPOD_LIBS $HAL_LIBS"
-fi
-
-dnl **************************************************
-dnl * necessary for the HAL libipoddevice code
-dnl **************************************************
-AC_PATH_PROG(EJECT_PATH, eject, eject)
-AC_PATH_PROG(UNMOUNT_PATH, pumount, no)
-
-if test "x$UNMOUNT_PATH" = "xno"; then
- AC_PATH_PROG(UNMOUNT_PATH_ALT, umount, umount)
- UNMOUNT_PATH=$UNMOUNT_PATH_ALT
-fi
-
-AC_ARG_WITH(eject-command, AC_HELP_STRING(--with-eject-command], [Command to invoke in order to eject a device]),
- eject_command="$withval", eject_command="${EJECT_PATH} %d")
-AC_DEFINE_UNQUOTED([EJECT_COMMAND], ["${eject_command}"], [eject command])
-
-AC_ARG_WITH(unmount-command, AC_HELP_STRING(--with-unmount-command], [Command to invoke in order to unmount a device]),
- unmount_command="$withval", unmount_command="${UNMOUNT_PATH} %d")
-AC_DEFINE_UNQUOTED([UNMOUNT_COMMAND], ["${unmount_command}"], [unmount command])
-
-
-dnl **************************************************
dnl * internationalization support
dnl **************************************************
ALL_LINGUAS="de es fr he it ja sv"