summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTodd Zullinger <tmzullinger@users.sourceforge.net>2007-07-31 20:42:54 +0000
committerTodd Zullinger <tmzullinger@users.sourceforge.net>2007-07-31 20:42:54 +0000
commit6dda4b59bb0f788da38823a035f28d4c515a38be (patch)
tree16f02c91b9efa543e3f4daab4b1bbcf3d88859f6 /configure.ac
parentbd2fc5d392af67e46ee0fe8bf31b4f9e457f2da3 (diff)
downloadlibgpod-6dda4b59bb0f788da38823a035f28d4c515a38be.tar.gz
libgpod-6dda4b59bb0f788da38823a035f28d4c515a38be.tar.xz
libgpod-6dda4b59bb0f788da38823a035f28d4c515a38be.zip
merge changes from the bug-1723660 branch
git-svn-id: https://gtkpod.svn.sf.net/svnroot/gtkpod/libgpod/trunk@1662 f01d2545-417e-4e96-918e-98f8d0dbbcb6
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0f4f753..ef845fe 100644
--- a/configure.ac
+++ b/configure.ac
@@ -93,6 +93,26 @@ fi
AM_CONDITIONAL(HAVE_GDKPIXBUF, test x"$have_gdkpixbuf" = xyes)
dnl **************************************************
+dnl * PYGOBJECT is optional
+dnl **************************************************
+
+AC_ARG_ENABLE(pygobject, [AC_HELP_STRING([--disable-pygobject],[Python API will lack GdkPixbuf support without PyGOBJECT])],
+[case "${enableval}" in
+ no) have_pygobject=no ;;
+ *) have_pygobject=yes;;
+esac], have_pygobject=yes)
+AH_TEMPLATE([HAVE_PYGOBJECT], [Whether pygobject is installed, Python API will lack GdkPixbuf support without PyGOBJECT])
+if test x$have_pygobject = xyes; then
+ PKG_CHECK_MODULES(PYGOBJECT, pygobject-2.0 >= 2.8.0, have_pygobject=yes, have_pygobject=no)
+ if test x"$have_pygobject" = xyes; then
+ AC_DEFINE_UNQUOTED(HAVE_PYGOBJECT, 1)
+ fi
+ LIBGPOD_CFLAGS="$LIBGPOD_CFLAGS $PYGOBJECT_CFLAGS"
+ LIBGPOD_LIBS="$LIBGPOD_LIBS $PYGOBJECT_LIBS"
+fi
+AM_CONDITIONAL(HAVE_PYGOBJECT, test x"$have_pygobject" = xyes)
+
+dnl **************************************************
dnl * internationalization support
dnl **************************************************
ALL_LINGUAS="de es fr he it ja ro sv"
@@ -195,6 +215,7 @@ Configuration for $PACKAGE $VERSION :
Linker ...............: $CC $LDFLAGS $LIBS $LIBGPOD_LIBS
ArtworkDB support ....: $have_gdkpixbuf
Python bindings ......: $with_python
+ PyGObject support ....: $have_pygobject
Now type 'make' to build $PACKAGE $VERSION,
and then 'make install' for installation.