summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJorg Schuler <jcsjcs@users.sourceforge.net>2005-10-02 13:22:11 +0000
committerJorg Schuler <jcsjcs@users.sourceforge.net>2005-10-02 13:22:11 +0000
commit87c00b0e96883674c21882bb349df3fa8ea36490 (patch)
treed85a51229542eb10156c2880c307fff9ff4444ab /Makefile.am
parent5ed383127a288db4b7401ec783e72db432155055 (diff)
downloadlibgpod-87c00b0e96883674c21882bb349df3fa8ea36490.tar.gz
libgpod-87c00b0e96883674c21882bb349df3fa8ea36490.tar.xz
libgpod-87c00b0e96883674c21882bb349df3fa8ea36490.zip
* Makefile.am: added bindings/... to EXTRA_DIST
* src/itdb.h, src/itdb_playlist.h, src/itdb_private.h: made enum ItdbPlType and enum ItdbPlFlag private and introduced itdb_playlist_set_mpl/_podcast() in addition to the existing itdb_playlist_is_mpl/_podcast() which make the public enums unecessary. * bumped to version 107 * src/ithumb-writer.c: itdb_write_ithumb_files (): commented out g_print() statement as this produced an empty line in gtkpod's warning window. * src/Makefile.am: GDKPIXPUF dependency solved inside source files -- db-artwork-writer-dummy.c no longer required. Now compiles with and without gdkpixbuf. * configure.ac: fixed error in AC_DEFINE_UNQUOTED(HAVE_GDKPIXBUF). * tests/test-covers.c: attached Flavio Stanchina size-patch git-svn-id: https://gtkpod.svn.sf.net/svnroot/gtkpod/libgpod/trunk@1112 f01d2545-417e-4e96-918e-98f8d0dbbcb6
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 76e7436..cdee804 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,11 +3,17 @@ SUBDIRS=src tests po
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = libgpod-1.0.pc
+# the bindings/ below are just a hack until a better way is found
EXTRA_DIST = \
intltool-merge.in \
intltool-update.in \
intltool-extract.in \
- libgpod-1.0.pc.in
+ libgpod-1.0.pc.in \
+ bindings/python/examples/play.py \
+ bindings/python/examples/tag-genre-from-audioscrobber.py \
+ bindings/python/Makefile \
+ bindings/python/gpod.i
+
DISTCLEANFILES = \
intltool-extract \