summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 03e3b6c..2120a96 100644
--- a/configure.ac
+++ b/configure.ac
@@ -98,9 +98,14 @@ AM_CONDITIONAL(WITH_INTERNAL_GCHECKSUM, test "x$with_internal_gchecksum" = "xyes
dnl **************************************************
dnl * sgutils is necessary to get the xml device file from the ipod
dnl **************************************************
-AC_CHECK_LIB(sgutils, sg_ll_inquiry,
- [SGUTILS_LIBS="-lsgutils"; have_sgutils=yes],
- have_sgutils=no)
+AC_CHECK_LIB(sgutils2, sg_ll_inquiry,
+ [SGUTILS_LIBS="-lsgutils2"; have_sgutils=yes],
+ have_sgutils=no)
+if test "x$have_sgutils" != xyes; then
+ AC_CHECK_LIB(sgutils, sg_ll_inquiry,
+ [SGUTILS_LIBS="-lsgutils"; have_sgutils=yes],
+ have_sgutils=no)
+fi
AC_SUBST(SGUTILS_LIBS)
AM_CONDITIONAL(HAVE_SGUTILS, test x"$have_sgutils" = xyes)