summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristophe Fergeau <teuf@gnome.org>2008-07-09 19:34:26 +0000
committerChristophe Fergeau <teuf@gnome.org>2008-07-09 19:34:26 +0000
commitd1b53b7bcef419e8894398d74ce9afcea9440b12 (patch)
tree79b3497b449e279dd50fae92285801e842869f62 /configure.ac
parent0235cf2fb1d031f845a868ec5746145e7e9babb2 (diff)
downloadlibgpod-tmz-d1b53b7bcef419e8894398d74ce9afcea9440b12.tar.gz
libgpod-tmz-d1b53b7bcef419e8894398d74ce9afcea9440b12.tar.xz
libgpod-tmz-d1b53b7bcef419e8894398d74ce9afcea9440b12.zip
* configure.ac: properly detect newer libsgutils (the so name was
changed) * tools/ipod-scsi-inquiry.c: add missing include Based on a patch from Dan HorĂ¡k (dan@danny.cz) git-svn-id: https://gtkpod.svn.sf.net/svnroot/gtkpod/libgpod/trunk@2045 f01d2545-417e-4e96-918e-98f8d0dbbcb6
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 03e3b6c..2120a96 100644
--- a/configure.ac
+++ b/configure.ac
@@ -98,9 +98,14 @@ AM_CONDITIONAL(WITH_INTERNAL_GCHECKSUM, test "x$with_internal_gchecksum" = "xyes
dnl **************************************************
dnl * sgutils is necessary to get the xml device file from the ipod
dnl **************************************************
-AC_CHECK_LIB(sgutils, sg_ll_inquiry,
- [SGUTILS_LIBS="-lsgutils"; have_sgutils=yes],
- have_sgutils=no)
+AC_CHECK_LIB(sgutils2, sg_ll_inquiry,
+ [SGUTILS_LIBS="-lsgutils2"; have_sgutils=yes],
+ have_sgutils=no)
+if test "x$have_sgutils" != xyes; then
+ AC_CHECK_LIB(sgutils, sg_ll_inquiry,
+ [SGUTILS_LIBS="-lsgutils"; have_sgutils=yes],
+ have_sgutils=no)
+fi
AC_SUBST(SGUTILS_LIBS)
AM_CONDITIONAL(HAVE_SGUTILS, test x"$have_sgutils" = xyes)