summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJorg Schuler <jcsjcs@users.sourceforge.net>2008-06-02 15:47:25 +0000
committerJorg Schuler <jcsjcs@users.sourceforge.net>2008-06-02 15:47:25 +0000
commit96c2ac6e4e510bb6b7ae7d9718abcb813e692ef1 (patch)
treecd719c4c2741250c3364d89508111ab32520a6a1 /configure.ac
parent0bae31d72c4a6a7f2a7ae6bfa64f18e41119c1be (diff)
downloadlibgpod-tmz-96c2ac6e4e510bb6b7ae7d9718abcb813e692ef1.tar.gz
libgpod-tmz-96c2ac6e4e510bb6b7ae7d9718abcb813e692ef1.tar.xz
libgpod-tmz-96c2ac6e4e510bb6b7ae7d9718abcb813e692ef1.zip
* src/gchecksum.c
src/gchecksum.h src/Makefile.am configure.ac: copied gchecksum from glib 2.16.3. It's used if we compile on a system that does not have glib 2.16 or higher. Testing is needed whether it's really pulled in in those cases -- I'm using 2.16.3 myself. * src/itdb_itunesdb.c (mk_mhit): write mhii_link. * src/db-artwork-writer.c: code to handle sparse artwork correctly. (ipod_supports_sparse_artwork): currently hard-coded to TRUE. Will be changed in the future to reflect the information given in the SysInfoExtended. Change yourself if your iPod does not support Sparse Artwork (sharing of thumbnails between several tracks). git-svn-id: https://gtkpod.svn.sf.net/svnroot/gtkpod/libgpod/trunk@2005 f01d2545-417e-4e96-918e-98f8d0dbbcb6
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 950a5bb..03e3b6c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -76,6 +76,25 @@ expanded_libdir=`(
eval echo $libdir
)`
+
+dnl **************************************************
+dnl we've copied gchecksum from glib 2.16. Only use the
+dnl copy if the version of glib on the system does not
+dnl provide it.
+dnl **************************************************
+
+AC_ARG_WITH(internal-gchecksum,
+ AC_HELP_STRING([--with-internal-gchecksum],
+ [Build using internal copy of gchecksum]),,
+ with_internal_gchecksum=no)
+
+if test "x$with_internal_gchecksum" = "xno"; then
+ PKG_CHECK_MODULES(GLIB, glib-2.0 >= 2.16.0, with_internal_gchecksum=no,
+ with_internal_gchecksum=yes)
+fi
+
+AM_CONDITIONAL(WITH_INTERNAL_GCHECKSUM, test "x$with_internal_gchecksum" = "xyes")
+
dnl **************************************************
dnl * sgutils is necessary to get the xml device file from the ipod
dnl **************************************************