summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristophe Fergeau <teuf@gnome.org>2008-05-25 10:38:09 +0000
committerChristophe Fergeau <teuf@gnome.org>2008-05-25 10:38:09 +0000
commit38ea0e03d9414b955cd51f09a8e668c63f8899f9 (patch)
treed24c80f92bfb89240b81a2dcdc97a6520f7016fc /configure.ac
parentc3e9ad30bd3e6beb2e3edc5a1a732e66ac17d0f5 (diff)
downloadlibgpod-tmz-38ea0e03d9414b955cd51f09a8e668c63f8899f9.tar.gz
libgpod-tmz-38ea0e03d9414b955cd51f09a8e668c63f8899f9.tar.xz
libgpod-tmz-38ea0e03d9414b955cd51f09a8e668c63f8899f9.zip
* configure.ac: check libxml presence
* src/Makefile.am: add new files, remove obsolete ones * src/itdb_plist.h: * src/itdb_plist.c: plist parser, this parses a plist XML file to a GHashTable of GValue *. This parser should be generic, ie it doesn't know it's parsing SysInfoExtended, it only cares about it being a plist file * src/itdb_sysinfo_extended_parser.h: * src/itdb_sysinfo_extended_parser.c: convert the parsed plist data to data structures usable by libgpod * src/itdb_device.h: * src/itdb_device.c: parses SysInfoExtended in addition to SysInfo * src/itdb_sysinfo.c: this hacky parser is obsoleted by the new (much more complete) SysInfoExtended parser, so it's removed * tests/Makefile.am: * tests/test-sysinfo-extended-parsing.c: small test program for the new parser git-svn-id: https://gtkpod.svn.sf.net/svnroot/gtkpod/libgpod/trunk@1980 f01d2545-417e-4e96-918e-98f8d0dbbcb6
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9eee413..e1d7171 100644
--- a/configure.ac
+++ b/configure.ac
@@ -128,6 +128,17 @@ AC_SUBST(TAGLIB_CFLAGS)
AC_SUBST(TAGLIB_LIBS)
AM_CONDITIONAL(HAVE_TAGLIB, test x"$have_taglib" = xyes)
+dnl **************************************************
+dnl * libxml is used to parse the plist files (aka SysInfoExtended)
+dnl **************************************************
+PKG_CHECK_MODULES(LIBXML, libxml-2.0, have_libxml=yes, have_libxml=no)
+if test x"$have_libxml" = xyes; then
+ AH_TEMPLATE([HAVE_LIBXML], [Whether libxml is installed, it's only used in a test program])
+ AC_DEFINE_UNQUOTED(HAVE_LIBXML, 1)
+fi
+AC_SUBST(LIBXML_CFLAGS)
+AC_SUBST(LIBXML_LIBS)
+AM_CONDITIONAL(HAVE_LIBXML, test x"$have_libxml" = xyes)
dnl **************************************************
dnl * GDKPIXBUF is optional