summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristophe Fergeau <teuf@gnome.org>2008-05-25 11:27:27 +0000
committerChristophe Fergeau <teuf@gnome.org>2008-05-25 11:27:27 +0000
commit1c1bedde1bbb58a6c4a0cde15d2a466d994d6ec5 (patch)
tree6c752611a92bdaedea944deefe8ab7479b4feb2f /configure.ac
parent1166a8f0d362dfcf763ddb0091b39affae269104 (diff)
downloadlibgpod-tmz-1c1bedde1bbb58a6c4a0cde15d2a466d994d6ec5.tar.gz
libgpod-tmz-1c1bedde1bbb58a6c4a0cde15d2a466d994d6ec5.tar.xz
libgpod-tmz-1c1bedde1bbb58a6c4a0cde15d2a466d994d6ec5.zip
* configure.ac: rework libxml detection
* src/Makefile.am: remove LIBXML_CFLAGS/LIBXML_LIBS since they are no longer used * src/itdb_plist.c: add stub functions when libxml isn't available * src/itdb_sysinfo_extended_parser.c: include config.h git-svn-id: https://gtkpod.svn.sf.net/svnroot/gtkpod/libgpod/trunk@1982 f01d2545-417e-4e96-918e-98f8d0dbbcb6
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac40
1 files changed, 33 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index e1d7171..418acac 100644
--- a/configure.ac
+++ b/configure.ac
@@ -131,19 +131,29 @@ AM_CONDITIONAL(HAVE_TAGLIB, test x"$have_taglib" = xyes)
dnl **************************************************
dnl * libxml is used to parse the plist files (aka SysInfoExtended)
dnl **************************************************
-PKG_CHECK_MODULES(LIBXML, libxml-2.0, have_libxml=yes, have_libxml=no)
+AC_ARG_ENABLE(libxml, [AC_HELP_STRING([--disable-libxml],[SysInfoExtended won't be parsed])],
+[case "${enableval}" in
+ no) enable_libxml=no ;;
+ *) enable_libxml=yes;;
+esac])
+AH_TEMPLATE([HAVE_LIBXML], [Whether libxml is installed, it's used to parse SysInfoExtended])
+if test x$enable_libxml != xno; then
+ PKG_CHECK_MODULES(LIBXML, libxml-2.0, have_libxml=yes, have_libxml=no)
+ if test x"$enable_libxml" = xyes -a x"$have_libxml" = xno; then
+ AC_MSG_ERROR([libxml support explicitly requested but libxml couldn't be found])
+ fi
+fi
if test x"$have_libxml" = xyes; then
- AH_TEMPLATE([HAVE_LIBXML], [Whether libxml is installed, it's only used in a test program])
AC_DEFINE_UNQUOTED(HAVE_LIBXML, 1)
+ LIBGPOD_CFLAGS="$LIBGPOD_CFLAGS $LIBXML_CFLAGS"
+ LIBGPOD_LIBS="$LIBGPOD_LIBS $LIBXML_LIBS"
+else
+ have_libxml=no
fi
-AC_SUBST(LIBXML_CFLAGS)
-AC_SUBST(LIBXML_LIBS)
-AM_CONDITIONAL(HAVE_LIBXML, test x"$have_libxml" = xyes)
dnl **************************************************
dnl * GDKPIXBUF is optional
dnl **************************************************
-
AC_ARG_ENABLE(gdk-pixbuf, [AC_HELP_STRING([--disable-gdk-pixbuf],[ArtworkDB will be disabled without gdk-pixbuf])],
[case "${enableval}" in
no) enable_gdkpixbuf=no ;;
@@ -295,7 +305,8 @@ Configuration for $PACKAGE $VERSION :
Preprocessor .........: $CC $CPPFLAGS
Compiler .............: $CC $CFLAGS $LIBGPOD_CFLAGS
Linker ...............: $CC $LDFLAGS $LIBS $LIBGPOD_LIBS
- ArtworkDB support ....: $have_gdkpixbuf
+ Artwork support ......: $have_gdkpixbuf
+ libxml support .......: $have_libxml
Python bindings ......: $with_python
PyGObject support ....: $have_pygobject
@@ -303,3 +314,18 @@ Configuration for $PACKAGE $VERSION :
and then 'make install' for installation.
"
+if test x"$have_libxml" = xno; then
+ echo "
+**WARNING** libxml support is disabled, libgpod won't be able to
+parse SysInfoExtended. This means it can't take advantage of the
+extensive iPod description (image formats, features, ...)
+available from that file
+"
+fi
+
+if test x"$have_gdkpixbuf" = xno; then
+ echo "
+**WARNING** gdkpixbuf support is disabled. libgpod won't be able
+to read or write artwork (covers, photos, ...) from/to the iPod
+"
+fi