summaryrefslogtreecommitdiffstats
path: root/SPECS/libgpod.spec
diff options
context:
space:
mode:
Diffstat (limited to 'SPECS/libgpod.spec')
-rw-r--r--SPECS/libgpod.spec139
1 files changed, 13 insertions, 126 deletions
diff --git a/SPECS/libgpod.spec b/SPECS/libgpod.spec
index a98457b..e95423a 100644
--- a/SPECS/libgpod.spec
+++ b/SPECS/libgpod.spec
@@ -1,17 +1,3 @@
-%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
-
-# python-gpod should not advertise _gpod.so in its Provides
-%define __provides_exclude_from %{python_sitearch}/.*\.so$
-
-%ifarch %ix86 x86_64 ppc ppc64 ia64 %{arm} sparcv9 alpha s390x
-%global with_mono 1
-%else
-%global with_mono 0
-%endif
-%if 0%{?rhel}
-%global with_mono 0
-%endif
-
Summary: Library to access the contents of an iPod
Name: libgpod
Version: 0.8.2
@@ -20,6 +6,9 @@ License: LGPLv2+
Group: System Environment/Libraries
URL: http://www.gtkpod.org/libgpod.html
Source0: http://downloads.sourceforge.net/gtkpod/%{name}-%{version}.tar.bz2
+# fix build with mono4
+# https://src.fedoraproject.org/rpms/libgpod/blob/98b831c9/f/libgpod-0.8.3-mono4.patch
+Patch2: libgpod-0.8.3-mono4.patch
# upstreamable patch: reduce pkgconfig-related overlinking
#
@@ -36,13 +25,8 @@ BuildRequires: libplist-devel
BuildRequires: libusb1-devel
BuildRequires: libxml2-devel
BuildRequires: libxslt
-%if %{with_mono}
BuildRequires: mono-devel
BuildRequires: gtk-sharp2-devel
-%endif
-BuildRequires: pygobject2-devel
-BuildRequires: python-devel
-BuildRequires: python-mutagen
BuildRequires: sg3_utils-devel
BuildRequires: sqlite-devel
BuildRequires: swig
@@ -53,47 +37,6 @@ Libgpod is a library to access the contents of an iPod. It supports playlists,
smart playlists, playcounts, ratings, podcasts, album artwork, photos, etc.
-%package devel
-Summary: Development files for the libgpod library
-Group: Development/Libraries
-Requires: %{name}%{?_isa} = %{version}-%{release}
-
-%description devel
-Libgpod is a library to access the contents of an iPod. It supports playlists,
-smart playlists, playcounts, ratings, podcasts, album artwork, photos, etc.
-
-This package contains the files required to develop programs that will use
-libgpod.
-
-
-%package doc
-Summary: API documentation for the libgpod library
-Group: Documentation
-License: GFDL
-%if 0%{?fedora}
-BuildArch: noarch
-%endif
-Requires: %{name} = %{version}-%{release}
-
-%description doc
-Libgpod is a library to access the contents of an iPod. It supports playlists,
-smart playlists, playcounts, ratings, podcasts, album artwork, photos, etc.
-
-This package contains the API documentation.
-
-
-%package -n python-gpod
-Summary: Python module to access iPod content
-Group: Development/Languages
-Requires: %{name}%{?_isa} = %{version}-%{release}
-Requires: python-mutagen
-
-%description -n python-gpod
-A python module to access iPod content. This module provides bindings to the
-libgpod library.
-
-
-%if %{with_mono}
%package sharp
Summary: C#/.NET library to access iPod content
Group: Development/Languages
@@ -106,7 +49,6 @@ library.
%package sharp-devel
Summary: Development files for libgpod-sharp
-Summary: C#/.NET library to access iPod content
Group: Development/Languages
Requires: %{name}-sharp%{?_isa} = %{version}-%{release}
@@ -116,18 +58,14 @@ library.
This package contains the files required to develop programs that will use
libgpod-sharp.
-%endif
%prep
%setup -q
-
+%patch2 -p1 -b .with_mono4
%patch50 -p1 -b .pkgconfig_overlinking
-#autoreconf -f
-
-# remove execute perms on the python examples as they'll be installed in %%doc
-chmod -x bindings/python/examples/*.py
+autoreconf -f
%build
@@ -137,78 +75,27 @@ make %{?_smp_mflags}
%install
make DESTDIR=%{buildroot} install
-%find_lang %{name}
-mkdir -p %{buildroot}/%{_libdir}/libgpod
+# remove unwanted files
+rm -rf %{buildroot}%{_bindir} \
+ %{buildroot}%{_datadir} \
+ %{buildroot}/lib \
+ %{buildroot}%{_includedir} \
+ %{buildroot}%{_libdir}/%{name}.* \
+ %{buildroot}%{_libdir}/pkgconfig/%{name}-1.0.pc
-# remove Makefiles from the python examples dir
-rm -rf bindings/python/examples/Makefile*
-
-%if %{with_mono}
# remove execute perms from some libgpod-sharp files
chmod -x %{buildroot}/%{_libdir}/%{name}/*.dll.config
-%else
-# remove unwanted file
-rm -f %{buildroot}/%{_libdir}/pkgconfig/%{name}-sharp.pc
-%endif
-
-%if 0%{?fedora} >= 15
-# Setup tmpfiles.d config
-mkdir -p %{buildroot}%{_sysconfdir}/tmpfiles.d
-echo "D /var/run/%{name} 0755 root root -" > \
- %{buildroot}%{_sysconfdir}/tmpfiles.d/%{name}.conf
-%endif
-
-
-%post -p /sbin/ldconfig
-%postun -p /sbin/ldconfig
-
-%files -f %{name}.lang
-%defattr(-, root, root, 0755)
-%doc AUTHORS ChangeLog COPYING NEWS README*
-%if 0%{?fedora} >= 15
-%config(noreplace) %{_sysconfdir}/tmpfiles.d/%{name}.conf
-%endif
-%{_bindir}/*
-%{_libdir}/*.so.*
-%dir %{_localstatedir}/run/%{name}
-/lib/udev/iphone-set-info
-/lib/udev/ipod-set-info
-/lib/udev/rules.d/*.rules
-%dir %{_libdir}/libgpod/
-
-%files devel
-%defattr(-, root, root, 0755)
-%{_includedir}/gpod-1.0/
-%{_libdir}/pkgconfig/%{name}-1.0.pc
-%exclude %{_libdir}/*.a
-%exclude %{_libdir}/*.la
-%{_libdir}/*.so
-
-
-%files doc
-%defattr(-, root, root, 0755)
-%{_datadir}/gtk-doc
-
-%files -n python-gpod
-%defattr(-, root, root, 0755)
-%doc COPYING bindings/python/README bindings/python/examples
-%{python_sitearch}/gpod
-%exclude %{python_sitearch}/gpod/*.la
-
-
-%if %{with_mono}
%files sharp
-%defattr(-, root, root, 0755)
+%license COPYING
%{_libdir}/%{name}/%{name}-sharp*
%files sharp-devel
%defattr(-, root, root, 0755)
%{_libdir}/pkgconfig/%{name}-sharp.pc
-%endif
%changelog
* Thu Mar 09 2017 Kalev Lember <klember@redhat.com> - 0.8.2-12