summaryrefslogtreecommitdiffstats
path: root/SPECS/libgpod.spec.pgreco
diff options
context:
space:
mode:
Diffstat (limited to 'SPECS/libgpod.spec.pgreco')
-rw-r--r--SPECS/libgpod.spec.pgreco105
1 files changed, 105 insertions, 0 deletions
diff --git a/SPECS/libgpod.spec.pgreco b/SPECS/libgpod.spec.pgreco
new file mode 100644
index 0000000..1e3b957
--- /dev/null
+++ b/SPECS/libgpod.spec.pgreco
@@ -0,0 +1,105 @@
+%global upstreamname libgpod
+
+Summary: Library to access the contents of an iPod
+Name: libgpodextras
+Version: 0.8.2
+Release: 12%{?dist}
+License: LGPLv2+
+Group: System Environment/Libraries
+URL: http://www.gtkpod.org/libgpod.html
+Source0: http://downloads.sourceforge.net/gtkpod/%{upstreamname}-%{version}.tar.bz2
+# fix build with mono4
+# https://src.fedoraproject.org/rpms/libgpod/blob/98b831c9/f/libgpod-0.8.3-mono4.patch
+Patch2: libgpod-0.8.3-mono4.patch
+
+# upstreamable patch: reduce pkgconfig-related overlinking
+#
+Patch50: libgpod-0.8.2-pkgconfig_overlinking.patch
+
+BuildRequires: automake libtool
+BuildRequires: docbook-style-xsl
+BuildRequires: glib2-devel
+BuildRequires: gdk-pixbuf2-devel
+BuildRequires: gettext
+BuildRequires: intltool
+BuildRequires: libimobiledevice-devel
+BuildRequires: libplist-devel
+BuildRequires: libusb1-devel
+BuildRequires: libxml2-devel
+BuildRequires: libxslt
+BuildRequires: mono-devel
+BuildRequires: gtk-sharp2-devel
+BuildRequires: sg3_utils-devel
+BuildRequires: sqlite-devel
+BuildRequires: swig
+Requires: udev
+
+%description
+Libgpod is a library to access the contents of an iPod. It supports playlists,
+smart playlists, playcounts, ratings, podcasts, album artwork, photos, etc.
+
+%package -n %{upstreamname}-sharp
+Summary: C#/.NET library to access iPod content
+Group: Development/Languages
+Requires: %{upstreamname}%{?_isa} = %{version}-%{release}
+
+%description -n %{upstreamname}-sharp
+C#/.NET library to access iPod content. Provides bindings to the libgpod
+library.
+
+
+%package -n %{upstreamname}-sharp-devel
+Summary: Development files for libgpod-sharp
+Group: Development/Languages
+Requires: %{upstreamname}-sharp%{?_isa} = %{version}-%{release}
+
+%description -n %{upstreamname}-sharp-devel
+C#/.NET library to access iPod content. Provides bindings to the libgpod
+library.
+
+This package contains the files required to develop programs that will use
+libgpod-sharp.
+
+
+%prep
+%setup -q -n %{upstreamname}-%{version}
+%patch2 -p1 -b .mono4
+%patch50 -p1 -b .pkgconfig_overlinking
+
+#autoreconf -f
+
+
+%build
+autoreconf -vif
+
+%configure --without-hal --enable-udev --with-temp-mount-dir=%{_localstatedir}/run/%{upstreamname}
+make %{?_smp_mflags}
+
+
+%install
+make DESTDIR=%{buildroot} install
+
+# remove unwanted files
+rm -rf %{buildroot}%{_bindir} \
+ %{buildroot}%{_datadir} \
+ %{buildroot}/lib \
+ %{buildroot}%{_includedir} \
+ %{buildroot}%{_libdir}/%{upstreamname}.* \
+ %{buildroot}%{_libdir}/pkgconfig/%{upstreamname}-1.0.pc
+
+# remove execute perms from some libgpod-sharp files
+chmod -x %{buildroot}/%{_libdir}/%{upstreamname}/*.dll.config
+
+
+%files -n %{upstreamname}-sharp
+%license COPYING
+%{_libdir}/%{upstreamname}/%{upstreamname}-sharp*
+
+
+%files -n %{upstreamname}-sharp-devel
+%defattr(-, root, root, 0755)
+%{_libdir}/pkgconfig/%{upstreamname}-sharp.pc
+
+%changelog
+* Wed Oct 10 2018 <pablo@fliagreco.com.ar> - 0.8.2-12
+- Initial RPM release, support for libgpod-sharp