summaryrefslogtreecommitdiffstats
path: root/git.spec
diff options
context:
space:
mode:
authorTodd Zullinger <tmz@pobox.com>2008-12-01 17:20:37 -0500
committerTodd Zullinger <tmz@pobox.com>2008-12-23 10:25:44 -0500
commit35acf5bff30a07a68de3dd1254a93aa718127396 (patch)
tree9d8fb8b5d652018f71836f6e6be4d5abbf6d7209 /git.spec
parentac85b9de7baab13c8dd93be5f0287e5963bee638 (diff)
downloadgit-package-35acf5bff30a07a68de3dd1254a93aa718127396.tar.gz
git-package-35acf5bff30a07a68de3dd1254a93aa718127396.tar.xz
git-package-35acf5bff30a07a68de3dd1254a93aa718127396.zip
Use macros more consistently
Diffstat (limited to 'git.spec')
-rw-r--r--git.spec24
1 files changed, 13 insertions, 11 deletions
diff --git a/git.spec b/git.spec
index 730c59e..fbba5f5 100644
--- a/git.spec
+++ b/git.spec
@@ -133,7 +133,7 @@ Requires: git = %{version}-%{release}, emacs-common
%build
make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" \
- ETC_GITCONFIG=/etc/gitconfig \
+ ETC_GITCONFIG=%{_sysconfdir}/gitconfig \
prefix=%{_prefix} all %{!?_without_docs: doc}
make -C contrib/emacs
@@ -141,7 +141,7 @@ make -C contrib/emacs
rm -rf $RPM_BUILD_ROOT
make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" DESTDIR=$RPM_BUILD_ROOT \
prefix=%{_prefix} mandir=%{_mandir} INSTALL="install -p" \
- ETC_GITCONFIG=/etc/gitconfig \
+ ETC_GITCONFIG=%{_sysconfdir}/gitconfig \
INSTALLDIRS=vendor install %{!?_without_docs: install-doc}
make -C contrib/emacs install \
emacsdir=$RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp
@@ -151,13 +151,11 @@ for elc in $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/*.elc ; do
done
install -Dpm 644 %{SOURCE1} \
$RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/site-start.d/git-init.el
-mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d
-install -pm 644 %SOURCE2 $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d/git
-mkdir -p $RPM_BUILD_ROOT/var/www/git
-install -pm 644 -t $RPM_BUILD_ROOT/var/www/git gitweb/*.png gitweb/*.css
-install -pm 755 -t $RPM_BUILD_ROOT/var/www/git gitweb/gitweb.cgi
+mkdir -p $RPM_BUILD_ROOT%{_var}/www/git
+install -pm 644 -t $RPM_BUILD_ROOT%{_var}/www/git gitweb/*.png gitweb/*.css
+install -pm 755 -t $RPM_BUILD_ROOT%{_var}/www/git gitweb/gitweb.cgi
mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d
-install -pm 0644 %SOURCE3 $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d/git.conf
+install -pm 0644 %{SOURCE3} $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d/git.conf
find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
find $RPM_BUILD_ROOT -type f -name '*.bs' -empty -exec rm -f {} ';'
@@ -170,7 +168,10 @@ find $RPM_BUILD_ROOT -type f -name perllocal.pod -exec rm -f {} ';'
%else
rm -rf $RPM_BUILD_ROOT%{_mandir}
%endif
-mkdir -p $RPM_BUILD_ROOT/var/lib/git-daemon
+
+mkdir -p $RPM_BUILD_ROOT%{_var}/lib/git-daemon
+mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/xinetd.d
+install -pm 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/xinetd.d/git
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
install -pm 644 -T contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/git
@@ -249,11 +250,11 @@ rm -rf $RPM_BUILD_ROOT
%defattr(-,root,root)
%{_libexecdir}/git-core/git-daemon
%config(noreplace)%{_sysconfdir}/xinetd.d/git
-/var/lib/git-daemon
+%{_var}/lib/git-daemon
%files -n gitweb
%defattr(-,root,root)
-/var/www/git/
+%{_var}/www/git/
%config(noreplace)%{_sysconfdir}/httpd/conf.d/git.conf
@@ -265,6 +266,7 @@ rm -rf $RPM_BUILD_ROOT
- Install git-* commands in %%{_libexecdir}/git-core, the upstream default
- Remove libcurl from Requires, rpm will pick this up automatically
- Preserve timestamps on installed files
+- Use macros more consistently
* Sat Dec 20 2008 Todd Zullinger <tmz@pobox.com> 1.6.0.6-1
- git-1.6.0.6