summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
Diffstat (limited to 'kernel.spec')
-rwxr-xr-xkernel.spec20
1 files changed, 12 insertions, 8 deletions
diff --git a/kernel.spec b/kernel.spec
index f8846a66a..480121cef 100755
--- a/kernel.spec
+++ b/kernel.spec
@@ -120,17 +120,17 @@ Summary: The Linux kernel
# Set debugbuildsenabled to 0 to not build a separate debug kernel, but
# to build the base kernel using the debug configuration. (Specifying
# the --with-release option overrides this setting.)
-%define debugbuildsenabled 1
+%define debugbuildsenabled 0
# define buildid .local
%define specversion 6.1.0
%define patchversion 6.1
-%define pkgrelease 0.rc1.15
+%define pkgrelease 0.rc1.20221018gitbb1a1146467a.16
%define kversion 6
-%define tarfile_release 6.1-rc1
+%define tarfile_release 6.1-rc1-10-gbb1a1146467a
# This is needed to do merge window version magic
%define patchlevel 1
# This allows pkg_release to have configurable %%{?dist} tag
-%define specrelease 0.rc1.15%{?buildid}%{?dist}
+%define specrelease 0.rc1.20221018gitbb1a1146467a.16%{?buildid}%{?dist}
# This defines the kabi tarball version
%define kabiversion 6.1.0
@@ -575,7 +575,7 @@ Requires: kernel-modules-uname-r = %{KVERREL}
#
# List the packages used during the kernel build
#
-BuildRequires: kmod, patch, bash, coreutils, tar, git-core, which
+BuildRequires: kmod, bash, coreutils, tar, git-core, which
BuildRequires: bzip2, xz, findutils, gzip, m4, perl-interpreter, perl-Carp, perl-devel, perl-generators, make, diffutils, gawk
BuildRequires: gcc, binutils, redhat-rpm-config, hmaccalc, bison, flex, gcc-c++
BuildRequires: net-tools, hostname, bc, elfutils-devel
@@ -1392,7 +1392,7 @@ if [ "%{patches}" != "%%{patches}" ] ; then
done
fi 2>/dev/null
-patch_command='patch -p1 -F1 -s'
+patch_command='git --work-tree=. apply'
ApplyPatch()
{
local patch=$1
@@ -3185,8 +3185,12 @@ fi
#
#
%changelog
-* Mon Oct 17 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.1.0-0.rc1.15]
-- Revert "redhat: properly handle binary files in patches" (Akihiko Odaki)
+* Tue Oct 18 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.1.0-0.rc1.bb1a1146467a.16]
+- perf tools: Fix man page build wrt perf-arm-coresight.txt (Adrian Hunter)
+- spec: prevent git apply from searching for the .git directory (Ondrej Mosnacek)
+
+* Tue Oct 18 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.1.0-0.rc1.bb1a1146467a.15]
+- Linux v6.1.0-0.rc1.bb1a1146467a
* Mon Oct 17 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.1.0-0.rc1.14]
- Linux v6.1.0-0.rc1