summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
Diffstat (limited to 'kernel.spec')
-rw-r--r--kernel.spec85
1 files changed, 25 insertions, 60 deletions
diff --git a/kernel.spec b/kernel.spec
index 9cb871aac..e2fea926e 100644
--- a/kernel.spec
+++ b/kernel.spec
@@ -22,6 +22,8 @@ Summary: The Linux kernel
%if %{zipmodules}
%global zipsed -e 's/\.ko$/\.ko.xz/'
+# for parallel xz processes, replace with 1 to go back to single process
+%global zcpu `nproc --all`
%endif
# define buildid .local
@@ -44,14 +46,13 @@ Summary: The Linux kernel
# For non-released -rc kernels, this will be appended after the rcX and
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
#
-%global baserelease 350
-
+%global baserelease 200
%global fedora_build %{baserelease}
# base_sublevel is the kernel version we're starting with and patching
# on top of -- for example, 3.1-rc7-git1 starts with a 3.0 base,
# which yields a base_sublevel of 0.
-%define base_sublevel 1
+%define base_sublevel 2
## If this is a released kernel ##
%if 0%{?released_kernel}
@@ -60,7 +61,7 @@ Summary: The Linux kernel
%define stable_rc 0
# Do we have a -stable update to apply?
-%define stable_update 21
+%define stable_update 4
# Set rpm version accordingly
%if 0%{?stable_update}
%define stablerev %{stable_update}
@@ -565,34 +566,29 @@ Patch303: ACPI-scan-Fix-regression-related-to-X-Gene-UARTs.patch
# rhbz 1574718
Patch304: ACPI-irq-Workaround-firmware-issue-on-X-Gene-based-m400.patch
-# https://patchwork.kernel.org/patch/9820417/
-Patch305: qcom-msm89xx-fixes.patch
-
# https://patchwork.kernel.org/project/linux-mmc/list/?submitter=71861
-Patch306: arm-sdhci-esdhc-imx-fixes.patch
+Patch305: arm-sdhci-esdhc-imx-fixes.patch
+
+# Fix accepted for 5.3 https://patchwork.kernel.org/patch/10992783/
+Patch306: arm64-dts-rockchip-Update-DWC3-modules-on-RK3399-SoCs.patch
+
+# RHBZ Bug 1576593 - work around while vendor investigates
+Patch307: arm-make-highpte-not-expert.patch
# Raspberry Pi bits
-Patch330: bcm2835-cpufreq-add-CPU-frequency-control-driver.patch
+Patch330: ARM-cpufreq-support-for-Raspberry-Pi.patch
Patch331: watchdog-bcm2835_wdt-Fix-module-autoload.patch
-# Fix spurious "load avg 4" issue
-Patch333: bcm2835-vchiq-use-interruptible-waits.patch
-
-# The new power driver has regressed display so disable it until the problem is diagnosed
Patch334: 0001-Revert-ARM-bcm283x-Switch-V3D-over-to-using-the-PM-d.patch
Patch335: 0002-Revert-ARM-bcm283x-Extend-the-WDT-DT-node-out-to-cov.patch
# Tegra bits
Patch340: arm64-tegra-jetson-tx1-fixes.patch
-# https://patchwork.kernel.org/patch/10858639/
-Patch341: arm64-tegra-Add-NVIDIA-Jetson-Nano-Developer-Kit-support.patch
-
# 400 - IBM (ppc/s390x) patches
# 500 - Temp fixes/CVEs etc
-
# rhbz 1431375
Patch501: input-rmi4-remove-the-need-for-artifical-IRQ.patch
@@ -604,51 +600,17 @@ Patch507: 0001-Drop-that-for-now.patch
# Submitted upstream at https://lkml.org/lkml/2019/4/23/89
Patch508: KEYS-Make-use-of-platform-keyring-for-module-signature.patch
-# CVE-2019-3900 rhbz 1698757 1702940
-Patch524: net-vhost_net-fix-possible-infinite-loop.patch
-
-# Fix wifi on various ideapad models not working (rhbz#1703338)
-Patch526: 0001-platform-x86-ideapad-laptop-Remove-no_hw_rfkill_list.patch
-
-# CVE-2019-12378 rhbz 1715459 1715460
-Patch528: ipv6_sockglue-fix-missing-check-bug-in-ip6_ra_control.patch
-
-# CVE-2019-12380 rhbz 1715494 1715495
-Patch530: 0001-efi-x86-Add-missing-error-handling-to-old_memmap-1-1.patch
-
-# CVE-2019-12381 rhbz 1715501 1715502
-Patch531: 0001-ip_sockglue-Fix-missing-check-bug-in-ip_ra_control.patch
+# build fix
+Patch527: v2-powerpc-mm-mark-more-tlb-functions-as-__always_inline.patch
-# CVE-2019-12382 rhbz 1715554 1715556
-Patch532: drm-edid-fix-missing-check-bug-in-drm_load_edid_firmware.patch
-
-# CVE-2019-12379 rhbz 1715491 1715706
-Patch533: consolemap-fix-memory-leaking-bug.patch
-
-# CVE-2019-12455 rhbz 1716990 1717003
-Patch534: clk-sunxi-fix-a-missing-check-bug-in-sunxi_divs_clk_setup.patch
-
-# CVE-2019-12454 rhbz 1716996 1717003
-Patch535: wcd9335-fix-a-incorrect-use-of-kstrndup.patch
-
-# CVE-2019-12456 rhbz 1717182 1717183
-Patch536: scsi-mpt3sas_ctl-fix-double-fetch-bug-in_ctl_ioctl_main.patch
-
-# CVE-2019-12614 rhbz 1718176 1718185
-Patch538: powerpc-fix-a-missing-check-in-dlpar_parse_cc_property.patch
-
-# Fix the LCD panel on the GPD MicroPC not working, pending as fixes for 5.2
-Patch544: drm-panel-orientation-quirks.patch
-
-# rhbz 1716334
-# https://patchwork.kernel.org/patch/11029027/
-Patch547: iwlwifi-mvm-disable-TX-AMSDU-on-older-NICs.patch
-
-# CVE-2019-????? rhbz 1731784
-Patch550: 8250_lpss-check-null-return-when-calling-pci_ioremap.patch
+# Fix the LCD panel orientation on the GPD MicroPC, pending as fix for 5.3
+Patch531: drm-panel-orientation-quirks.patch
# rhbz 1732045
-Patch551: 0001-dma-direct-correct-the-physical-addr-in-dma_direct_s.patch
+Patch532: 0001-dma-direct-correct-the-physical-addr-in-dma_direct_s.patch
+
+# This should make stable soon
+Patch533: for-v5.2-iwlwifi-mvm-disable-TX-AMSDU-on-older-NICs.patch
# END OF PATCH DEFINITIONS
@@ -1626,7 +1588,7 @@ BuildKernel %make_target %kernel_image %{_use_vdso}
fi \
fi \
if [ "%{zipmodules}" -eq "1" ]; then \
- find $RPM_BUILD_ROOT/lib/modules/ -type f -name '*.ko' | xargs xz; \
+ find $RPM_BUILD_ROOT/lib/modules/ -type f -name '*.ko' | xargs -P%{zcpu} xz; \
fi \
%{nil}
@@ -1891,6 +1853,9 @@ fi
#
#
%changelog
+* Mon Jul 29 2019 Justin M. Forbes <jforbes@fedoraproject.org> - 5.2.4-200
+- Linux v5.2.4 Rebase
+
* Fri Jul 26 2019 Jeremy Cline <jcline@redhat.com> - 5.1.20-300
- Linux v5.1.20