summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
authorJustin M. Forbes <jforbes@fedoraproject.org>2021-06-10 09:41:42 -0500
committerJustin M. Forbes <jforbes@fedoraproject.org>2021-06-10 09:41:42 -0500
commite5c1ab6d64e0de0321ee1c62f32f89480e3b8d2d (patch)
tree1252bde7a75574d90654df153904d5d48f3acca8 /kernel.spec
parent3429b90aea0dd898f9dbfa030ce6830c43a4cbce (diff)
downloadkernel-e5c1ab6d64e0de0321ee1c62f32f89480e3b8d2d.tar.gz
kernel-e5c1ab6d64e0de0321ee1c62f32f89480e3b8d2d.tar.xz
kernel-e5c1ab6d64e0de0321ee1c62f32f89480e3b8d2d.zip
kernel-5.13.0-0.rc5.20210610gitcd1245d75ce9.40
* Thu Jun 10 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.13.0-0.rc5.20210610gitcd1245d75ce9.40] - spec: Enable sefltests rpm build (Jiri Olsa) - spec: Allow bpf selftest/samples to fail (Jiri Olsa) - kvm: Add kvm_stat.service file and kvm_stat logrotate config to the tools (Jiri Benc) - kernel.spec: Add missing source files to kernel-selftests-internal (Jiri Benc) - kernel.spec: selftests: add net/forwarding to TARGETS list (Jiri Benc) - kernel.spec: selftests: add build requirement on libmnl-devel (Jiri Benc) - kernel.spec: add action.o to kernel-selftests-internal (Jiri Benc) - kernel.spec: avoid building bpftool repeatedly (Jiri Benc) - kernel.spec: selftests require python3 (Jiri Benc) - kernel.spec: skip selftests that failed to build (Jiri Benc) - kernel.spec: fix installation of bpf selftests (Jiri Benc) - redhat: fix samples and selftests make options (Jiri Benc) - kernel.spec: enable mptcp selftests for kernel-selftests-internal (Jiri Benc) - kernel.spec: Do not export shared objects from libexecdir to RPM Provides (Jiri Benc) - kernel.spec: add missing dependency for the which package (Jiri Benc) - kernel.spec: add netfilter selftests to kernel-selftests-internal (Jiri Benc) - kernel.spec: move slabinfo and page_owner_sort debuginfo to tools-debuginfo (Jiri Benc) - kernel.spec: package and ship VM tools (Jiri Benc) - configs: enable CONFIG_PAGE_OWNER (Jiri Benc) - kernel.spec: add coreutils (Jiri Benc) - kernel.spec: add netdevsim driver selftests to kernel-selftests-internal (Jiri Benc) - redhat/Makefile: Clean out the --without flags from the baseonly rule (Jiri Benc) - kernel.spec: Stop building unnecessary rpms for baseonly builds (Jiri Benc) - kernel.spec: disable more kabi switches for gcov build (Jiri Benc) - kernel.spec: Rename kabi-dw base (Jiri Benc) - kernel.spec: Fix error messages during build of zfcpdump kernel (Jiri Benc) - kernel.spec: perf: remove bpf examples (Jiri Benc) - kernel.spec: selftests should not depend on modules-internal (Jiri Benc) - kernel.spec: build samples (Jiri Benc) - kernel.spec: tools: sync missing options with RHEL 8 (Jiri Benc) - configs/ark/s390: set CONFIG_MARCH_Z14 and CONFIG_TUNE_Z15 (Philipp Rudo) [1876435] - configs/common/s390: Clean up CONFIG_{MARCH,TUNE}_Z* (Philipp Rudo) - configs/process_configs.sh: make use of dummy-tools (Philipp Rudo) - configs/common: disable CONFIG_INIT_STACK_ALL_{PATTERN,ZERO} (Philipp Rudo) - configs/common/aarch64: disable CONFIG_RELR (Philipp Rudo) Resolves: rhbz#1876435 Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
Diffstat (limited to 'kernel.spec')
-rwxr-xr-xkernel.spec22
1 files changed, 14 insertions, 8 deletions
diff --git a/kernel.spec b/kernel.spec
index c8eee6b61..22156f28e 100755
--- a/kernel.spec
+++ b/kernel.spec
@@ -73,7 +73,7 @@ Summary: The Linux kernel
# the --with-release option overrides this setting.)
%define debugbuildsenabled 0
-%global distro_build 0.rc5.20210608git368094df48e6.39
+%global distro_build 0.rc5.20210610gitcd1245d75ce9.40
%if 0%{?fedora}
%define secure_boot_arch x86_64
@@ -117,13 +117,13 @@ Summary: The Linux kernel
%define kversion 5.13
%define rpmversion 5.13.0
-%define pkgrelease 0.rc5.20210608git368094df48e6.39
+%define pkgrelease 0.rc5.20210610gitcd1245d75ce9.40
# This is needed to do merge window version magic
%define patchlevel 13
# allow pkg_release to have configurable %%{?dist} tag
-%define specrelease 0.rc5.20210608git368094df48e6.39%{?buildid}%{?dist}
+%define specrelease 0.rc5.20210610gitcd1245d75ce9.40%{?buildid}%{?dist}
%define pkg_release %{specrelease}
@@ -573,6 +573,9 @@ BuildRequires: libtraceevent-devel
%ifnarch %{arm} s390x
BuildRequires: numactl-devel
%endif
+%ifarch aarch64
+BuildRequires: opencsd-devel >= 1.0.0-2
+%endif
%endif
%if %{with_tools}
BuildRequires: gettext ncurses-devel
@@ -647,7 +650,7 @@ BuildRequires: clang
# exact git commit you can run
#
# xzcat -qq ${TARBALL} | git get-tar-commit-id
-Source0: linux-5.13-rc5-36-g368094df48e6.tar.xz
+Source0: linux-5.13-rc5-63-gcd1245d75ce9.tar.xz
Source1: Makefile.rhelver
@@ -1316,8 +1319,8 @@ ApplyOptionalPatch()
fi
}
-%setup -q -n kernel-5.13-rc5-36-g368094df48e6 -c
-mv linux-5.13-rc5-36-g368094df48e6 linux-%{KVERREL}
+%setup -q -n kernel-5.13-rc5-63-gcd1245d75ce9 -c
+mv linux-5.13-rc5-63-gcd1245d75ce9 linux-%{KVERREL}
cd linux-%{KVERREL}
cp -a %{SOURCE1} .
@@ -2096,8 +2099,11 @@ InitBuildVars
%endif
%endif
+%ifarch aarch64
+%global perf_build_extra_opts CORESIGHT=1
+%endif
%global perf_make \
- %{__make} %{?make_opts} EXTRA_CFLAGS="${RPM_OPT_FLAGS}" LDFLAGS="%{__global_ldflags}" %{?cross_opts} -C tools/perf V=1 NO_PERF_READ_VDSO32=1 NO_PERF_READ_VDSOX32=1 WERROR=0 NO_LIBUNWIND=1 HAVE_CPLUS_DEMANGLE=1 NO_GTK2=1 NO_STRLCPY=1 NO_BIONIC=1 LIBBPF_DYNAMIC=1 LIBTRACEEVENT_DYNAMIC=1 prefix=%{_prefix} PYTHON=%{__python3}
+ %{__make} %{?make_opts} EXTRA_CFLAGS="${RPM_OPT_FLAGS}" LDFLAGS="%{__global_ldflags}" %{?cross_opts} -C tools/perf V=1 NO_PERF_READ_VDSO32=1 NO_PERF_READ_VDSOX32=1 WERROR=0 NO_LIBUNWIND=1 HAVE_CPLUS_DEMANGLE=1 NO_GTK2=1 NO_STRLCPY=1 NO_BIONIC=1 LIBBPF_DYNAMIC=1 LIBTRACEEVENT_DYNAMIC=1 %{?perf_build_extra_opts} prefix=%{_prefix} PYTHON=%{__python3}
%if %{with_perf}
# perf
# make sure check-headers.sh is executable
@@ -2871,7 +2877,7 @@ fi
#
#
%changelog
-* Tue Jun 08 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.13.0-0.rc5.20210608git368094df48e6.39]
+* Thu Jun 10 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.13.0-0.rc5.20210610gitcd1245d75ce9.40]
- spec: Enable sefltests rpm build (Jiri Olsa)
- spec: Allow bpf selftest/samples to fail (Jiri Olsa)
- kvm: Add kvm_stat.service file and kvm_stat logrotate config to the tools (Jiri Benc)