summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
authorJosh Boyer <jwboyer@redhat.com>2012-01-05 13:38:54 -0500
committerJosh Boyer <jwboyer@redhat.com>2012-01-05 13:41:06 -0500
commitac403a617cea3f1c74a56bb54c2ee3b17988fee9 (patch)
tree92ee64b5a1232711a96cd789cb115b1f7e7bd1c8 /kernel.spec
parentbe19a69e8c7c9ba02219cceb4fde97df7d94a8f0 (diff)
downloadkernel-ac403a617cea3f1c74a56bb54c2ee3b17988fee9.tar.gz
kernel-ac403a617cea3f1c74a56bb54c2ee3b17988fee9.tar.xz
kernel-ac403a617cea3f1c74a56bb54c2ee3b17988fee9.zip
Move the depmod file removal below the compat-wireless build to make sure we
clean them all out
Diffstat (limited to 'kernel.spec')
-rw-r--r--kernel.spec17
1 files changed, 11 insertions, 6 deletions
diff --git a/kernel.spec b/kernel.spec
index 6264d15da..55ff2fa29 100644
--- a/kernel.spec
+++ b/kernel.spec
@@ -1791,12 +1791,6 @@ BuildKernel() {
rm mod-extra.list mod-extra2.list mod-extra3.list
popd
- # remove files that will be auto generated by depmod at rpm -i time
- for i in alias alias.bin builtin.bin ccwmap dep dep.bin ieee1394map inputmap isapnpmap ofmap pcimap seriomap symbols symbols.bin usbmap
- do
- rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/modules.$i
- done
-
# Move the devel headers out of the root file system
mkdir -p $RPM_BUILD_ROOT/usr/src/kernels
mv $RPM_BUILD_ROOT/lib/modules/$KernelVer/build $RPM_BUILD_ROOT/$DevelDir
@@ -1820,6 +1814,13 @@ BuildKernel() {
cd -
%endif
+
+ # remove files that will be auto generated by depmod at rpm -i time
+ for i in alias alias.bin builtin.bin ccwmap dep dep.bin ieee1394map inputmap isapnpmap ofmap pcimap seriomap symbols symbols.bin usbmap
+ do
+ rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/modules.$i
+ done
+
}
###
@@ -2286,6 +2287,10 @@ fi
# ||----w |
# || ||
%changelog
+* Thu Jan 05 2012 Josh Boyer <jwboyer@redhat.com>
+- Move the depmod file removal below the compat-wireless build to make sure we
+ clean them all out
+
* Thu Jan 05 2012 Dave Jones <davej@redhat.com>
- CONFIG_DEBUG_SET_MODULE_RONX should always be set.