summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
authorJustin M. Forbes <jforbes@fedoraproject.org>2021-12-01 11:22:02 -0600
committerJustin M. Forbes <jforbes@fedoraproject.org>2021-12-01 11:22:02 -0600
commit3d549bf473e9bcd03a7855a0dcfe22731d836e3e (patch)
tree43c4cdadb415eee4f13b013bc26b3074b5d6aca1 /kernel.spec
parent24c54b66f612ef44208248ded797fde114e72ebe (diff)
downloadkernel-3d549bf473e9bcd03a7855a0dcfe22731d836e3e.tar.gz
kernel-3d549bf473e9bcd03a7855a0dcfe22731d836e3e.tar.xz
kernel-3d549bf473e9bcd03a7855a0dcfe22731d836e3e.zip
kernel-5.16-0.rc3.20211201git58e1100fdc59.25
* Wed Dec 01 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.16-0.rc3.20211201git58e1100fdc59.25] - redhat/configs: unset KEXEC_SIG for s390x zfcpdump (Coiby Xu) - spec: Keep .BTF section in modules (Jiri Olsa) Resolves: rhbz# Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
Diffstat (limited to 'kernel.spec')
-rwxr-xr-xkernel.spec27
1 files changed, 18 insertions, 9 deletions
diff --git a/kernel.spec b/kernel.spec
index 4614f264a..7820ae478 100755
--- a/kernel.spec
+++ b/kernel.spec
@@ -83,9 +83,9 @@ Summary: The Linux kernel
# Set debugbuildsenabled to 0 to not build a separate debug kernel, but
# to build the base kernel using the debug configuration. (Specifying
# the --with-release option overrides this setting.)
-%define debugbuildsenabled 1
+%define debugbuildsenabled 0
-%global distro_build 0.rc3.24
+%global distro_build 0.rc3.20211201git58e1100fdc59.25
%if 0%{?fedora}
%define secure_boot_arch x86_64
@@ -130,13 +130,13 @@ Summary: The Linux kernel
%define rpmversion 5.16.0
%define patchversion 5.16
-%define pkgrelease 0.rc3.24
+%define pkgrelease 0.rc3.20211201git58e1100fdc59.25
# This is needed to do merge window version magic
%define patchlevel 16
# allow pkg_release to have configurable %%{?dist} tag
-%define specrelease 0.rc3.24%{?buildid}%{?dist}
+%define specrelease 0.rc3.20211201git58e1100fdc59.25%{?buildid}%{?dist}
%define pkg_release %{specrelease}
@@ -411,6 +411,11 @@ Summary: The Linux kernel
%define with_zfcpdump 0
%endif
+# skip BTF in kernel modules for s390x
+%ifnarch s390x
+%define with_kmod_btf --keep-section '.BTF'
+%endif
+
%if 0%{?fedora}
# This is not for Fedora
%define with_zfcpdump 0
@@ -682,7 +687,7 @@ BuildRequires: lld
# exact git commit you can run
#
# xzcat -qq ${TARBALL} | git get-tar-commit-id
-Source0: linux-5.16-rc3.tar.xz
+Source0: linux-5.16-rc3-51-g58e1100fdc59.tar.xz
Source1: Makefile.rhelver
@@ -1105,7 +1110,7 @@ AutoReqProv: no\
%description %{?1:%{1}-}debuginfo\
This package provides debug information for package %{name}%{?1:-%{1}}.\
This is required to use SystemTap with %{name}%{?1:-%{1}}-%{KVERREL}.\
-%{expand:%%global _find_debuginfo_opts %{?_find_debuginfo_opts} -p '.*\/usr\/src\/kernels/.*|XXX' -o ignored-debuginfo.list -p '/.*/%%{KVERREL_RE}%{?1:[+]%{1}}/.*|/.*%%{KVERREL_RE}%{?1:\+%{1}}(\.debug)?' -o debuginfo%{?1}.list}\
+%{expand:%%global _find_debuginfo_opts %{?_find_debuginfo_opts} %{?with_kmod_btf} -p '.*\/usr\/src\/kernels/.*|XXX' -o ignored-debuginfo.list -p '/.*/%%{KVERREL_RE}%{?1:[+]%{1}}/.*|/.*%%{KVERREL_RE}%{?1:\+%{1}}(\.debug)?' -o debuginfo%{?1}.list}\
%{nil}
#
@@ -1374,8 +1379,8 @@ ApplyOptionalPatch()
fi
}
-%setup -q -n kernel-5.16-rc3 -c
-mv linux-5.16-rc3 linux-%{KVERREL}
+%setup -q -n kernel-5.16-rc3-51-g58e1100fdc59 -c
+mv linux-5.16-rc3-51-g58e1100fdc59 linux-%{KVERREL}
cd linux-%{KVERREL}
cp -a %{SOURCE1} .
@@ -2184,7 +2189,7 @@ InitBuildVars
%global perf_build_extra_opts CORESIGHT=1
%endif
%global perf_make \
- %{__make} %{?make_opts} EXTRA_CFLAGS="${RPM_OPT_FLAGS}" LDFLAGS="%{__global_ldflags}" %{?cross_opts} -C tools/perf V=1 NO_PERF_READ_VDSO32=1 NO_PERF_READ_VDSOX32=1 WERROR=0 NO_LIBUNWIND=1 HAVE_CPLUS_DEMANGLE=1 NO_GTK2=1 NO_STRLCPY=1 NO_BIONIC=1 LIBTRACEEVENT_DYNAMIC=1 %{?perf_build_extra_opts} prefix=%{_prefix} PYTHON=%{__python3}
+ %{__make} %{?make_opts} EXTRA_CFLAGS="${RPM_OPT_FLAGS}" LDFLAGS="%{__global_ldflags}" %{?cross_opts} -C tools/perf V=1 NO_PERF_READ_VDSO32=1 NO_PERF_READ_VDSOX32=1 WERROR=0 NO_LIBUNWIND=1 HAVE_CPLUS_DEMANGLE=1 NO_GTK2=1 NO_STRLCPY=1 NO_BIONIC=1 LIBBPF_DYNAMIC=1 LIBTRACEEVENT_DYNAMIC=1 %{?perf_build_extra_opts} prefix=%{_prefix} PYTHON=%{__python3}
%if %{with_perf}
# perf
# make sure check-headers.sh is executable
@@ -2972,6 +2977,10 @@ fi
#
#
%changelog
+* Wed Dec 01 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.16-0.rc3.20211201git58e1100fdc59.25]
+- redhat/configs: unset KEXEC_SIG for s390x zfcpdump (Coiby Xu)
+- spec: Keep .BTF section in modules (Jiri Olsa)
+
* Wed Nov 24 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.16-0.rc2.20211124git5d9f4cf36721.19]
- Fix up PREEMPT configs (Justin M. Forbes)
- New configs in drivers/media (Fedora Kernel Team)