summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
authorLaura Abbott <labbott@redhat.com>2017-11-13 15:10:31 -0800
committerLaura Abbott <labbott@redhat.com>2017-11-13 15:10:31 -0800
commit0a7987e5d8ff88de051dc320f447b73c32b05a32 (patch)
treedd60be58d7623acab4e6e053763d3cab8645db65 /kernel.spec
parent1a5d24760948ee0eea5779cb3a177cd89e1a3373 (diff)
downloadkernel-0a7987e5d8ff88de051dc320f447b73c32b05a32.tar.gz
kernel-0a7987e5d8ff88de051dc320f447b73c32b05a32.tar.xz
kernel-0a7987e5d8ff88de051dc320f447b73c32b05a32.zip
Put some %if %{with_pae} in a few places
This is mostly to quiet a bunch of rpmlint warnings about unexpanded macros for non-existant packages.
Diffstat (limited to 'kernel.spec')
-rw-r--r--kernel.spec5
1 files changed, 4 insertions, 1 deletions
diff --git a/kernel.spec b/kernel.spec
index 14401f384..ad963ecb8 100644
--- a/kernel.spec
+++ b/kernel.spec
@@ -955,6 +955,7 @@ Provides: installonlypkg(kernel)\
# Now, each variant package.
+%if %{with_pae}
%ifnarch armv7hl
%define variant_summary The Linux kernel compiled for PAE capable machines
%kernel_variant_package %{pae}
@@ -984,7 +985,7 @@ Install the kernel-PAE package if your machine has more than 4GB of memory.
This variant of the kernel has numerous debugging options enabled.
It should only be installed when trying to gather additional information
on kernel bugs, as some of these options impact performance noticably.
-
+%endif
%define variant_summary The Linux kernel compiled with extra debugging enabled
%kernel_variant_package debug
@@ -2018,11 +2019,13 @@ fi}\
%kernel_variant_preun
%kernel_variant_post -r kernel-smp
+%if %{with_pae}
%kernel_variant_preun %{pae}
%kernel_variant_post -v %{pae} -r (kernel|kernel-smp)
%kernel_variant_post -v %{pae}debug -r (kernel|kernel-smp)
%kernel_variant_preun %{pae}debug
+%endif
%kernel_variant_preun debug
%kernel_variant_post -v debug