summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
authorThorsten Leemhuis <fedora@leemhuis.info>2023-02-04 09:24:53 +0100
committerThorsten Leemhuis <fedora@leemhuis.info>2023-02-04 09:24:53 +0100
commit710607627563e6f74121d207e4606f543238f303 (patch)
tree14703249c9eb4512b8bc4dd0e9351cc7547824dc /kernel.spec
parent2310bfb9db6ac8bedbe0ef5d2b218abf57d6d979 (diff)
parentc97f56fe27309b3394cab2fef4b3d454df7071f0 (diff)
downloadkernel-rawhide-user-thl-vanilla-fedora.tar.gz
kernel-rawhide-user-thl-vanilla-fedora.tar.xz
kernel-rawhide-user-thl-vanilla-fedora.zip
Diffstat (limited to 'kernel.spec')
-rwxr-xr-xkernel.spec38
1 files changed, 28 insertions, 10 deletions
diff --git a/kernel.spec b/kernel.spec
index 873f3cb30..c56ec0a1a 100755
--- a/kernel.spec
+++ b/kernel.spec
@@ -130,13 +130,13 @@ Summary: The Linux kernel
# define buildid .local
%define specversion 6.2.0
%define patchversion 6.2
-%define pkgrelease 0.rc6.20230131git22b8077d0fce.45
+%define pkgrelease 0.rc6.20230203git66a87fff1a87.47
%define kversion 6
-%define tarfile_release 6.2-rc6-3-g22b8077d0fce
+%define tarfile_release 6.2-rc6-163-g66a87fff1a87
# This is needed to do merge window version magic
%define patchlevel 2
# This allows pkg_release to have configurable %%{?dist} tag
-%define specrelease 0.rc6.20230131git22b8077d0fce.45%{?buildid}%{?dist}
+%define specrelease 0.rc6.20230203git66a87fff1a87.47%{?buildid}%{?dist}
# This defines the kabi tarball version
%define kabiversion 6.2.0
@@ -639,7 +639,7 @@ BuildRequires: python3-docutils
BuildRequires: zlib-devel binutils-devel
%endif
%if %{with_selftests}
-BuildRequires: clang llvm fuse-devel
+BuildRequires: clang llvm-devel fuse-devel
%ifnarch %{arm}
BuildRequires: numactl-devel
%endif
@@ -854,7 +854,7 @@ Source2002: kvm_stat.logrotate
# Some people enjoy building customized kernels from the dist-git in Fedora and
# use this to override configuration options. One day they may all use the
# source tree, but in the mean time we carry this to support the legacy workflow
-Source3000: merge.pl
+Source3000: merge.py
Source3001: kernel-local
%if %{patchlist_changelog}
Source3002: Patchlist.changelog
@@ -1046,7 +1046,7 @@ This package provides debug information for package kernel-tools.
%{expand:%%global _find_debuginfo_opts %{?_find_debuginfo_opts} -p '.*%%{_bindir}/centrino-decode(\.debug)?|.*%%{_bindir}/powernow-k8-decode(\.debug)?|.*%%{_bindir}/cpupower(\.debug)?|.*%%{_libdir}/libcpupower.*|.*%%{_bindir}/turbostat(\.debug)?|.*%%{_bindir}/x86_energy_perf_policy(\.debug)?|.*%%{_bindir}/tmon(\.debug)?|.*%%{_bindir}/lsgpio(\.debug)?|.*%%{_bindir}/gpio-hammer(\.debug)?|.*%%{_bindir}/gpio-event-mon(\.debug)?|.*%%{_bindir}/gpio-watch(\.debug)?|.*%%{_bindir}/iio_event_monitor(\.debug)?|.*%%{_bindir}/iio_generic_buffer(\.debug)?|.*%%{_bindir}/lsiio(\.debug)?|.*%%{_bindir}/intel-speed-select(\.debug)?|.*%%{_bindir}/page_owner_sort(\.debug)?|.*%%{_bindir}/slabinfo(\.debug)?|.*%%{_sbindir}/intel_sdsi(\.debug)?|XXX' -o kernel-tools-debuginfo.list}
%package -n rtla
-Summary: RTLA: Real-Time Linux Analysis tools
+Summary: RTLA: Real-Time Linux Analysis tools
%description -n rtla
The rtla tool is a meta-tool that includes a set of commands that
aims to analyze the real-time properties of Linux. But, instead of
@@ -1517,7 +1517,7 @@ cd configs
# Drop some necessary files from the source dir into the buildroot
cp $RPM_SOURCE_DIR/kernel-*.config .
cp %{SOURCE80} .
-# merge.pl
+# merge.py
cp %{SOURCE3000} .
# kernel-local
cp %{SOURCE3001} .
@@ -1528,12 +1528,12 @@ FLAVOR=%{primary_target} SPECVERSION=%{version} ./generate_all_configs.sh %{debu
for i in %{all_arch_configs}
do
mv $i $i.tmp
- ./merge.pl %{SOURCE3001} $i.tmp > $i
+ ./merge.py %{SOURCE3001} $i.tmp > $i
%if %{with_gcov}
echo "Merging with gcov options"
cat %{SOURCE75}
mv $i $i.tmp
- ./merge.pl %{SOURCE75} $i.tmp > $i
+ ./merge.py %{SOURCE75} $i.tmp > $i
%endif
rm $i.tmp
done
@@ -3229,11 +3229,29 @@ fi
#
#
%changelog
-* Tue Jan 31 2023 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.2.0-0.rc6.22b8077d0fce.45]
+* Fri Feb 03 2023 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.2.0-0.rc6.66a87fff1a87.47]
+- Linux v6.2.0-0.rc6.66a87fff1a87
+
+* Thu Feb 02 2023 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.2.0-0.rc6.9f266ccaa2f5.46]
+- redhat/configs: Enable CONFIG_SENSORS_LM90 for RHEL (Mark Salter)
+- Fix up SQUASHFS decompression configs (Justin M. Forbes)
+- redhat/configs: enable CONFIG_OCTEON_EP as a module in ARK (Michal Schmidt) [2041990]
+- redhat: ignore rpminspect runpath report on urandom_read selftest binaries (Herton R. Krzesinski)
+- kernel.spec: add llvm-devel build requirement (Scott Weaver)
- Update self-test data to not expect debugbuildsenabled 0 (Justin M. Forbes)
- Turn off forced debug builds (Justin M. Forbes)
- Turn on debug builds for aarch64 Fedora (Justin M. Forbes)
+- redhat/configs: modify merge.py to match old overrides input (Clark Williams)
+- redhat: fixup pylint complaints (Clark Williams)
+- redhat: remove merge.pl and references to it (Clark Williams)
+- redhat: update merge.py to handle merge.pl corner cases (Clark Williams)
- Revert "redhat: fix elf got hardening for vm tools" (Don Zickus)
+- Linux v6.2.0-0.rc6.9f266ccaa2f5
+
+* Wed Feb 01 2023 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.2.0-0.rc6.c0b67534c95c.45]
+- Update rebase notes for Fedora (Justin M. Forbes)
+- Update CONFIG_LOCKDEP_CHAINS_BITS to 19 (cmurf)
+- Linux v6.2.0-0.rc6.c0b67534c95c
* Tue Jan 31 2023 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.2.0-0.rc6.22b8077d0fce.44]
- Linux v6.2.0-0.rc6.22b8077d0fce