summaryrefslogtreecommitdiffstats
path: root/swift-lang.spec
diff options
context:
space:
mode:
Diffstat (limited to 'swift-lang.spec')
-rw-r--r--swift-lang.spec30
1 files changed, 6 insertions, 24 deletions
diff --git a/swift-lang.spec b/swift-lang.spec
index 85eb38f..6fae4c8 100644
--- a/swift-lang.spec
+++ b/swift-lang.spec
@@ -1,7 +1,7 @@
%global debug_package %{nil}
-%global swifttag 4.2-DEVELOPMENT-SNAPSHOT-2018-06-23-a
-%global swiftgithash 1e07724
-%global swiftgitdate 20180623
+%global swifttag 4.2-DEVELOPMENT-SNAPSHOT-2018-06-26-a
+%global swiftgithash be3b9a7
+%global swiftgitdate 20180626
%global swiftbuild swift-source
Name: swift-lang
Version: 4.2
@@ -25,12 +25,10 @@ Source12: https://github.com/apple/swift-xcode-playground-support/archive/
Source13: swift-lang.conf
-Patch0: change-locations.patch
+Patch0: %{name}-%{version}-change-lldb-location.patch
Patch1: compiler-rt-no-ustat.patch
Patch2: no-ninja-build.patch
Patch3: time-struct-redefined.patch
-Patch4: integration-tests.patch
-Patch5: set-environ-variable.patch
BuildRequires: which
@@ -108,13 +106,6 @@ mv swift-xcode-playground-support-swift-%{swifttag} swift-xcode-playground-suppo
# Fixes an error in compiler-rt where the timespec struct is redefined
%patch3 -p0
-# Sets the environment variable SWIFT_BUILD_FOR_FEDORA to tell the tests to use
-# the correct version of clang when testing
-%patch4 -p0
-
-# Sets the environment variable SWIFT_BUILD_FOR_FEDORA for the toolchain build
-%patch5 -p0
-
%build
export VERBOSE=1
@@ -162,15 +153,6 @@ ln -fs liblldbIntelFeatures.so.6.0.0 %{buildroot}/usr/lib/swift-lldb/liblldbInte
ln -fs liblldbIntelFeatures.so.6 %{buildroot}/usr/lib/swift-lldb/liblldbIntelFeatures.so
ln -fs %{_bindir}/swift %{buildroot}%{_libexecdir}/swift-lldb/swift
-# We include our Swift-specific version of clang as it has additional functionality to
-# work with Swift in conjunction with other languages.
-mkdir -p %{buildroot}%{_libexecdir}/swift-clang
-install -m 0755 %{_builddir}/%{swiftbuild}/build/buildbot_linux/llvm-linux-x86_64/bin/clang-6.0 %{buildroot}%{_libexecdir}/swift-clang
-ln -fs clang-6.0 %{buildroot}/usr/libexec/swift-clang/clang
-ln -fs clang-6.0 %{buildroot}/usr/libexec/swift-clang/clang++
-ln -fs clang-6.0 %{buildroot}/usr/libexec/swift-clang/clang-cl
-ln -fs clang-6.0 %{buildroot}/usr/libexec/swift-clang/clang-cpp
-
mkdir -p %{buildroot}/usr/lib/swift
cp -r %{_builddir}/usr/lib/swift/* %{buildroot}/usr/lib/swift
ln -fs /usr/lib/swift %{buildroot}/usr/lib/swift-lldb/swift
@@ -204,8 +186,8 @@ install -m 0644 %{_builddir}/usr/share/man/man1/swift.1 %{buildroot}%{_mandir}/m
%postun -p /sbin/ldconfig
%changelog
-* Mon Jun 25 2018 Ron Olson <tachoknight@gmail.com> 4.2-0.20.20180623git1e07724
-- Updated to swift-4.2-DEVELOPMENT-SNAPSHOT-2018-06-23-a
+* Thu Jun 28 2018 Ron Olson <tachoknight@gmail.com> 4.2-0.20.20180626gitbe3b9a7
+- Updated to swift-4.2-DEVELOPMENT-SNAPSHOT-2018-06-26-a
* Wed Jun 13 2018 Ron Olson <tachoknight@gmail.com> 4.2-0.19.20180612gitbb9532c
- Updated to swift-4.2-DEVELOPMENT-SNAPSHOT-2018-06-12-a and removed
gcc-c++ as a build requirement