summaryrefslogtreecommitdiffstats
path: root/swift-lang.spec
diff options
context:
space:
mode:
Diffstat (limited to 'swift-lang.spec')
-rw-r--r--swift-lang.spec94
1 files changed, 71 insertions, 23 deletions
diff --git a/swift-lang.spec b/swift-lang.spec
index 3631c56..c11d9d0 100644
--- a/swift-lang.spec
+++ b/swift-lang.spec
@@ -1,12 +1,12 @@
%global debug_package %{nil}
-%global swifttag 4.2-DEVELOPMENT-SNAPSHOT-2018-09-26-a
-%global swiftgithash f4134eb
-%global swiftgitdate 20180926
+%global swifttag DEVELOPMENT-SNAPSHOT-2018-11-16-a
+%global swiftgithash 201dcba
+%global swiftgitdate 20181116
%global swiftbuild swift-source
%global __provides_exclude ^/usr/lib/swift-lldb/.*\\.so.*
Name: swift-lang
-Version: 4.2
-Release: 0.74.%{swiftgitdate}git%{swiftgithash}%{?dist}
+Version: 5.0
+Release: 0.11.%{swiftgitdate}git%{swiftgithash}%{?dist}
Summary: Apple's Swift programming language
License: ASL 2.0
URL: https://swift.org
@@ -26,10 +26,8 @@ Source12: https://github.com/apple/swift-xcode-playground-support/archive/
Source13: swift-lang.conf
Source14: swift-lang-runtime.conf
-Patch0: %{name}-%{version}-change-lldb-location.patch
-Patch1: compiler-rt-no-ustat.patch
-Patch2: no-ninja-build.patch
-Patch3: reflection-template.patch
+Patch0: change-lldb-location.patch
+Patch1: no-ninja-build.patch
BuildRequires: clang
BuildRequires: cmake
@@ -105,16 +103,9 @@ mv swift-xcode-playground-support-swift-%{swifttag} swift-xcode-playground-suppo
# as the swift executable (i.e. /usr/bin).
%patch0 -p0
-# sys/ustat.h was removed from glibc (per https://sourceware.org/git/?p=glibc.git;a=commit;h=cf2478d53ad7071e84c724a986b56fe17f4f4ca7)
-# A patch has been submitted to resolve this upstream (https://github.com/apple/swift-compiler-rt/pull/20) but until
-# it is merged this patch is necessary to build Swift on Fedora with the latest glibc.
-%patch1 -p0
-
# Since we require ninja for building, there's no sense to rebuild it just for Swift
-%patch2 -p0
+%patch1 -p0
-# Template issue with clang 7.0
-%patch3 -p0
%build
export VERBOSE=1
@@ -148,14 +139,13 @@ install -m 0755 %{_builddir}/usr/bin/repl_swift %{buildroot}%{_libexecdir}/swift
# make up the Swift toolchain. Since we use subdirectories for the
# libraries, no actual .so files are dumped in /usr/lib.
mkdir -p %{buildroot}/usr/lib/swift-lldb
-cp %{_builddir}/usr/lib/liblldb.so.6.0.0 %{buildroot}/usr/lib/swift-lldb
-ln -fs liblldb.so.6.0.0 %{buildroot}/usr/lib/swift-lldb/liblldb.so.6
-ln -fs liblldb.so.6 %{buildroot}/usr/lib/swift-lldb/liblldb.so
+cp %{_builddir}/usr/lib/liblldb.so.7.0.0 %{buildroot}/usr/lib/swift-lldb
+ln -fs liblldb.so.7.0.0 %{buildroot}/usr/lib/swift-lldb/liblldb.so.7
+ln -fs liblldb.so.7 %{buildroot}/usr/lib/swift-lldb/liblldb.so
cp %{_builddir}/usr/lib/libsourcekitdInProc.so %{buildroot}/usr/lib/swift-lldb
cp %{_builddir}/usr/lib/libswiftDemangle.so %{buildroot}/usr/lib/swift-lldb
-cp %{_builddir}/usr/lib/liblldbIntelFeatures.so.6.0.0 %{buildroot}/usr/lib/swift-lldb
-ln -fs liblldbIntelFeatures.so.6.0.0 %{buildroot}/usr/lib/swift-lldb/liblldbIntelFeatures.so.6
-ln -fs liblldbIntelFeatures.so.6 %{buildroot}/usr/lib/swift-lldb/liblldbIntelFeatures.so
+cp %{_builddir}/usr/lib/liblldbIntelFeatures.so.7 %{buildroot}/usr/lib/swift-lldb
+ln -fs liblldbIntelFeatures.so.7 %{buildroot}/usr/lib/swift-lldb/liblldbIntelFeatures.so
ln -fs %{_bindir}/swift %{buildroot}%{_libexecdir}/swift-lldb/swift
mkdir -p %{buildroot}/usr/lib/swift
@@ -204,6 +194,64 @@ install -m 0644 %{_builddir}/usr/share/man/man1/swift.1 %{buildroot}%{_mandir}/m
%changelog
+* Mon Nov 19 2018 Ron Olson <tachoknight@gmail.com> 5.0-0.11.20181116git201dcba
+- Updated to swift-DEVELOPMENT-SNAPSHOT-2018-11-16-a
+* Fri Nov 16 2018 Ron Olson <tachoknight@gmail.com> 5.0-0.10.20181115git739169d
+- Updated to swift-DEVELOPMENT-SNAPSHOT-2018-11-15-a
+* Wed Oct 31 2018 Ron Olson <tachoknight@gmail.com> 4.2.1-0.101.20181030git02a6ca9
+- Updated to swift-4.2.1-RELEASE
+* Tue Oct 30 2018 Ron Olson <tachoknight@gmail.com> 4.2-0.100.20181029gitf4134eb
+- Updated to swift-4.2-DEVELOPMENT-SNAPSHOT-2018-10-29-a
+* Sat Oct 27 2018 Ron Olson <tachoknight@gmail.com> 4.2-0.99.20181026gitf4134eb
+- Updated to swift-4.2-DEVELOPMENT-SNAPSHOT-2018-10-26-a
+* Fri Oct 26 2018 Ron Olson <tachoknight@gmail.com> 4.2-0.98.20181025gitf4134eb
+- Updated to swift-4.2-DEVELOPMENT-SNAPSHOT-2018-10-25-a
+* Wed Oct 24 2018 Ron Olson <tachoknight@gmail.com> 4.2-0.97.20181023gitf4134eb
+- Updated to swift-4.2-DEVELOPMENT-SNAPSHOT-2018-10-23-a
+* Tue Oct 23 2018 Ron Olson <tachoknight@gmail.com> 4.2-0.96.20181022gitf4134eb
+- Updated to swift-4.2-DEVELOPMENT-SNAPSHOT-2018-10-22-a
+* Mon Oct 22 2018 Ron Olson <tachoknight@gmail.com> 4.2-0.95.20181021gitf4134eb
+- Updated to swift-4.2-DEVELOPMENT-SNAPSHOT-2018-10-21-a
+* Sun Oct 21 2018 Ron Olson <tachoknight@gmail.com> 4.2-0.94.20181020gitf4134eb
+- Updated to swift-4.2-DEVELOPMENT-SNAPSHOT-2018-10-20-a
+* Fri Oct 19 2018 Ron Olson <tachoknight@gmail.com> 4.2-0.93.20181018gitf4134eb
+- Updated to swift-4.2-DEVELOPMENT-SNAPSHOT-2018-10-18-a
+* Thu Oct 18 2018 Ron Olson <tachoknight@gmail.com> 4.2-0.92.20181017gitf4134eb
+- Updated to swift-4.2-DEVELOPMENT-SNAPSHOT-2018-10-17-a
+* Wed Oct 17 2018 Ron Olson <tachoknight@gmail.com> 4.2-0.91.20181016gitf4134eb
+- Updated to swift-4.2-DEVELOPMENT-SNAPSHOT-2018-10-16-a
+* Tue Oct 16 2018 Ron Olson <tachoknight@gmail.com> 4.2-0.90.20181015gitf4134eb
+- Updated to swift-4.2-DEVELOPMENT-SNAPSHOT-2018-10-15-a
+* Mon Oct 15 2018 Ron Olson <tachoknight@gmail.com> 4.2-0.89.20181014gitf4134eb
+- Updated to swift-4.2-DEVELOPMENT-SNAPSHOT-2018-10-14-a
+* Sun Oct 14 2018 Ron Olson <tachoknight@gmail.com> 4.2-0.88.20181013gitf4134eb
+- Updated to swift-4.2-DEVELOPMENT-SNAPSHOT-2018-10-13-a
+* Sat Oct 13 2018 Ron Olson <tachoknight@gmail.com> 4.2-0.87.20181012gitf4134eb
+- Updated to swift-4.2-DEVELOPMENT-SNAPSHOT-2018-10-12-a
+* Fri Oct 12 2018 Ron Olson <tachoknight@gmail.com> 4.2-0.86.20181011gitf4134eb
+- Updated to swift-4.2-DEVELOPMENT-SNAPSHOT-2018-10-11-a
+* Thu Oct 11 2018 Ron Olson <tachoknight@gmail.com> 4.2-0.85.20181010gitf4134eb
+- Updated to swift-4.2-DEVELOPMENT-SNAPSHOT-2018-10-10-a
+* Wed Oct 10 2018 Ron Olson <tachoknight@gmail.com> 4.2-0.84.20181009gitf4134eb
+- Updated to swift-4.2-DEVELOPMENT-SNAPSHOT-2018-10-09-a
+* Tue Oct 09 2018 Ron Olson <tachoknight@gmail.com> 4.2-0.83.20181008gitf4134eb
+- Updated to swift-4.2-DEVELOPMENT-SNAPSHOT-2018-10-08-a
+* Mon Oct 08 2018 Ron Olson <tachoknight@gmail.com> 4.2-0.82.20181007gitf4134eb
+- Updated to swift-4.2-DEVELOPMENT-SNAPSHOT-2018-10-07-a
+* Sun Oct 07 2018 Ron Olson <tachoknight@gmail.com> 4.2-0.81.20181006gitf4134eb
+- Updated to swift-4.2-DEVELOPMENT-SNAPSHOT-2018-10-06-a
+* Sat Oct 06 2018 Ron Olson <tachoknight@gmail.com> 4.2-0.80.20181005gitf4134eb
+- Updated to swift-4.2-DEVELOPMENT-SNAPSHOT-2018-10-05-a
+* Thu Oct 04 2018 Ron Olson <tachoknight@gmail.com> 4.2-0.79.20181003gitf4134eb
+- Updated to swift-4.2-DEVELOPMENT-SNAPSHOT-2018-10-03-a
+* Wed Oct 03 2018 Ron Olson <tachoknight@gmail.com> 4.2-0.78.20181002gitf4134eb
+- Updated to swift-4.2-DEVELOPMENT-SNAPSHOT-2018-10-02-a
+* Tue Oct 02 2018 Ron Olson <tachoknight@gmail.com> 4.2-0.77.20181001gitf4134eb
+- Updated to swift-4.2-DEVELOPMENT-SNAPSHOT-2018-10-01-a
+* Sat Sep 29 2018 Ron Olson <tachoknight@gmail.com> 4.2-0.76.20180928gitf4134eb
+- Updated to swift-4.2-DEVELOPMENT-SNAPSHOT-2018-09-28-a
+* Fri Sep 28 2018 Ron Olson <tachoknight@gmail.com> 4.2-0.75.20180927gitf4134eb
+- Updated to swift-4.2-DEVELOPMENT-SNAPSHOT-2018-09-27-a
* Thu Sep 27 2018 Ron Olson <tachoknight@gmail.com> 4.2-0.74.20180926gitf4134eb
- Updated to swift-4.2-DEVELOPMENT-SNAPSHOT-2018-09-26-a
* Wed Sep 26 2018 Ron Olson <tachoknight@gmail.com> 4.2-0.73.20180925gitf4134eb