summaryrefslogtreecommitdiffstats
path: root/swift-lang.spec
diff options
context:
space:
mode:
authorRon Olson <tachoknight@gmail.com>2018-11-16 14:34:39 -0600
committerRon Olson <tachoknight@gmail.com>2018-11-16 14:34:39 -0600
commitd1974439b30c1864f6498acae0d74d158ace1b0e (patch)
tree89531cec01baef6dd0d95fa3b773228a698a43f5 /swift-lang.spec
parentfb52062cc204ba82b313e6d8e6cdf1756b54e647 (diff)
downloadswift-lang-d1974439b30c1864f6498acae0d74d158ace1b0e.tar.gz
swift-lang-d1974439b30c1864f6498acae0d74d158ace1b0e.tar.xz
swift-lang-d1974439b30c1864f6498acae0d74d158ace1b0e.zip
First attempt at post 4.2.1 using what will be 5.0 sources
Diffstat (limited to 'swift-lang.spec')
-rw-r--r--swift-lang.spec38
1 files changed, 15 insertions, 23 deletions
diff --git a/swift-lang.spec b/swift-lang.spec
index e6acf86..f86ef26 100644
--- a/swift-lang.spec
+++ b/swift-lang.spec
@@ -1,12 +1,12 @@
%global debug_package %{nil}
-%global swifttag 4.2.1-RELEASE
-%global swiftgithash 02a6ca9
-%global swiftgitdate 20181030
+%global swifttag DEVELOPMENT-SNAPSHOT-2018-11-15-a
+%global swiftgithash 739169d
+%global swiftgitdate 20181115
%global swiftbuild swift-source
%global __provides_exclude ^/usr/lib/swift-lldb/.*\\.so.*
Name: swift-lang
-Version: 4.2.1
-Release: 0.101.%{swiftgitdate}git%{swiftgithash}%{?dist}
+Version: 5.0
+Release: 0.1.%{swiftgitdate}git%{swiftgithash}%{?dist}
Summary: Apple's Swift programming language
License: ASL 2.0
URL: https://swift.org
@@ -26,10 +26,8 @@ Source12: https://github.com/apple/swift-xcode-playground-support/archive/
Source13: swift-lang.conf
Source14: swift-lang-runtime.conf
-Patch0: %{name}-%{version}-change-lldb-location.patch
-Patch1: compiler-rt-no-ustat.patch
-Patch2: no-ninja-build.patch
-Patch3: reflection-template.patch
+Patch0: change-lldb-location.patch
+Patch1: no-ninja-build.patch
BuildRequires: clang
BuildRequires: cmake
@@ -105,16 +103,9 @@ mv swift-xcode-playground-support-swift-%{swifttag} swift-xcode-playground-suppo
# as the swift executable (i.e. /usr/bin).
%patch0 -p0
-# sys/ustat.h was removed from glibc (per https://sourceware.org/git/?p=glibc.git;a=commit;h=cf2478d53ad7071e84c724a986b56fe17f4f4ca7)
-# A patch has been submitted to resolve this upstream (https://github.com/apple/swift-compiler-rt/pull/20) but until
-# it is merged this patch is necessary to build Swift on Fedora with the latest glibc.
-%patch1 -p0
-
# Since we require ninja for building, there's no sense to rebuild it just for Swift
-%patch2 -p0
+%patch1 -p0
-# Template issue with clang 7.0
-%patch3 -p0
%build
export VERBOSE=1
@@ -148,14 +139,13 @@ install -m 0755 %{_builddir}/usr/bin/repl_swift %{buildroot}%{_libexecdir}/swift
# make up the Swift toolchain. Since we use subdirectories for the
# libraries, no actual .so files are dumped in /usr/lib.
mkdir -p %{buildroot}/usr/lib/swift-lldb
-cp %{_builddir}/usr/lib/liblldb.so.6.0.0 %{buildroot}/usr/lib/swift-lldb
-ln -fs liblldb.so.6.0.0 %{buildroot}/usr/lib/swift-lldb/liblldb.so.6
-ln -fs liblldb.so.6 %{buildroot}/usr/lib/swift-lldb/liblldb.so
+cp %{_builddir}/usr/lib/liblldb.so.7.0.0 %{buildroot}/usr/lib/swift-lldb
+ln -fs liblldb.so.7.0.0 %{buildroot}/usr/lib/swift-lldb/liblldb.so.7
+ln -fs liblldb.so.7 %{buildroot}/usr/lib/swift-lldb/liblldb.so
cp %{_builddir}/usr/lib/libsourcekitdInProc.so %{buildroot}/usr/lib/swift-lldb
cp %{_builddir}/usr/lib/libswiftDemangle.so %{buildroot}/usr/lib/swift-lldb
-cp %{_builddir}/usr/lib/liblldbIntelFeatures.so.6.0.0 %{buildroot}/usr/lib/swift-lldb
-ln -fs liblldbIntelFeatures.so.6.0.0 %{buildroot}/usr/lib/swift-lldb/liblldbIntelFeatures.so.6
-ln -fs liblldbIntelFeatures.so.6 %{buildroot}/usr/lib/swift-lldb/liblldbIntelFeatures.so
+cp %{_builddir}/usr/lib/liblldbIntelFeatures.so.7 %{buildroot}/usr/lib/swift-lldb
+ln -fs liblldbIntelFeatures.so.7 %{buildroot}/usr/lib/swift-lldb/liblldbIntelFeatures.so
ln -fs %{_bindir}/swift %{buildroot}%{_libexecdir}/swift-lldb/swift
mkdir -p %{buildroot}/usr/lib/swift
@@ -204,6 +194,8 @@ install -m 0644 %{_builddir}/usr/share/man/man1/swift.1 %{buildroot}%{_mandir}/m
%changelog
+* Fri Nov 16 2018 Ron Olson <tachoknight@gmail.com> 5.0-0.1.20181115git739169d
+- Updated to swift-DEVELOPMENT-SNAPSHOT-2018-11-15-a
* Wed Oct 31 2018 Ron Olson <tachoknight@gmail.com> 4.2.1-0.101.20181030git02a6ca9
- Updated to swift-4.2.1-RELEASE
* Tue Oct 30 2018 Ron Olson <tachoknight@gmail.com> 4.2-0.100.20181029gitf4134eb