summaryrefslogtreecommitdiffstats
path: root/swift-lang.spec
diff options
context:
space:
mode:
authorRon Olson <tachoknight@gmail.com>2020-04-14 15:07:39 -0500
committerRon Olson <tachoknight@gmail.com>2020-04-14 15:07:39 -0500
commit8e62b80e958264b92e0804c336a1c2d8c461a2d0 (patch)
treed4ccd59108af39f8ea613155ecb091c283024b5b /swift-lang.spec
parent43fe7bf1ccdc651b37b9958e9a41bc9d67a1d4e9 (diff)
downloadswift-lang-8e62b80e958264b92e0804c336a1c2d8c461a2d0.tar.gz
swift-lang-8e62b80e958264b92e0804c336a1c2d8c461a2d0.tar.xz
swift-lang-8e62b80e958264b92e0804c336a1c2d8c461a2d0.zip
Updated to GitHub versionHEADmaster
Diffstat (limited to 'swift-lang.spec')
-rw-r--r--swift-lang.spec541
1 files changed, 348 insertions, 193 deletions
diff --git a/swift-lang.spec b/swift-lang.spec
index e2083ae..5cb9cba 100644
--- a/swift-lang.spec
+++ b/swift-lang.spec
@@ -1,50 +1,51 @@
%global debug_package %{nil}
-%global swifttag 5.0.1-RELEASE
-%global swiftgithash 604054e
-%global swiftgitdate 20190418
+%global swifttag 5.2.1-RELEASE
+# Swift syntax seems to only be updated on major releases
+%global swiftsyntax 5.2.1-RELEASE
%global swiftbuild swift-source
-%global __provides_exclude ^/usr/lib/swift-lldb/.*\\.so.*
-
-Name: swift-lang
-Version: 5.0.1
-Release: 0.55.%{swiftgitdate}git%{swiftgithash}%{?dist}
-Summary: Apple's Swift programming language
-License: ASL 2.0
-URL: https://swift.org
-Source0: https://github.com/apple/swift/archive/swift-%{swifttag}.tar.gz#/swift.tar.gz
-Source1: https://github.com/apple/swift-compiler-rt/archive/swift-%{swifttag}.tar.gz#/swift-compiler-rt.tar.gz
-Source2: https://github.com/apple/swift-corelibs-libdispatch/archive/swift-%{swifttag}.tar.gz#/corelibs-libdispatch.tar.gz
-Source3: https://github.com/apple/swift-corelibs-foundation/archive/swift-%{swifttag}.tar.gz#/corelibs-foundation.tar.gz
-Source4: https://github.com/apple/swift-integration-tests/archive/swift-%{swifttag}.tar.gz#/swift-integration-tests.tar.gz
-Source5: https://github.com/apple/swift-corelibs-xctest/archive/swift-%{swifttag}.tar.gz#/corelibs-xctest.tar.gz
-Source6: https://github.com/apple/swift-clang/archive/swift-%{swifttag}.tar.gz#/clang.tar.gz
-Source7: https://github.com/apple/swift-package-manager/archive/swift-%{swifttag}.tar.gz#/package-manager.tar.gz
-Source8: https://github.com/apple/swift-lldb/archive/swift-%{swifttag}.tar.gz#/lldb.tar.gz
-Source9: https://github.com/apple/swift-llvm/archive/swift-%{swifttag}.tar.gz#/llvm.tar.gz
-Source10: https://github.com/apple/swift-llbuild/archive/swift-%{swifttag}.tar.gz#/llbuild.tar.gz
-Source11: https://github.com/apple/swift-cmark/archive/swift-%{swifttag}.tar.gz#/cmark.tar.gz
-Source12: https://github.com/apple/swift-xcode-playground-support/archive/swift-%{swifttag}.tar.gz#/swift-xcode-playground-support.tar.gz
-Source13: swift-lang.conf
-Source14: swift-lang-runtime.conf
-
-Patch0: change-lldb-location.patch
-Patch1: no-ninja-build.patch
-Patch2: clangloc.patch
-Patch3: compiler-rt-fuzzer.patch
-Patch4: swift-unwrapped.patch
-Patch5: no-inplace-copy.patch
-
+%global cmake_version 3.16.5
+
+Name: swift-lang
+Version: 5.2.1
+Release: 3%{?dist}
+Summary: Apple's Swift programming language
+License: ASL 2.0 and Unicode
+URL: https://swift.org
+Source0: https://github.com/apple/swift/archive/swift-%{swifttag}.tar.gz#/swift.tar.gz
+Source1: https://github.com/apple/swift-corelibs-libdispatch/archive/swift-%{swifttag}.tar.gz#/corelibs-libdispatch.tar.gz
+Source2: https://github.com/apple/swift-corelibs-foundation/archive/swift-%{swifttag}.tar.gz#/corelibs-foundation.tar.gz
+Source3: https://github.com/apple/swift-integration-tests/archive/swift-%{swifttag}.tar.gz#/swift-integration-tests.tar.gz
+Source4: https://github.com/apple/swift-corelibs-xctest/archive/swift-%{swifttag}.tar.gz#/corelibs-xctest.tar.gz
+Source5: https://github.com/apple/swift-package-manager/archive/swift-%{swifttag}.tar.gz#/package-manager.tar.gz
+Source6: https://github.com/apple/swift-llbuild/archive/swift-%{swifttag}.tar.gz#/llbuild.tar.gz
+Source7: https://github.com/apple/swift-cmark/archive/swift-%{swifttag}.tar.gz#/cmark.tar.gz
+Source8: https://github.com/apple/swift-xcode-playground-support/archive/swift-%{swifttag}.tar.gz#/swift-xcode-playground-support.tar.gz
+Source9: https://github.com/apple/sourcekit-lsp/archive/swift-%{swifttag}.tar.gz#/sourcekit-lsp.tar.gz
+Source10: https://github.com/apple/indexstore-db/archive/swift-%{swifttag}.tar.gz#/indexstore-db.tar.gz
+Source11: https://github.com/apple/llvm-project/archive/swift-%{swifttag}.tar.gz#/llvm-project.tar.gz
+Source12: https://github.com/unicode-org/icu/archive/release-61-2.tar.gz
+Source13: https://github.com/apple/swift-syntax/archive/swift-%{swiftsyntax}.zip#/swift-syntax.tar.gz
+Source14: https://github.com/Kitware/CMake/releases/download/v%{cmake_version}/cmake-%{cmake_version}.tar.gz
+
+Patch0: build-setup.patch
+Patch1: compiler-rt-fuzzer.patch
+Patch2: python3-2.patch
+Patch3: linux-tests-python-3-2.patch
+Patch4: glibcpthread.patch
+Patch5: swift.patch
+Patch6: llvm.patch
+Patch7: indexstore.patch
+Patch8: build-setup-s390x.patch
+Patch9: ibm-identifier.patch
+
BuildRequires: clang
-BuildRequires: cmake
BuildRequires: swig
BuildRequires: pkgconfig
BuildRequires: perl-podlators
BuildRequires: rsync
-%if 0%{?fedora} > 28
-BuildRequires: python-unversioned-command
-%endif
-BuildRequires: python2
-BuildRequires: python2-devel
+BuildRequires: python3
+BuildRequires: python3-devel
+BuildRequires: python3-distro
BuildRequires: libbsd-devel
BuildRequires: libxml2-devel
BuildRequires: libsqlite3x-devel
@@ -54,21 +55,26 @@ BuildRequires: libcurl-devel
BuildRequires: libuuid-devel
BuildRequires: libedit-devel
BuildRequires: libicu-devel
-# python2-sphinx was removed after f30
-%if 0%{?fedora} > 30
-BuildRequires: python3-sphinx
-%else
-BuildRequires: python2-sphinx
-%endif
BuildRequires: ninja-build
+BuildRequires: /usr/bin/pathfix.py
+BuildRequires: make
+BuildRequires: openssl-devel
-Requires: glibc-devel
-Requires: clang
+Requires: glibc-devel
+%if 0%{?fedora} >= 31
+Requires: binutils-gold
+%else
+Requires: binutils
+%endif
+Requires: gcc
Requires: ncurses-devel
Requires: ncurses-compat-libs
-Requires: %{name}-runtime = %{version}-%{release}
-ExclusiveArch: x86_64 aarch64
+Provides: %{name} = %{version}-%{release}
+Obsoletes: %{name} < %{version}-%{release}
+Obsoletes: %{name}-runtime < %{version}-%{release}
+
+ExclusiveArch: x86_64 aarch64 s390x
%description
@@ -83,182 +89,106 @@ importantly, Swift is designed to make writing and maintaining
correct programs easier for the developer.
-%package runtime
-Summary: Runtime files for Swift programs
-
-
-%description runtime
-Runtime libraries for Swift programs
-
-
%prep
-%setup -q -c -n %{swiftbuild} -a 0 -a 1 -a 2 -a 3 -a 4 -a 5 -a 6 -a 7 -a 8 -a 9 -a 10 -a 11 -a 12
+# Now we build our own CMake because the one in EPEL8 is too old and
+# we can safely build it for all platforms (though will add some time
+# to the whole build process)
+%setup -q -c -n cmake -a 14
+mkdir cmake-build
+cd cmake-build
+../cmake-%{cmake_version}/bootstrap && make
+
+%setup -q -c -n %{swiftbuild} -a 0 -a 1 -a 2 -a 3 -a 4 -a 5 -a 6 -a 7 -a 8 -a 9 -a 10 -a 11 -a 12 -a 13
# The Swift build script requires directories to be named
# in a specific way so renaming the source directories is
# necessary
-mv swift-clang-swift-%{swifttag} clang
mv swift-cmark-swift-%{swifttag} cmark
-mv swift-compiler-rt-swift-%{swifttag} compiler-rt
mv swift-corelibs-foundation-swift-%{swifttag} swift-corelibs-foundation
mv swift-corelibs-libdispatch-swift-%{swifttag} swift-corelibs-libdispatch
mv swift-corelibs-xctest-swift-%{swifttag} swift-corelibs-xctest
mv swift-integration-tests-swift-%{swifttag} swift-integration-tests
mv swift-llbuild-swift-%{swifttag} llbuild
-mv swift-lldb-swift-%{swifttag} lldb
-mv swift-llvm-swift-%{swifttag} llvm
mv swift-package-manager-swift-%{swifttag} swiftpm
mv swift-swift-%{swifttag} swift
mv swift-xcode-playground-support-swift-%{swifttag} swift-xcode-playground-support
+mv sourcekit-lsp-swift-%{swifttag} sourcekit-lsp
+mv indexstore-db-swift-%{swifttag} indexstore-db
+mv llvm-project-swift-%{swifttag} llvm-project
-# This patch tells the Swift executable to look for its Swift-specific
-# lldb executable in /usr/libexec/swift-lldb, not in the same directory
-# as the swift executable (i.e. /usr/bin).
-%patch0 -p0
+# ICU
+mv icu-release-61-2 icu
-# Since we require ninja for building, there's no sense to rebuild it just for Swift
-%patch1 -p0
+# Swift Syntax on its own release (sigh)
+mv swift-syntax-swift-%{swiftsyntax} swift-syntax
-# This changes the location of where the headers and libs are to keep lldb happy
-%patch2 -p0
+# Since we require ninja for building, there's no sense to rebuild it just for Swift
+%ifnarch s390x
+%patch0 -p0
+%else
+# Couple other things for s390x
+%patch8 -p0
+%endif
# Fixes an issue with using std::thread in a vector in compiler-rt
-%patch3 -p0
+%patch1 -p0
+
+# Python 3 is the new default so we need to make the python code work with it
+%patch2 -p0
+%patch3 -p0
-# Patch for handling optional issue with pthreads functions in Swift file
-# in the package mananger
+# Fixes compiler issue with glibc and pthreads after 2.5.0.9000
%patch4 -p0
-# Patch to handle library being copied to same directory; CMake 3.14 zeros
-# out the file
+#
+# 5.2 patches
+#
%patch5 -p0
+# implicit include of cstdint
+%patch6 -p0
+%patch7 -p0
+
+# s390x-specific patches
+%ifarch s390x
+%patch9 -p0
+%endif
+
+# Fix python to python3
+pathfix.py -pni "%{__python3} %{py3_shbang_opts}" swift/utils/api_checker/swift-api-checker.py
%build
export VERBOSE=1
-export PYTHON_DISALLOW_AMBIGUOUS_VERSION=0
+# We may not have /usr/bin/python, so we roll our own
+# because the build script expects there to be one.
+mkdir $PWD/binforpython
+ln -s /usr/bin/python3 $PWD/binforpython/python
+export PATH=$PWD/binforpython:$PATH
+# And for CMake, which we built first
+export PATH=$PWD/../cmake/cmake-build/bin:$PATH
+
+# Here we go!
swift/utils/build-script --preset=buildbot_linux,no_test install_destdir=%{_builddir} installable_package=%{_builddir}/swift-%{version}-fedora.tar.gz
%install
-export PYTHON_DISALLOW_AMBIGUOUS_VERSION=0
-mkdir -p %{buildroot}%{_libexecdir}/swift-lldb
+mkdir -p %{buildroot}%{_libexecdir}/swift/
+cp -r %{_builddir}/usr/* %{buildroot}%{_libexecdir}/swift
mkdir -p %{buildroot}%{_bindir}
-mkdir -p %{buildroot}/usr/lib
-install -m 0755 %{_builddir}/usr/bin/swift %{buildroot}%{_bindir}
-install -m 0755 %{_builddir}/usr/bin/swift-build %{buildroot}%{_bindir}
-install -m 0755 %{_builddir}/usr/bin/swift-build-tool %{buildroot}%{_bindir}
-install -m 0755 %{_builddir}/usr/bin/swift-demangle %{buildroot}%{_bindir}
-install -m 0755 %{_builddir}/usr/bin/swift-package %{buildroot}%{_bindir}
-install -m 0755 %{_builddir}/usr/bin/swift-run %{buildroot}%{_bindir}
-install -m 0755 %{_builddir}/usr/bin/swift-test %{buildroot}%{_bindir}
-ln -fs swift %{buildroot}/usr/bin/swift-autolink-extract
-ln -fs swift %{buildroot}/usr/bin/swiftc
-ln -fs swift %{buildroot}/usr/bin/swift-format
-
-install -m 0755 %{_builddir}/usr/bin/lldb* %{buildroot}%{_libexecdir}/swift-lldb
-install -m 0755 %{_builddir}/usr/bin/repl_swift %{buildroot}%{_libexecdir}/swift-lldb
-
-# Why /usr/lib instead of %{_libdir}?
-# The Swift toolchain is *extermely* sensitive to locations of its files
-# (for example, the need for the patch above in the prep section) and
-# has "lib" hardcoded in many, many places throughout all the projects that
-# make up the Swift toolchain. Since we use subdirectories for the
-# libraries, no actual .so files are dumped in /usr/lib.
-mkdir -p %{buildroot}/usr/lib/swift-lldb
-cp %{_builddir}/usr/lib/liblldb.so.7.0.0 %{buildroot}/usr/lib/swift-lldb
-ln -fs liblldb.so.7.0.0 %{buildroot}/usr/lib/swift-lldb/liblldb.so.7
-ln -fs liblldb.so.7 %{buildroot}/usr/lib/swift-lldb/liblldb.so
-cp %{_builddir}/usr/lib/libsourcekitdInProc.so %{buildroot}/usr/lib/swift-lldb
-cp %{_builddir}/usr/lib/libswiftDemangle.so %{buildroot}/usr/lib/swift-lldb
-cp %{_builddir}/usr/lib/liblldbIntelFeatures.so.7 %{buildroot}/usr/lib/swift-lldb
-ln -fs liblldbIntelFeatures.so.7 %{buildroot}/usr/lib/swift-lldb/liblldbIntelFeatures.so
-ln -fs %{_bindir}/swift %{buildroot}%{_libexecdir}/swift-lldb/swift
-
-mkdir -p %{buildroot}/usr/lib/swift
-cp -r %{_builddir}/usr/lib/swift/* %{buildroot}/usr/lib/swift
-rm %{buildroot}/usr/lib/swift/clang
-cp -r %{_builddir}/usr/lib/clang %{buildroot}/usr/lib/swift
-ln -fs /usr/lib/swift/clang/7.0.0/include %{buildroot}/usr/lib/swift/clang/include
-ln -fs /usr/lib/swift/clang/7.0.0/lib %{buildroot}/usr/lib/swift/clang/lib
-ln -fs /usr/lib/swift/clang/7.0.0/share %{buildroot}/usr/lib/swift/clang/share
-ln -fs /usr/lib/swift %{buildroot}/usr/lib/swift-lldb/swift
-chmod 0755 %{buildroot}/usr/lib/swift/linux/libswiftDispatch.so
-chmod 0755 %{buildroot}/usr/lib/swift/linux/libFoundation.so
-chmod 0755 %{buildroot}/usr/lib/swift/linux/libXCTest.so
-chmod 0755 %{buildroot}/usr/lib/swift/pm/llbuild/libllbuild.so
-chmod 0755 %{buildroot}/usr/lib/swift/pm/llbuild/libllbuildSwift.so
-
-mkdir -p %{buildroot}/usr/lib/swift_static
-cp -r %{_builddir}/usr/lib/swift_static/* %{buildroot}/usr/lib/swift_static
-
-mkdir -p %{buildroot}/%{_sysconfdir}/ld.so.conf.d/
-install -m 0644 %{SOURCE13} %{buildroot}/%{_sysconfdir}/ld.so.conf.d/swift-lang.conf
-install -m 0644 %{SOURCE14} %{buildroot}/%{_sysconfdir}/ld.so.conf.d/swift-lang-runtime.conf
-
+ln -fs %{_libexecdir}/swift/bin/swift %{buildroot}%{_bindir}/swift
+ln -fs %{_libexecdir}/swift/bin/swiftc %{buildroot}%{_bindir}/swiftc
+ln -fs %{_libexecdir}/swift/bin/sourcekit-lsp %{buildroot}%{_bindir}/sourcekit-lsp
mkdir -p %{buildroot}%{_mandir}/man1
-install -m 0644 %{_builddir}/usr/share/man/man1/swift.1 %{buildroot}%{_mandir}/man1
-
-
-# This is necessary because in Swift 4 the directories
-# under clang were actual directories. In 5 Apple added
-# an additional layer of indirection, to the compiler
-# version, with the previous directories relocated there.
-# Apparently there is an issue with rpm being able to
-# replace directories with something else (in this case,
-# symlinks), thus making this pre-installation step
-# necessary when upgrading from 4.x to 5.
-%pretrans -p <lua>
-path = "/usr/lib/swift/clang"
-subdirs = {"include", "lib"}
-for _, dir in ipairs(subdirs) do
- fullDir = path .. "/" .. dir
- st = posix.stat(fullDir)
- if st and st.type == "directory" then
- status = os.rename(fullDir, fullDir .. ".rpmmoved")
- if not status then
- suffix = 0
- while not status do
- suffix = suffix + 1
- status = os.rename(fullDir .. ".rpmmoved", fullDir .. ".rpmmoved." .. suffix)
- end
- os.rename(fullDir, fullDir .. ".rpmmoved")
- end
- end
-end
+cp %{_builddir}/usr/share/man/man1/swift.1 %{buildroot}%{_mandir}/man1/swift.1
%files
%license swift/LICENSE.txt
-%{_bindir}/swift*
-%{_mandir}/man1/*
-%ghost /usr/lib/swift/clang/include.rpmmoved
-%ghost /usr/lib/swift/clang/lib.rpmmoved
-/usr/lib/swift-lldb/
-/usr/lib/swift/Block/
-/usr/lib/swift/CoreFoundation/
-/usr/lib/swift/clang/
-/usr/lib/swift/dispatch/
-/usr/lib/swift/migrator/
-/usr/lib/swift/os/
-/usr/lib/swift/pm/
-/usr/lib/swift/shims/
-/usr/lib/swift_static/
-%{_libexecdir}/swift-lldb/
-%{_sysconfdir}/ld.so.conf.d/swift-lang.conf
-
-
-%files runtime
-%ghost /usr/lib/swift/clang/include.rpmmoved
-%ghost /usr/lib/swift/clang/lib.rpmmoved
-%dir /usr/lib/swift
-/usr/lib/swift/linux/
-%ifarch aarch64
-/usr/lib/swift/linux/aarch64/
-%else
-/usr/lib/swift/linux/x86_64/
-%endif
-%{_sysconfdir}/ld.so.conf.d/swift-lang-runtime.conf
+%{_bindir}/swift
+%{_bindir}/swiftc
+%{_bindir}/sourcekit-lsp
+%{_mandir}/man1/swift.1.gz
+%{_libexecdir}/swift/
%post -p /sbin/ldconfig
@@ -266,10 +196,235 @@ end
%changelog
-* Thu Apr 18 2019 Ron Olson <tachoknight@gmail.com> 5.0.1-0.55.20190418git604054e
-- Updated to swift-5.0.1-RELEASE
-* Thu Apr 18 2019 Ron Olson <tachoknight@gmail.com> 5.0-0.54.20190325gitba33f9e
-- And modified it again to allow new installations
+* Sun Apr 12 2020 Ron Olson <tachoknight@gmail.com> 5.2.1-3
+- Put CMake back as a build step because the version in EPEL 8 is too
+ old
+* Sun Apr 12 2020 Ron Olson <tachoknight@gmail.com> 5.2.1-2
+- Added s390x architecture and F30-specific requires
+* Mon Apr 06 2020 Ron Olson <tachoknight@gmail.com> 5.2.1-1
+- Reorganized the package to place everything in a single location,
+ changed the versioning scheme, and removed a number of obsolete patches
+* Wed Apr 01 2020 Ron Olson <tachoknight@gmail.com> 5.2.1-0.1.20200331git2e3b1b3
+- Updated to swift-5.2.1-RELEASE
+* Wed Mar 25 2020 Ron Olson <tachoknight@gmail.com> 5.2-0.10.20200324git443e9a4
+- Updated to swift-5.2-RELEASE
+* Thu Mar 12 2020 Ron Olson <tachoknight@gmail.com> 5.2-0.9.20200311git33150e3
+- Updated to swift-5.2-DEVELOPMENT-SNAPSHOT-2020-03-11-a and switched to
+ using patched version of cmake to get around issues building 5.2 with
+ 3.17
+* Fri Feb 28 2020 Ron Olson <tachoknight@gmail.com> 5.2-0.8.20200227git33150e3
+- Updated to swift-5.2-DEVELOPMENT-SNAPSHOT-2020-02-27-a
+* Sun Feb 02 2020 Ron Olson <tachoknight@gmail.com> 5.2-0.7.20200201git66c06ab
+- Updated to swift-5.2-DEVELOPMENT-SNAPSHOT-2020-02-01-a
+* Sat Feb 01 2020 Ron Olson <tachoknight@gmail.com> 5.2-0.6.20200131gitfab20c6
+- Updated to swift-5.2-DEVELOPMENT-SNAPSHOT-2020-01-31-a
+* Thu Jan 30 2020 Ron Olson <tachoknight@gmail.com> 5.2-0.5.20200129gita0c1677
+- Updated to swift-5.2-DEVELOPMENT-SNAPSHOT-2020-01-29-a
+* Tue Jan 28 2020 Ron Olson <tachoknight@gmail.com> 5.2-0.4.20200127git7c02102
+- Updated to swift-5.2-DEVELOPMENT-SNAPSHOT-2020-01-27-a
+* Mon Jan 20 2020 Ron Olson <tachoknight@gmail.com> 5.2-0.3.20200117git3194881
+- Updated to swift-5.2-DEVELOPMENT-SNAPSHOT-2020-01-17-a
+* Fri Jan 10 2020 Ron Olson <tachoknight@gmail.com> 5.2-0.2.20200109git880e9e6
+- Updated to swift-5.2-DEVELOPMENT-SNAPSHOT-2020-01-09-a
+* Tue Jan 07 2020 Ron Olson <tachoknight@gmail.com> 5.2-0.1.20200106git74df113
+- Updated to swift-5.2-DEVELOPMENT-SNAPSHOT-2020-01-06-a
+* Sat Dec 21 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.6.20191220git04833a6
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-12-20-a
+* Fri Dec 20 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.5.20191219git04833a6
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-12-19-a
+* Thu Dec 19 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.4.20191218git04833a6
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-12-18-a
+* Wed Dec 18 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.3.20191217git04833a6
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-12-17-a
+* Tue Dec 17 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.2.20191216git04833a6
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-12-16-a
+* Fri Dec 13 2019 Ron Olson <tachoknight@gmail.com> 5.1.3-0.1.20191213git005fc1f
+- Updated to swift-5.1.3-RELEASE
+* Fri Dec 13 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.20.20191212gita22eb08
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-12-12-a
+* Wed Dec 11 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.19.20191210git4a1b378
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-12-10-a
+* Tue Dec 10 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.18.20191209git4a1b378
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-12-09-a
+* Mon Dec 09 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.17.20191130gited9117a
+- Release of 5.1.2 with sourcekit-lsp enabled. The user still needs to build
+ and install the plugin for vscode; if they do this version will support
+ code-completion, also works with neovim too
+* Sat Dec 07 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.16.20191206git4b8db65
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-12-06-a
+* Fri Dec 06 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.15.20191205git4b8db65
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-12-05-a
+* Thu Dec 05 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.14.20191204git4b8db65
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-12-04-a
+* Wed Dec 04 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.13.20191203git4b8db65
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-12-03-a
+* Sat Nov 30 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.12.20191129git60f3082
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-11-29-a
+* Fri Nov 29 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.11.20191128git60f3082
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-11-28-a
+* Thu Nov 28 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.10.20191127git60f3082
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-11-27-a
+* Wed Nov 27 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.9.20191126git60f3082
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-11-26-a
+* Tue Nov 26 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.8.20191125git60f3082
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-11-25-a
+* Mon Nov 25 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.7.20191124git60f3082
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-11-24-a
+* Sat Nov 23 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.6.20191122git60f3082
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-11-22-a
+* Fri Nov 22 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.5.20191121git60f3082
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-11-21-a
+* Tue Nov 19 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.4.20191118git60f3082
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-11-18-a
+* Mon Nov 18 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.3.20191117git60f3082
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-11-17-a
+* Sat Nov 16 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.2.20191115git51fe191
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-11-15-a
+* Fri Nov 15 2019 Ron Olson <tachoknight@gmail.com> 5.1.3-0.1.20191114gite74feb6
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-11-14-a
+* Thu Nov 07 2019 Ron Olson <tachoknight@gmail.com> 5.1.2-0.1.20191107git71def56
+- Updated to swift-5.1.2-RELEASE
+* Wed Nov 06 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.7.20191105gitb368b0d
+- Added icu, also updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-11-05-a
+* Mon Nov 04 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.6.20191101git74328cd
+- Added unpackaged files, switched to new llvm-project-based subproject
+* Sun Nov 03 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.5.20191101git74328cd
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-11-01-a
+* Thu Oct 31 2019 Ron Olson <tachoknight@gmail.com> 5.1.1-0.4.20191004git4242edd
+- Added sourcekit-lsp
+* Wed Oct 30 2019 Ron Olson <tachoknight@gmail.com> 5.1.1-0.3.20191004git4242edd
+- Clang 9 was causing compiler-rt to not build properly due to a macro.
+* Thu Oct 17 2019 Ron Olson <tachoknight@gmail.com> 5.1.1-0.2.20191004git4242edd
+- Fixed issue with installing swift-lang only gave the option for
+ swift-lang-runtime
+* Fri Oct 04 2019 Ron Olson <tachoknight@gmail.com> 5.1.1-0.1.20191004git4242edd
+- Updated to swift-5.1.1-RELEASE
+* Thu Sep 19 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.57.20190919gitfa33242
+- Updated to swift-5.1-RELEASE and removed FrameworkABIBaseline as apparently
+ it disappeared
+* Thu Sep 19 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.56.20190918gite05f800
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-09-18-a
+* Wed Sep 18 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.55.20190917git1f49050
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-09-17-a
+* Tue Sep 17 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.54.20190916git279ca88
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-09-16-a
+* Mon Sep 16 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.53.20190915git279ca88
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-09-15-a
+* Sun Sep 15 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.52.20190914git279ca88
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-09-14-a
+* Sat Sep 14 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.51.20190913git11b9972
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-09-13-a
+* Fri Sep 13 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.50.20190912gitb9d082f
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-09-12-a
+* Thu Sep 12 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.49.20190911gitb8f4481
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-09-11-a
+* Tue Sep 10 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.48.20190909git28a0436
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-09-09-a
+* Mon Sep 09 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.47.20190908git28a0436
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-09-08-a also added test for
+ Red Hat Enterprise Linux and CentOS (when it is updated to match RHEL 8)
+ Also packaged some new files
+* Fri Sep 06 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.46.20190905git1880eb0
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-09-05-a
+* Thu Sep 05 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.45.20190904git1880eb0
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-09-04-a
+* Wed Sep 04 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.44.20190903gitfcc37cd
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-09-03-a
+* Tue Sep 03 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.43.20190902gitfcc37cd
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-09-02-a
+* Mon Sep 02 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.42.20190901gitfcc37cd
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-09-01-a
+* Sun Sep 01 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.41.20190831gitfcc37cd
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-08-31-a
+* Fri Aug 30 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.40.20190829gitfcc37cd
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-08-29-a
+* Thu Aug 29 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.39.20190828gite90298c
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-08-28-a and added explicit
+ requirement for python3-distro
+* Wed Aug 28 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.38.20190827gite90298c
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-08-27-a and added a patch
+ to allow LLDB to be built using Python 3.8 (currently in F32/Rawhide)
+* Tue Aug 27 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.37.20190826git3b0cf9e
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-08-26-a
+* Mon Aug 26 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.36.20190825git3b0cf9e
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-08-25-a
+* Sun Aug 25 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.35.20190824git3b0cf9e
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-08-24-a
+* Sat Aug 24 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.34.20190823git3b0cf9e
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-08-23-a
+* Fri Aug 23 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.33.20190822git3b0cf9e
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-08-22-a
+* Wed Aug 21 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.32.20190820git3b0cf9e
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-08-20-a
+* Mon Aug 19 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.31.20190817git3b0cf9e
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-08-17-a
+* Sat Aug 17 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.30.20190816git1329017
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-08-16-a
+* Fri Aug 16 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.29.20190815git1329017
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-08-15-a
+* Wed Aug 14 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.28.20190813git425a146
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-08-13-a
+* Tue Aug 13 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.27.20190812git425a146
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-08-12-a and added another
+ directory
+* Fri Jul 26 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.26.20190725git0450b7d
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-07-25-a
+* Thu Jul 25 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.25.20190724gite9b6385
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-07-24-a
+* Wed Jul 24 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.24.20190723git3e8f631
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-07-23-a
+* Tue Jul 23 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.23.20190719gitf883175
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-07-19-a and first version
+ that relies on Python 3 for building
+* Mon Jul 15 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.22.20190714git7b90512
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-07-14-a
+* Sun Jul 14 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.21.20190713git26c2dbe
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-07-13-a
+* Sat Jul 13 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.20.20190712gita062b3c
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-07-12-a
+* Fri Jul 12 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.19.20190711gitacd767e
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-07-11-a
+* Thu Jul 11 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.18.20190710gitd7f811d
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-07-10-a
+* Wed Jul 10 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.17.20190709gitf67864b
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-07-09-a
+* Thu Jul 04 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.16.20190703gitd2c038e
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-07-03-a
+* Wed Jul 03 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.15.20190702git2efadfd
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-07-02-a
+* Tue Jul 02 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.14.20190701git6761ba4
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-07-01-a and removed
+ dependency on python-sphinx as a problem with a pygments lexer was being
+ treated as an error and causing the builds to fail
+* Sun Jun 30 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.13.20190629gitdcde8ac
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-06-29-a
+* Sat Jun 29 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.12.20190628gitca3c825
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-06-28-a
+* Fri Jun 28 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.11.20190627git993b248
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-06-27-a
+* Thu Jun 27 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.10.20190626git16859f1
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-06-26-a and added patch
+ to remove reference to depreciated header file
+* Wed Jun 26 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.9.20190624git4e7bcdb
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-06-24-a and got the REPL
+ to work
+* Sun Jun 23 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.8.20190621git9729868
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-06-21-a
+* Fri Jun 21 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.7.20190620gita5aa0c6
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-06-20-a
+* Thu Jun 20 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.6.20190619git500333c
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-06-19-a
+* Thu Jun 20 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.5.20190619git500333c
+- Cleaned up the spec file to remove 4.2 to 5 migration code and some
+ old patches
+* Mon Jun 17 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.4.20190616gitcbfbc8e
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-06-16-a
+* Sun Jun 02 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.3.20190529git37f230a
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-05-29-a
+* Fri Apr 26 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.2.20190425git6d89fc9
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-04-25-a
+* Thu Apr 18 2019 Ron Olson <tachoknight@gmail.com> 5.1-0.1.20190416git85a776d
+- Updated to swift-5.1-DEVELOPMENT-SNAPSHOT-2019-04-16-a
* Thu Mar 28 2019 Ron Olson <tachoknight@gmail.com> 5.0-0.53.20190325gitba33f9e
- Modified spec file to handle upgrades from 4.2 to 5.0.
* Mon Mar 25 2019 Ron Olson <tachoknight@gmail.com> 5.0-0.52.20190325gitba33f9e