summaryrefslogtreecommitdiffstats
path: root/testsuite/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'testsuite/configure.ac')
-rw-r--r--testsuite/configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/testsuite/configure.ac b/testsuite/configure.ac
index 5166d226..33e06752 100644
--- a/testsuite/configure.ac
+++ b/testsuite/configure.ac
@@ -23,5 +23,17 @@ if test -n "$dejazilla"; then
fi
AC_SUBST(dejazilla)
+apps=
+for exp in $srcdir/systemtap.apps/*.exp
+do
+ app=`basename $exp .exp`
+ apps="$app $apps"
+done
+AC_ARG_ENABLE([testapps],
+ AC_HELP_STRING([--enable-testapps=foo bar or all],
+ [enable rebuilding of large external apps for testing <sdt.h> markers]))
+AC_MSG_NOTICE([Will test ${enable_testapps-no} apps from: $apps])
+AC_SUBST(enable_testapps)
+
AC_CONFIG_FILES(Makefile)
AC_OUTPUT