summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorFrank Ch. Eigler <fche@elastic.org>2008-12-31 14:41:29 -0500
committerFrank Ch. Eigler <fche@elastic.org>2008-12-31 14:41:29 -0500
commite016a49a83276fc061df86b1b4d72ec8c4efdd29 (patch)
tree71b63e6c4c5c36a9061c56db61b3aa6643443f36 /configure.ac
parent57e8bac13b43fa6f84f5fc1925d254f051a789a9 (diff)
downloadsystemtap-steved-e016a49a83276fc061df86b1b4d72ec8c4efdd29.tar.gz
systemtap-steved-e016a49a83276fc061df86b1b4d72ec8c4efdd29.tar.xz
systemtap-steved-e016a49a83276fc061df86b1b4d72ec8c4efdd29.zip
build: make compatible with elfutils 0.138 too
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 13 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 606da4a2..f979f8e4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -223,13 +223,6 @@ AC_LANG_PUSH(C++)
AC_CHECK_HEADERS([tr1/unordered_map])
AC_LANG_POP(C++)
-AC_CONFIG_HEADERS([config.h:config.in])
-AC_CONFIG_FILES(Makefile doc/Makefile doc/SystemTap_Tapset_Reference/Makefile stap.1 stapprobes.5 stapfuncs.5 stapvars.5 stapex.5 staprun.8 stap-server.8 man/stapprobes.iosched.5 man/stapprobes.netdev.5 man/stapprobes.nfs.5 man/stapprobes.nfsd.5 man/stapprobes.pagefault.5 man/stapprobes.process.5 man/stapprobes.rpc.5 man/stapprobes.scsi.5 man/stapprobes.signal.5 man/stapprobes.socket.5 man/stapprobes.tcp.5 man/stapprobes.udp.5)
-AC_CONFIG_SUBDIRS(testsuite)
-
-AC_CONFIG_FILES([run-stap], [chmod +x run-stap])
-
-AC_OUTPUT
if test $build_elfutils = yes; then
case "$with_elfutils" in
@@ -250,10 +243,22 @@ if test $build_elfutils = yes; then
--exec-prefix="$exec_prefix" \
--prefix="$prefix" \
CFLAGS="${CFLAGS/-Wall/}" \
- LDFLAGS="$LDFLAGS $elfutils_rpath"
+ LDFLAGS="$LDFLAGS $elfutils_rpath" &&
+ make install-data # so that elfutils/version.h - if any - may be found.
)
fi
+save_CPPFLAGS=${CPPFLAGS}
+CPPFLAGS="${CPPFLAGS} -Iinclude-elfutils" # in case bundled elfutils
+AC_CHECK_HEADERS([elfutils/version.h])
+CPPFLAGS="$save_CPPFLAGS"
+
+AC_CONFIG_HEADERS([config.h:config.in])
+AC_CONFIG_FILES(Makefile doc/Makefile doc/SystemTap_Tapset_Reference/Makefile stap.1 stapprobes.5 stapfuncs.5 stapvars.5 stapex.5 staprun.8 stap-server.8 man/stapprobes.iosched.5 man/stapprobes.netdev.5 man/stapprobes.nfs.5 man/stapprobes.nfsd.5 man/stapprobes.pagefault.5 man/stapprobes.process.5 man/stapprobes.rpc.5 man/stapprobes.scsi.5 man/stapprobes.signal.5 man/stapprobes.socket.5 man/stapprobes.tcp.5 man/stapprobes.udp.5)
+AC_CONFIG_SUBDIRS(testsuite)
+AC_CONFIG_FILES([run-stap], [chmod +x run-stap])
+AC_OUTPUT
+
if test "${prefix}" = "/usr/local"; then
AC_MSG_NOTICE([])
AC_MSG_NOTICE([For a private or temporary build of systemtap, we recommend])