summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorStan Cox <scox@redhat.com>2010-02-26 14:58:57 -0500
committerStan Cox <scox@redhat.com>2010-02-26 14:58:57 -0500
commitbe709d4c778321de3efc4aadd18af6033ebb932f (patch)
treea0c467bbde41d71a0cacb8b35b97310d62b46620 /configure.ac
parent57a56e00067b4546bb0da15fb00653ee0341f5af (diff)
downloadsystemtap-steved-be709d4c778321de3efc4aadd18af6033ebb932f.tar.gz
systemtap-steved-be709d4c778321de3efc4aadd18af6033ebb932f.tar.xz
systemtap-steved-be709d4c778321de3efc4aadd18af6033ebb932f.zip
Add package check for librpm
* configure (have_librpm): Define. * configure.ac: Regenerate.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 090d8dce..d13255d6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -377,6 +377,8 @@ AC_ARG_WITH([rpm],
[AS_HELP_STRING([--with-rpm],
[query rpm database for missing debuginfos])], [], [with_rpm="auto"])
if test "$with_rpm" != "no"; then
+ PKG_CHECK_MODULES([librpm], [rpm],
+ have_librpm="yes", have_librpm="no")
AC_CHECK_LIB(rpm, rpmtsInitIterator)
if test "x$have_librpm" != "xyes" -a "$with_rpm" == "yes"; then
AC_MSG_ERROR([cannot find librpm])