summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorhunt <hunt>2006-11-09 18:01:31 +0000
committerhunt <hunt>2006-11-09 18:01:31 +0000
commit5566993b4076d586cd681ccfd7007b1aef423fed (patch)
tree42eec6da394ca69dc40fcb15a824b974b2bdea97 /configure.ac
parent68082782a65795f75dcbba4bd2d620c1520e6624 (diff)
downloadsystemtap-steved-5566993b4076d586cd681ccfd7007b1aef423fed.tar.gz
systemtap-steved-5566993b4076d586cd681ccfd7007b1aef423fed.tar.xz
systemtap-steved-5566993b4076d586cd681ccfd7007b1aef423fed.zip
2006-11-09 Martin Hunt <hunt@redhat.com>
* Makefile.am (staprun_CFLAGS): New. Use PROCFLAGS. * configure.ac: Add PROCFLAGS. Processor-dependent compilation flags. * configure: Rebuilt. * Makefile.in: Rebuilt.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0220ccbf..ce797ac9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -114,6 +114,14 @@ date=`date +%Y-%m-%d`
AC_DEFINE_UNQUOTED(DATE, "$date", [Configuration/build date])
AC_SUBST(DATE, "$date")
+processor=`uname -p`
+case "$processor" in
+ppc64) PROCFLAGS=-m64 ;;
+x86_64) PROCFLAGS=-m64 ;;
+*) PROCFLAGS=""
+esac
+AC_SUBST([PROCFLAGS])
+
AC_CONFIG_HEADERS([config.h:config.in])
AC_CONFIG_FILES(Makefile systemtap.spec stp_check stap.1 stapprobes.5 stapfuncs.5 stapex.5 lket.5 lket-b2a.1 runtime/lket/b2a/Makefile testsuite/Makefile man/stapprobes.iosched.5 man/stapprobes.netdev.5 man/stapprobes.nfs.5 man/stapprobes.nfsd.5 man/stapprobes.pagefault.5 man/stapprobes.process.5 man/stapprobes.rpc.5 man/stapprobes.scsi.5 man/stapprobes.signal.5 man/stapprobes.tcp.5 man/stapprobes.udp.5)
AC_OUTPUT
@@ -140,3 +148,4 @@ if test $build_elfutils = yes; then
LDFLAGS="$LDFLAGS $elfutils_rpath"
)
fi
+