summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorFrank Ch. Eigler <fche@elastic.org>2009-08-18 11:37:27 -0400
committerFrank Ch. Eigler <fche@elastic.org>2009-08-18 11:38:31 -0400
commit412e1bf7de63114d4432382a08eb21f1301a241c (patch)
tree8ba488964e9a9f2550ce388a55b3516e9e7fc98e /configure.ac
parente4c3091f27b43a631dfbdb1ada1b121f8e581cd2 (diff)
downloadsystemtap-steved-412e1bf7de63114d4432382a08eb21f1301a241c.tar.gz
systemtap-steved-412e1bf7de63114d4432382a08eb21f1301a241c.tar.xz
systemtap-steved-412e1bf7de63114d4432382a08eb21f1301a241c.zip
elfutils build tweak: run nested configure with bash, add -fgnu89-inline
* configure.ac: Tweak --with-elfutils nested configure invocation. * rest of auto* files: regenerated with fedora-11 tools
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index cd1b01b8..d3cdd227 100644
--- a/configure.ac
+++ b/configure.ac
@@ -550,12 +550,12 @@ if test $build_elfutils = yes; then
elfutils_rpath="-Wl,--enable-new-dtags,-rpath,${libdir}/${PACKAGE_NAME}"
here=`pwd`
(mkdir -p build-elfutils && cd build-elfutils &&
- ${elfutils_srcdir}/configure --enable-libebl-subdir=${PACKAGE_NAME} \
+ bash ${elfutils_srcdir}/configure --enable-libebl-subdir=${PACKAGE_NAME} \
--includedir="${here}/include-elfutils" \
--libdir="${here}/lib-elfutils" \
--exec-prefix="$exec_prefix" \
--prefix="$prefix" \
- CFLAGS="${CFLAGS/-Wall/}" \
+ CFLAGS="${CFLAGS/-Wall/} -fgnu89-inline" \
LDFLAGS="$LDFLAGS $elfutils_rpath" &&
if test -f ${elfutils_srcdir}/config/version.h.in; then
echo Trying to install elfutils version header...